No Gateway on WRT54GL

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

Post Reply
taesen00
Posts: 2
Joined: Sat Jun 12, 2021 6:01 am

No Gateway on WRT54GL

Post by taesen00 »

Hello,

I've installed gargoyle_1.3.9_wrt54g-squashfs.bin on my WRT54GL v1.1, and I was trying to set it up to bridge mode. Shouldn't have done it with a toddler in my lap that likes to press buttons, but settings got sent, router config updated, and I have no idea how to access it now.

There's no Gateway for web access. I've tried guessing the IP, TFTP, and telnet to 192.168.1.1, and no luck with anything . Hard reset button doesn't seem to do anything.

I've tried to do a reset following the directions on
the forum, viewtopic.php?t=840, but I can't make the connection.

Does anyone know a way I can access it or just reset to it to initial settings and start over?

Lantis
Moderator
Posts: 6094
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: No Gateway on WRT54GL

Post by Lantis »

Those instructions are correct.
Failsafe reset is your only option.

There is no support for such an old version, sorry.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

taesen00
Posts: 2
Joined: Sat Jun 12, 2021 6:01 am

Re: No Gateway on WRT54GL

Post by taesen00 »

Lantis,

I guess I just needed some encouragement. Here's an update of what I did based on the instructions posted previously:

1. Poweredt he router and as the DMZ led came on I pressed the reset button till the power & dmz leds were blinking.
- On this one, I pressed it a bunch of times, and not press and hold. Then I stopped pressing it because my hand got tired, and pressed it again, and the Power and DMZ lights started blinking
2. I setup a computer with a static ip of 192.168.1.10 subnet 255.255.255.0 and gateway ip 192.168.1.1
3. logged into the router via telnet with ip 192.168.1.1 and ran the following without the quotes.
4. "mount_root; passwd" keyed in a new password twice (not password)
5. "nvram set"
- Got a segmentation fault on this command
6. "firstboot"
- Kept getting a notice that firstboot had already ran. Based on OpenWRT's failsafe mode directions, tried firstboot && reboot now with no luck. Then tried umount /overlay && jffs2reset && reboot now, and got complaints that /overlay was being used. Then tried dd if=/dev/zero of=/dev/loop0 bs=1M; reboot and got an error that it couldn't find /dev/loop0. Moved on to the next step
7. reboot or power cycle the router.

Once the router powered up I was able to login as 192.168.1.1.

The password WebGUI password was back to password and I can access it again.

RomanHK
Posts: 794
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: No Gateway on WRT54GL

Post by RomanHK »

Turris Omnia with OpenWrt 21.02 - Tested
Linksys WRT3200ACM with Gargoyle 1.13.x
TL-WR1043ND v2 with Gargoyle 1.10.0

http://gargoyle.romanhk.cz custom builds by gargoyle users

Post Reply