add vlan
Moderator: Moderators
Re: add vlan
Hi still no one to incorporate the vlan for gargoyle



Re: add vlan
Hi! VLAN works fine in gargoyle. Use openwrt syntaxis for /etc/config/network.
This code for routers with internal switch thats supports vlan tagging:
This code for x86 systems:
This code for routers with internal switch thats supports vlan tagging:
Code: Select all
config switch
option name 'switch1'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch1'
option vlan '1'
option vid '1'
option ports '5 1 3'
config switch_vlan
option device 'switch1'
option vlan '2'
option ports '6 1t 4'
option vid '102'
option description '4G-MOBILE'
config switch_vlan
option device 'switch1'
option vlan '3'
option ports '1t 2'
option vid '103'
option description 'DVR'
Code: Select all
config device
option type '8021q'
option ifname 'eth0'
option vid '102'
option name 'vlan102-mobile'
config interface 'mobile'
option proto 'static'
option ipaddr '192.168.2.2'
option netmask '255.255.255.0'
option gateway '192.168.2.1'
option metric '15'
option device 'vlan102-mobile'
option ipv6 '0'
config device
option type '8021q'
option ifname 'eth0'
option vid '103'
option name 'vlan103-dvr'
config interface 'dvr'
option proto 'static'
option ipv6 '0'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option device 'vlan103-dvr
Re: add vlan
VLAN for WAN port is on the GUI in the 1.15 beta