Wireless bridge static IP
Moderator: Moderators
Re: Wireless bridge static IP
OK, so that config is in and working but how do I set the Relay IP address to be what I want it to be?
I've used the primary routers static dhcp facility to assign an ip address of 192.168.0.103 to the bridge via the mac address seen by the primary router, rebooted the bridge, but the relay ip address still comes up at 192.168.0.154.
I've used the primary routers static dhcp facility to assign an ip address of 192.168.0.103 to the bridge via the mac address seen by the primary router, rebooted the bridge, but the relay ip address still comes up at 192.168.0.154.
Re: Wireless bridge static IP
The Relay ip can’t be set from the bridge. It is assigned by the AP.
What you are doing is correct. Maybe your bridge has an existing lease with the AP?
If it doesn’t resolve in 12 hours, a reboot of the AP might be wise to flush the cache
What you are doing is correct. Maybe your bridge has an existing lease with the AP?
If it doesn’t resolve in 12 hours, a reboot of the AP might be wise to flush the cache
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: Wireless bridge static IP
You were right. It's where it should be this morning. The 1.9x install looks great on my phone screen.
Thanks for the assistance.
Thanks for the assistance.
Re: Wireless bridge static IP
No worries glad it all came together
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: Wireless bridge static IP
I've manually set a static IP to my wireless bridges (i have two repeaters), if that's any help i'll leave the etc/network cfg below.
Code: Select all
config interface 'lan'
option ifname 'eth1'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.10.1'
option gateway '192.168.1.1'
option dns '192.168.1.1'
config interface 'wwan'
option proto 'static'
option ipaddr '192.168.1.254'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
config interface 'bridgecfg'
option proto 'relay'
option network 'lan wwan'
option ipaddr '192.168.1.254'
TP-Link Archer C7 v2 - Gargoyle 1.12.X
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1
Re: Wireless bridge static IP
set via command line or GUI?d3fz wrote:I've manually set a static IP to my wireless bridges (i have two repeaters), if that's any help i'll leave the etc/network cfg below.
Code: Select all
config interface 'lan' option ifname 'eth1' option force_link '1' option type 'bridge' option proto 'static' option netmask '255.255.255.0' option ipaddr '192.168.10.1' option gateway '192.168.1.1' option dns '192.168.1.1' config interface 'wwan' option proto 'static' option ipaddr '192.168.1.254' option netmask '255.255.255.0' option gateway '192.168.1.1' config interface 'bridgecfg' option proto 'relay' option network 'lan wwan' option ipaddr '192.168.1.254'
Re: Wireless bridge static IP
I've done it via WinSCP, actually. If i change anything via GUI at this point, it will probably override my settings.
TP-Link Archer C7 v2 - Gargoyle 1.12.X
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1
Re: Wireless bridge static IP
That’s a good tip.
I’m not sure it should be added to the UI, but it’s a good advanced use case.
I’m not sure it should be added to the UI, but it’s a good advanced use case.
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: Wireless bridge static IP
Quick question.
I've set up a wireless bridge properly, clients can access the internet with no problem, but when i'm connected through the repeater (wireless/ethernet), i can't access/ping the GUI using the Relay IP.
But if i'm connected to the main router, i can access the repeater GUI using the Relay IP, without a problem.
I also have a very similar setup with another device that's running LEDE (also using relayd), which i can ping (no GUI) normally whenever i'm connected to it.
The only thing that seems to differ from one configuration to another, is the firewall settings, which i haven't touch. They're both default.
Is this the correct behavior when using wireless bridge ?
I've set up a wireless bridge properly, clients can access the internet with no problem, but when i'm connected through the repeater (wireless/ethernet), i can't access/ping the GUI using the Relay IP.
But if i'm connected to the main router, i can access the repeater GUI using the Relay IP, without a problem.
I also have a very similar setup with another device that's running LEDE (also using relayd), which i can ping (no GUI) normally whenever i'm connected to it.
The only thing that seems to differ from one configuration to another, is the firewall settings, which i haven't touch. They're both default.
Is this the correct behavior when using wireless bridge ?
TP-Link Archer C7 v2 - Gargoyle 1.12.X
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1
Re: Wireless bridge static IP
You’re supposed to be able to.
Does the relayd process say it is binding to your Relay ip?
Does the relayd process say it is binding to your Relay ip?
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.