My computer dual boots two differents OS: Windows 7 Professional (64 bit) and Linux Mint 17 (Mate, 64 bit).
The router setup was done in Linux Mint and I managed to get internet through a LAN connection. However, this is not the case when I boot Windows. Moreover, after booting Windows, if I return to Linux, I have to reset the router. Otherwise, I will get no internet at all (the computer will not even communicate with the router without a hard reset).
Furthermore, even when I do have internet in Linux, I lose the connection as soon as I try to connect my phone (Nexus 4) through WiFi.
To sum up, the only time I have an internet connection is when:
1. using Linux;
2. Windows has not been used since the router's last reset; and
3. no devices are connected through WiFi.
Here are my relevant configuration files:
/tmp/dhcp
Code: Select all
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
list server '/.bit/178.32.31.41'
list server '/.bit/78.47.86.43'
list server '/.glue/66.244.95.20'
list server '/.glue/95.211.32.162'
list server '/.glue/95.142.171.235'
list server '/.parody/66.244.95.20'
list server '/.parody/95.211.32.162'
list server '/.parody/95.142.171.235'
list server '/.dyn/66.244.95.20'
list server '/.dyn/95.211.32.162'
list server '/.dyn/95.142.171.235'
list server '/.bbs/66.244.95.20'
list server '/.bbs/95.211.32.162'
list server '/.bbs/95.142.171.235'
list server '/.free/66.244.95.20'
list server '/.free/95.211.32.162'
list server '/.free/95.142.171.235'
list server '/.fur/66.244.95.20'
list server '/.fur/95.211.32.162'
list server '/.fur/95.142.171.235'
list server '/.geek/66.244.95.20'
list server '/.geek/95.211.32.162'
list server '/.geek/95.142.171.235'
list server '/.gopher/66.244.95.20'
list server '/.gopher/95.211.32.162'
list server '/.gopher/95.142.171.235'
list server '/.indy/66.244.95.20'
list server '/.indy/95.211.32.162'
list server '/.indy/95.142.171.235'
list server '/.ing/66.244.95.20'
list server '/.ing/95.211.32.162'
list server '/.ing/95.142.171.235'
list server '/.null/66.244.95.20'
list server '/.null/95.211.32.162'
list server '/.null/95.142.171.235'
list server '/.oss/66.244.95.20'
list server '/.oss/95.211.32.162'
list server '/.oss/95.142.171.235'
list server '/.micro/66.244.95.20'
list server '/.micro/95.211.32.162'
list server '/.micro/95.142.171.235'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
Code: Select all
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config include
option path '/etc/firewall.user'
option reload '1'
config include
option type 'script'
option path '/usr/lib/gargoyle_firewall_util/gargoyle_additions.firewall'
option family 'IPv4'
option reload '1'
config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'
Code: Select all
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option gateway '192.168.1.254'
option dns '192.168.1.254'
config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 3 4'
Code: Select all
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr 'f8:d1:11:83:1c:9e'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
config wifi-iface 'cfg2'
option device 'radio0'
option network 'lan'
option mode 'sta'
option client_bridge '1'
option ssid '[SSID]'
option encryption 'psk2'
option key '[PASSWORD]'
config wifi-iface 'cfg3'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Gargoyle'
option encryption 'psk2'
option key '[PASSWORD]'