ar71xx builds and TP-Link 4300 stock

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

pmerrill
Posts: 285
Joined: Wed Feb 15, 2012 8:23 pm

ar71xx builds and TP-Link 4300 stock

Postby pmerrill » Sat Mar 02, 2013 12:50 am

Use At Your Own Risk

I've compiled the latest ar71xx.usb_large images and zipped them, they can be found below. I've tested an upgrade on a TP-Link 4300 and it worked fine (from another 1.5.9 image). I can't vouch for the other images however.

http://db.tt/zGzhQwsM

In addition, since the latest Gargoyle has problems with some hardware (xBoxes and my wireless HP printer won't connect), I created a revert to stock image as well. It's the latest cut down TP-Link image and worked for me to revert my TP-Link 4300 back to stock from a 1.5.9 install.

http://db.tt/yIdhBXLQ

I am now running stock unfortunately until OpenWRT fixes the xBox problem (ugh).
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

Mr. Henry
Posts: 3
Joined: Wed Feb 20, 2013 2:09 pm

Re: ar71xx builds and TP-Link 4300 stock

Postby Mr. Henry » Sun Mar 03, 2013 1:54 pm

Thanks for your work - can confirm working fine for WDR4300 :)

Also thanks for providing the revert-image.

nchall
Posts: 31
Joined: Thu Dec 02, 2010 2:42 am

Re: ar71xx builds and TP-Link 4300 stock

Postby nchall » Sun Mar 03, 2013 4:43 pm

Thanks very much. Can confirm working for WZR-HP-G300NH2. Just flashed it so if I have any problems I will report back.

nchall
Posts: 31
Joined: Thu Dec 02, 2010 2:42 am

Re: ar71xx builds and TP-Link 4300 stock

Postby nchall » Sun Mar 03, 2013 5:54 pm

Any chance you could post the Mar 1st builds for the WHR-HP-G300N?

pmerrill
Posts: 285
Joined: Wed Feb 15, 2012 8:23 pm

Re: ar71xx builds and TP-Link 4300 stock

Postby pmerrill » Mon Mar 04, 2013 6:02 am

Ok two files now

ar71xx.usb_large (4300 is in this one)
http://db.tt/bqQdB8Tt

ar71xx (whr-hp-g300n among others)
http://db.tt/zGzhQwsM

As stated before, use at your own risk.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

nchall
Posts: 31
Joined: Thu Dec 02, 2010 2:42 am

Re: ar71xx builds and TP-Link 4300 stock

Postby nchall » Mon Mar 04, 2013 10:47 am

Thanks so much. Will flash and report back with any issues.

nchall
Posts: 31
Joined: Thu Dec 02, 2010 2:42 am

Re: ar71xx builds and TP-Link 4300 stock

Postby nchall » Mon Mar 04, 2013 11:45 pm

Must have been some changes in the ath9k driver because everything is working great now with WDS. Thanks again for the build.

Slacker
Posts: 55
Joined: Mon Aug 20, 2012 2:00 pm

Re: ar71xx builds and TP-Link 4300 stock

Postby Slacker » Wed Mar 06, 2013 2:38 pm

Successful flash on a 1043nd 1.7.
Unfortunately, it looks like the 1mbit/packet-loss/disable_ani bug still exists, except that now no error is logged. :roll:

Heads up on possible WAN port instability. I'd lose connection and could not ping the gateway several times per day since the flash.
This could've been due to my crappy ISP, so I flashed back to 1.5.6 but got a different gateway now...

I'm staying at 1.5.6 until I no longer experience wifi troubles...

8hours
Posts: 4
Joined: Sat Dec 29, 2012 5:49 pm

Re: ar71xx builds and TP-Link 4300 stock

Postby 8hours » Tue Apr 02, 2013 10:55 am

Hello,


I have also run into problems connection to an Epson printer. I guess its related to the xBox / HP printer problem you mentioned.

sorry to ask again, but Im not sure. does this build fix the problem?

I also reverted my WDR3600 to stock firmware btw. I downloaded the image from the official page and could revert using the gargoyle web interface

pmerrill
Posts: 285
Joined: Wed Feb 15, 2012 8:23 pm

Re: ar71xx builds and TP-Link 4300 stock

Postby pmerrill » Tue Apr 02, 2013 8:16 pm

Possibly. I notice that the latest DD-WRT allows me to connect to my HP Printer, so am now using that. There is a possibility that since DD-WRT and Gargoyle use the same OpenWRT drivers (can anyone confirm?) the latest build of Gargoyle + latest OpenWRT will also fix the problem, but I guess you'd need to try that one.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: Google [Bot] and 4 guests