Is WR1043ND-V4 supported?

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

cwswpl
Posts: 21
Joined: Tue Dec 06, 2016 2:22 am
Location: Australia

Is WR1043ND-V4 supported?

Post by cwswpl »

I have a factory TP Link WR1043ND-V4 that I bought about a year ago, intending to install Gargoyle before I realised it wasn't supported on this newer model.

Does the latest Gargoyle 1.10.0 support this model yet? The list of supported routers still only mentions V2 and V3 with caveats, but surely V4 must be widely in circulation by now?

Sorry if this question has been asked before, but the forum won't let me search on the model number because it is "too common".

Cheers

d3fz
Posts: 269
Joined: Sun Aug 28, 2016 7:34 pm

Re: Is WR1043ND-V4 supported?

Post by d3fz »

cwswpl wrote:Does the latest Gargoyle 1.10.0 support this model yet? The list of supported routers still only mentions V2 and V3 with caveats, but surely V4 must be widely in circulation by now?

Unfortunately, not yet. Not until Gargoyle moves to LEDE, which may take a while. LEDE offers full support, though.
TP-Link Archer C7 v2 - Gargoyle 1.12.X
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1

Sgt-Greco
Posts: 21
Joined: Thu Sep 28, 2017 9:28 am

Re: Is WR1043ND-V4 supported?

Post by Sgt-Greco »

Same here. Desperately waiting for a support.
TBH I have lost hope.
Is there a step by step guide to compile source code for this router?

Lantis
Moderator
Posts: 5528
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Is WR1043ND-V4 supported?

Post by Lantis »

You can start here
https://www.gargoyle-router.com/wiki/do ... umentation

But if you’ve never done this stuff before you won’t get Gargoyle working for the v4.
It is not trivial.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

cwswpl
Posts: 21
Joined: Tue Dec 06, 2016 2:22 am
Location: Australia

Re: Is WR1043ND-V4 supported?

Post by cwswpl »

OK, thanks I'll keep an eye on progress. In the meantime, I'd better get another router that will work with Gargoyle.

I gathered from the forums that the WR1043ND was a recommended model last year, but the V2 and V3 are very hard to find now, which is how I ended up with a V4.

What other brand/model routers are commonly used and known as reliable by the Gargoyle community - preferably available in Australia?

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Is WR1043ND-V4 supported?

Post by ispyisail »


cwswpl
Posts: 21
Joined: Tue Dec 06, 2016 2:22 am
Location: Australia

Re: Is WR1043ND-V4 supported?

Post by cwswpl »

Thanks ispy, I've had a look and it's good to see they are being promoted as open source ready. But they are not on the Gargoyle list, is that out of date?

https://www.gargoyle-router.com/wiki/do ... ed_routers

Looks like the 1200AC models are cheap enough on ebay, I'm not particularly concerned with top wifi speed as the house is most cabled ethernet. Any other reason why I should consider a higher model?

I notice Linksys have download page and that OpenWRT have a section called "Official Linksys OEM Firmware"

https://www.linksys.com/us/support-arti ... Num=114663

I'm confused about what these are, is that the factory firmware, or does linksys also contribute to the OpenWRT project?

My understanding is that OpenWRT is the router engine, and Gargoyle is built on top of that as the web management interface, have I got that right?

The linksys looks good, but will I be able to go to the Gargoyle download page and follow the process and get it to work? Those models don't seem to be mentioned in the docs.

Thanks again.

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Is WR1043ND-V4 supported?

Post by ispyisail »

Image

Image

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Is WR1043ND-V4 supported?

Post by ispyisail »

Wiki is out of date

Openwrt/Gargoyle at a basic level are the same

Use openwrt instructions

Lantis
Moderator
Posts: 5528
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Is WR1043ND-V4 supported?

Post by Lantis »

You’re correct about Openwrt and Gargoyle.
Linksys do not contribute to either one.

The 1200 is a nice bit of gear but I would recommend the 1900AC V1. It is the oldest and most stable (in my opinion) and has a cooling fan which helps stability.
Should find one of them pretty cheap.


I personally make sure the wrt series are supported as I own a lot of them. Download are available from the site.
No that list is not necessarily up to date.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply