IMQ@NAT kernel modul issue

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

Lantis
Moderator
Posts: 5590
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: IMQ@NAT kernel modul issue

Post by Lantis »

This execution path doesn’t exist in the new patch, please trace it out.
This occurred because in the old patch it also returned 0 so no error.
Now it will either return success or failure, not both.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

RomanHK
Posts: 623
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: IMQ@NAT kernel modul issue

Post by RomanHK »

Brings the first build test results from your repository. Perfect ;) .

Linksys WRT3200ACM = (10x restart without QoS, 20x restart with QoS) = O.K.
Turris Omnia = (5x restart without QoS, 20x restart with QoS) = O.K.

I already see success because you managed to get NAT first and then IMQ as needed. Good job +1.

I will continue to test and report any changes here. Thank you.
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

Lantis
Moderator
Posts: 5590
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: IMQ@NAT kernel modul issue

Post by Lantis »

Thanks. I’ll wait a bit longer but then will probably push that fix through.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

tester
Posts: 15
Joined: Wed May 08, 2019 4:15 pm

Re: IMQ@NAT kernel modul issue

Post by tester »

Lantis wrote:It doesn't load at boot, but loads when needed.


Is it just 46-ipt-imq removed or there is something else?

Lantis
Moderator
Posts: 5590
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: IMQ@NAT kernel modul issue

Post by Lantis »

That’s all
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

User avatar
CBx86
Posts: 140
Joined: Sun Jan 05, 2014 5:43 pm
Location: Brazil

Re: IMQ@NAT kernel modul issue

Post by CBx86 »

Hey guys! How are you doing? :D

Just update to 1.12.0@NETGEAR WNDR4300.

Set lan ip, masq, config QoS, pppoe, wifi and reading the log:

rmmod: module is not loaded


No warm?

Many thanks!

RomanHK
Posts: 623
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: IMQ@NAT kernel modul issue

Post by RomanHK »

Greetings also ...
I don't have such reports. When I searched the net, I found that this command was deleting kernel modules - I suppose it's harmless ( https://linux.die.net/man/8/rmmod ).
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

Lantis
Moderator
Posts: 5590
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: IMQ@NAT kernel modul issue

Post by Lantis »

There is no problem
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

User avatar
CBx86
Posts: 140
Joined: Sun Jan 05, 2014 5:43 pm
Location: Brazil

Re: IMQ@NAT kernel modul issue

Post by CBx86 »

Many Thanks, Guys!

Have a nice week. :D

Post Reply