gargoyle-ispy 2017-December-22 08:13

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

balqosz
Posts: 2
Joined: Mon Feb 27, 2017 12:01 am

Re: gargoyle-ispy 2017-December-22 08:13

Postby balqosz » Sun Dec 24, 2017 3:27 pm

Hi!

There is something that is not clear for me.
In the 1st post it says not to install on 4MB routers. My router es TPLINK WR741ND hw. version 4.20, with 4 MB flash in theory.
But inside the .7z file and in the routers listings, I see my model listed there. In the 7z file, these two files:

gargoyle_1.10.x-ar71xx-generic-tl-wr741nd-v4-squashfs-sysupgrade

gargoyle_1.10.x-ar71xx-generic-tl-wr743nd-v1-squashfs-factory

In my TPLink WR741ND v4 I'm currently on Gargoyle 1.92.. Can I upgrade to version 1.10 using one of those files? Which one?

Thank you!!

Lantis
Moderator
Posts: 5097
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2017-December-22 08:13

Postby Lantis » Sun Dec 24, 2017 4:10 pm

If you want to, sure. Stability is not guaranteed. We already don’t recommend 1.9.2 so moving to 1.10.x is no better/worse for you
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

dieselz
Posts: 40
Joined: Fri Jun 07, 2013 3:39 am
Contact:

Re: gargoyle-ispy 2017-December-22 08:13

Postby dieselz » Mon Dec 25, 2017 6:38 am

Hey guys,

i really need your help with something.
i have Netgear WNDR4300 v1
it hasn't been functioning properly for a while specifically the congestion control. usually when that used to happen with other routers i'd clear the nvram and all would be hunky dory but, for this one here; when i boot it into recovery and attempt to access it telnet, it doesn't respond. the only thing i could do from there is DDWRT tftp tool to flash an image.
and the first boot command when i do it from ssh connection it doesn't do anything!
i am not sure if this is a common thing for nanad or what but, i really need an advice.

Thanks.
TP-Link WDR4300 H/W Rev.1.6 Gargoyle-iSpy 1.9.x / Netgear WNDR4300 Gargoyle-iSpy 1.9.x

d3fz
Posts: 267
Joined: Sun Aug 28, 2016 7:34 pm

Re: gargoyle-ispy 2017-December-22 08:13

Postby d3fz » Mon Dec 25, 2017 11:53 am

dieselz wrote:and the first boot command when i do it from ssh connection it doesn't do anything!

Did you try a failsafe reset? Since you mentioned issuing "firstboot" through SSH, I guess so. Repeat the same process, but this time issue "firstboot -y", and see if it works.
TP-Link Archer C7 v2 - Gargoyle 1.10.X
TP-Link WR842ND v2 - Gargoyle 1.10.X
TP-Link RE450 AC v2 - Stock FW 1.0.4
TP-Link WA850RE v1.2 - LEDE 17.01.1

Tired of Chrome? Try Vivaldi - an advanced browser built for power users

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Mon Dec 25, 2017 3:51 pm

Hi all,

it looks like I've got a new problem with this build. I did update from 1.10.0 on an Archer C7 V2, preserving settings as always. This is the main router, connected to a VDSL 50 line. Surfing the net is working flawlessly, but I no longer have access to the USB storage that is attached to the router. I have a Toshiba Canvio Basics 2TB 2,5" drive connected, and "CIFS/FTP Anonymous Access: read/write" set for a share. This used to work, but now I can only view the top level directory whereas accessing any file or folder therein results in a "access denied" message. This is with Samba (CIFS) clients, both windows (XP and 7) and Android. Android asks for credentials, but neither "anonymous" nor "admin" with or without password work.

Code: Select all

df
/dev/sda1            1903500112 211532216 1595252592  12% /tmp/share_home/anonymous/PUBLIC

ls -l /tmp/share_home/anonymous/PUBLIC
drwx------    3 admin    admin         4096 Jan  2  2009 osm
-rwx------    1 admin    admin      9908517 Aug  6  2009 sew.pdf
(just two examples iut of a longer list)

ls -l /tmp/share_home/anonymous/PUBLIC/osm
drwx------    2 admin    admin         4096 Jan 17  2011 Archiv
-rwx------    1 admin    admin        21207 Apr  9  2009 FRIEDHOF_Ahornberg.GPS
(So from within webshell the subfolders are accessible)


There is one message in logread that might be related:

Code: Select all

Mon Dec 25 20:13:17 2017 daemon.warn rpc.statd[4919]: Running as root.  chown /var/lib/nfs to choose different user


Help? Troubleshooting advice (apart from "failsafe reset")?

Merry Christmas,

Ektus.

ispyisail
Moderator
Posts: 4655
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: gargoyle-ispy 2017-December-22 08:13

Postby ispyisail » Mon Dec 25, 2017 4:50 pm

preserving settings as always


I also tried upgrading from 1.10.0 to this version via preserving settings and bad things happeded

reset fixed all the problems?

Lantis
Moderator
Posts: 5097
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2017-December-22 08:13

Postby Lantis » Mon Dec 25, 2017 5:01 pm

Which version did it last work with?
I fixed some share issues in the last few months
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Mon Dec 25, 2017 5:15 pm

Lantis wrote:Which version did it last work with?
I fixed some share issues in the last few months

It works with 1.10.0. I just confirmed it by downgrading to that version, again preserving settings.

It's a very basic share, no passwords or users apart from the default anonymous, with full access from the local network. It has been installed just a couple months ago, replacing a 10+ year old dedicated NAS.

Regards
Ektus.

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Mon Dec 25, 2017 5:25 pm

ispyisail wrote:
preserving settings as always


I also tried upgrading from 1.10.0 to this version via preserving settings and bad things happeded

reset fixed all the problems?

Could you please point me to a document somewhere which tells the specific settings that are incompatible? I'd rather not setup from scratch.

Are there any attempts at adding version information to the config files, thus enabling the router to void any incompatible settings during update while keeping the rest?

For me, any update process that involves re-configuring the device is a bad process. It costs every user time to implement, and leads to bad acceptance of updates.

Regards
Ektus.

ispyisail
Moderator
Posts: 4655
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: gargoyle-ispy 2017-December-22 08:13

Postby ispyisail » Mon Dec 25, 2017 5:54 pm

Could you please point me to a document somewhere which tells the specific settings that are incompatible? I'd rather not setup from scratch.


I agree it should have worked

I was just my experience.............

The upgrade system has never been that good. Eric never wanted to add it but people insisted...........


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 3 guests