Gargoyle NAT 'leaking' port 443?

Report wireless and/or network connectivity problems in this forum.

Moderator: Moderators

roadhawk
Posts: 14
Joined: Fri Feb 26, 2016 5:37 am
Location: Germany

Re: Gargoyle NAT 'leaking' port 443?

Post by roadhawk »

I just loaded OpenWRT Chaos Calmer 15.05 onto a TP-Link TL-WR1043N/ND v1 and configured only wifi encryption.

Exactly the same thing happens.

Tomorrow, stock firmware . . . stay tuned.

roadhawk
Posts: 14
Joined: Fri Feb 26, 2016 5:37 am
Location: Germany

Re: Gargoyle NAT 'leaking' port 443?

Post by roadhawk »

Latest TP-Link stock firmware on a TP-Link TL-WR1043N/ND v1.
An overnight test showed no leakage.

So, to summarize:

- Gargoyle 1.9.x : Leak
- OpenWRT 15.05 : Leak
- TP-Link TL-WR1043ND_V1_140319 : Clean

I'm thinking more in terms of a kernel issue than a missing iptables rule.

I suppose the next step would be to try BarrierBreaker and then possibly a DesignatedDriver snapshot. I can see my router getting bricked this week.

nworbnhoj
Posts: 914
Joined: Mon Jul 21, 2014 10:08 am
Location: Australia
Contact:

Re: Gargoyle NAT 'leaking' port 443?

Post by nworbnhoj »

@roadhawk I think that it is worth posting your findings over on the openwrt forum as the solution will need to be identified and resolved in openwrt before Garoyle users can see the fix.
Can you help someone else get Gargoyle up and running?
TL-WDR3600 : Gargoyle 1.9.0 : NBN FixedWireless
TL-WR1043ND-V2 : Gargoyle 1.8.0 : 3G Huawei E160E

roadhawk
Posts: 14
Joined: Fri Feb 26, 2016 5:37 am
Location: Germany

Re: Gargoyle NAT 'leaking' port 443?

Post by roadhawk »

OpenWRT BarrierBreaker : Leak
OpenWRT DesignatedDriver : CLEAN

Sorted. So all we have to do is wait.

Lantis
Moderator
Posts: 5758
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle NAT 'leaking' port 443?

Post by Lantis »

Interesting.
Most likely to do with a kernel change.
There are rumours that CC 15.05.1 (maintenance update) will be based on Kernel 4.4 (which DD uses).
I think it is more likely that it will use 3.18.27.
For reference, gargoyle uses 3.18.23.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

sigwx
Posts: 61
Joined: Fri Oct 23, 2015 4:14 am

Re: Gargoyle NAT 'leaking' port 443?

Post by sigwx »

Well, looks like 15.05.1 will have 3.18.23 if I'm reading the OpenWRT front page correctly...?

Lantis
Moderator
Posts: 5758
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle NAT 'leaking' port 443?

Post by Lantis »

Correct, but since then, the CC branch has been pushed to 3.18.27.
Just isn't part of any official release.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

tapper
Moderator
Posts: 1071
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Gargoyle NAT 'leaking' port 443?

Post by tapper »

3.18.23 has a bug in witch will put some devices in a bootloop
Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

Post Reply