Version 1.14.0: Based on OpenWrt 22.03

The latest news about Gargoyle

Moderator: Moderators

smoke_15
Posts: 24
Joined: Tue Oct 22, 2013 9:23 pm
Location: California

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by smoke_15 »

Sorry yes I missed that. No worries, the 1.12 is pretty solid for now.

Though with support for newer platforms, would be great to hear if there are better routers (vs say wrt3200 acm) that are recommended now with this release (and with future releases).

As good as the specs on the wrt3200/wrt1900 are, I understand gargoyle doesn't have native hardware support for the chipset and its not possible to tweak the transmit power (it's max by default).

runner75
Posts: 16
Joined: Sat Nov 28, 2015 4:00 pm
Location: Venezuela

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by runner75 »

Thanks for the update. Channel 13 can be activated? Any way to change the region?
My Net WD750

Lantis
Moderator
Posts: 6851
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by Lantis »

If it is legal to do so in your country, yes you can use channel 13.
You can set the country code in Connection->Advanced
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

runner75
Posts: 16
Joined: Sat Nov 28, 2015 4:00 pm
Location: Venezuela

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by runner75 »

Lantis wrote:
Wed Jun 07, 2023 3:35 am
If it is legal to do so in your country, yes you can use channel 13.
You can set the country code in Connection->Advanced
In Venezuela legal use channel 13. Thanks.

Apart I noticed that the wifi connection is slow. I have also noticed that the WD My Net 750 does not get along well with the latest versions of OpenWRT based on the 22.0 branch
My Net WD750

heilbronn
Posts: 28
Joined: Sun Apr 17, 2022 8:52 am
Location: Germany

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by heilbronn »

I would like to give two feedbacks on 1.14.0:

1) I managed to successfuly install it on my **GL.iNet GL-AR150**!
Used it a little as a Wifi repeater. No problems so far! :D

2) However, I was not successful with my TP-Link TL-WR710N V2.1 (a 8/32 MB device). It always settles into "steady blinking about 2-3 times per second". Pings to 192.168.1.1 (own address set without DHCP) are replied to most of the time some time after booting, but then often fail again after some minutes. SSH and HTTP access always fail. Unfortunately, I have not yet managed to recover the device. :(

Could it be that 32MB RAM is not enough for Gargoyle 1.14?!
How can I help debugging? Does anybody have any ideas?
I have more TL-WR710N devices but wouldn't like to brick them unnecessarily...

Thanks for your good work!

heilbronn
Posts: 28
Joined: Sun Apr 17, 2022 8:52 am
Location: Germany

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by heilbronn »

heilbronn wrote:
Fri Jun 09, 2023 6:05 pm
...
2) However, I was not successful with my TP-Link TL-WR710N V2.1 (a 8/32 MB device). It always settles into "steady blinking about 2-3 times per second". Pings to 192.168.1.1 (own address set without DHCP) are replied to most of the time some time after booting, but then often fail again after some minutes. SSH and HTTP access always fail.
...
Could it be that 32MB RAM is not enough for Gargoyle 1.14?!
Would it help finding the problem to experimentally compile 8/32 MB devices without support for some RAM hogs/with stripped down kernel modules {OpenVPN, Wireguard, ....}?

Lantis
Moderator
Posts: 6851
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by Lantis »

A boot log would be interesting. This may require a serial connection to view.

If you can get it, please open another thread and we will dig into it.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

ArcticCat
Posts: 16
Joined: Wed Nov 23, 2016 6:45 pm

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by ArcticCat »

I have an archer C7 v5 (EU) version i've been running different versions of Gargoyle for years without issues

now when I try to upgrade to the 1.14 i am getting a warning that it firmware is not compatible

can I safely ignore this warning and "force upgrade" ?

Code: Select all

Firmware has been detected as incompatible with this device
Last edited by ArcticCat on Sat Jun 10, 2023 3:20 pm, edited 1 time in total.

heilbronn
Posts: 28
Joined: Sun Apr 17, 2022 8:52 am
Location: Germany

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by heilbronn »

Lantis wrote:
Fri Jun 09, 2023 6:55 pm
A boot log would be interesting. This may require a serial connection to view.

If you can get it, please open another thread and we will dig into it.
1. I ordered this UART USB-to-TTL adapter and will see what I can do with the TL-WR710N. Do you have a recommendation about which instruction to follow?
2. Which part of the forum shall I follow up to:
Gargoyle Development?

RadioOperator
Posts: 4
Joined: Mon Oct 31, 2022 1:09 pm

Re: Version 1.14.0: Based on OpenWrt 22.03

Post by RadioOperator »

I've downloaded the latest source code, and one-take pass the compiling. Then, I got the version no. is 1.15.x.

There is no bin Fw for Xiaomi-4C router, I try to install Xiaomi-4A-100m fw into my 4C, everything seems ok.

Many thanks to you all, not easy.

Post Reply