Successfully flashed a router? Tell Us!

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: Successfully flashed a router? Tell Us!

Postby sodapopdima » Thu Jun 16, 2011 1:49 pm

After much trial and error, successfully flashed

Linksys wrt150n v1.1
Gargoyle version 1.3.9 (higher versions lose wireless)

Linksys wrt350n v1
Gargoyle version 1.3.9 (higher versions brick the router bad, need serial for recovery)

All flashes done from a dd-wrt changeover from stock Linksys firmware.

Progman
Posts: 4
Joined: Fri Sep 16, 2011 8:24 am

Re: Successfully flashed a router? Tell Us!

Postby Progman » Fri Sep 16, 2011 3:17 pm

Successfully flashed TP-Link TL-MR3220 v1.2 by Gargoyle 1.5.x.
Attachments
Gargoyle.jpg
Gargoyle installed on the TP-Link TL-MR3220
Gargoyle.jpg (132.39 KiB) Viewed 13319 times

User avatar
Urgje
Posts: 45
Joined: Fri Sep 02, 2011 4:32 am
Location: The Netherlands

Re: Successfully flashed a router? Tell Us!

Postby Urgje » Tue Sep 20, 2011 8:00 am

Succesfully installed on a Netgear WNDR3700v2 with version 1.4.0, using
gargoyle_1.4.0-ar71xx-wndr3700v2-squashfs-factory.img.

Later succesfylly updated to version 1.4.2 using
gargoyle_1.4.2-ar71xx-wndr3700v2-squashfs-sysupgrade.bin

Before you update Gargoyle though, backup your settings, because the firmware update will result in a router with default settings. Restoring the backup worked just fine.
Urgje (Netgear WNDR3700v2 / Gargoyle 1.4.7)
[my ego shrank while growing up]

bru2haBR
Posts: 2
Joined: Sat Sep 24, 2011 5:56 pm

Re: Successfully flashed a router? Tell Us!

Postby bru2haBR » Sat Sep 24, 2011 6:17 pm

Successfully flashed Fon+ 2201C-UK with 1.4.2.

Had to use serial-to-usb cable on internal pins.

Some hiccups while installing.

Had to adjust flashing of size of rootfs (note change in -l value)

Code: Select all

fis create -b 0x80040450 -f 0xA8030000 -l 0x006E0000
      -e 0x00000000 rootfs

Error message "Can't locate d0000(851968) bytes free in FLASH"

Also, on rebooting Redboot would fail with message "No image ‘loader’ found".
Had to modify Redboot config to load new kernel:

Code: Select all

Redboot> fconfig
>>fis load -l vmlinux.bin.l7
>>exec
>><press enter>

skysurf76
Posts: 14
Joined: Thu Mar 24, 2011 9:43 pm

Re: Successfully flashed a router? Tell Us!

Postby skysurf76 » Sat Oct 08, 2011 3:27 pm

Flashed a WR841ND v7.1 router with gargoyle_1.4.2-ar71xx-tl-wr841nd-v5-squashfs-factory.bin and it works just fine.

So the version 7's of the WR841ND will work just fine with the gargoyle firmware made for the version 5's.

pier4r
Posts: 4
Joined: Sat Oct 08, 2011 3:32 pm

Re: Successfully flashed a router? Tell Us!

Postby pier4r » Sat Oct 08, 2011 5:44 pm

tp link wr741nd v2.4
gargoyle 1.4.0 r27980

succesful.

Only 2 flaws so far (maybe for my fault):
1. i can't execute not preesistent scripts.
2. if i reboot the router, it freeze. I ned to unplug the power and replug it to get the router back to work.


edit: no, it's all ok, these flaws are caused by me.

mesquito
Posts: 2
Joined: Sun Sep 25, 2011 2:58 am

Re: Successfully flashed a router? Tell Us!

Postby mesquito » Thu Oct 13, 2011 12:04 am

Installed 1.3.1 on Engenius EOC-1650 with no problems.
Devices are running great after 2 weeks in service.

Tried 1.4.2 and the flash keeps failing.

neftv
Posts: 1
Joined: Fri Oct 14, 2011 12:17 pm

Re: Successfully flashed a router? Tell Us!

Postby neftv » Fri Oct 14, 2011 12:30 pm

I am new to this forum. I wanted to let you know I successfully flashed with version 1.4.2 on my ASUS wl-520gu.
Summary of observations..
-basic router functions working
-Wifi working it seems but the wifi LED not on.
-I don't see the USB access for file sharing and ftp and such.
But otherwise this looks good.
Seems light on the router but any changes you make it reboots the system and I lose connectivity for a brief moment.

Thanks for making this available it was fun to play with.

TDSP
Posts: 1
Joined: Tue Oct 25, 2011 4:33 pm

Re: Successfully flashed a router? Tell Us!

Postby TDSP » Tue Oct 25, 2011 4:41 pm

Successfully installed on an EnGenius ECB3500

I figured out it was an Athertos Chipset, I used FonFlash and I got 1.42 to work. Simple, painless and took me less than an hour once I did my research.

I'm working on a better tutorial for the forums I am on that I will share here. This is a POWERFUL router, I'm getting quarter mile ranges out of one of the three I've installed since I figured this out last week.

I'd like to thank everyone who developed this branch of the code for being an AWESOME alternative to the pay for play DD-WRT firmware EnGenius recommends.

Kline
Posts: 8
Joined: Sat Oct 29, 2011 9:27 pm

Re: Successfully flashed a router? Tell Us!

Postby Kline » Sat Oct 29, 2011 9:32 pm

Two successful installs on Netgear WNDR3700v1 (USA).

One came from stock the other from DD-WRT. Stock I was able to flash with the factory-NA image via web upgrade while the DD-WRT one I had to place into recovery mode (unplug, hold reset, plug in, release reset once power light blinking) and TFTP over the factory-NA image.

Used: gargoyle_1.4.3-ar71xx-wndr3700-squashfs-factory-NA

Also upgraded the prior DD-WRT one to:
gargoyle_1.5.0-ar71xx-wndr3700-squashfs-sysupgrade

Without issue after flashing the above 1.4.3; did a full backup/restore of settings and everything worked great there too.


Return to “Hardware / Installation Issues”

Who is online

Users browsing this forum: No registered users and 4 guests