Successfully flashed a router? Tell Us!

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

maphew
Posts: 17
Joined: Tue Oct 13, 2015 3:10 am

Re: Successfully flashed a router? Tell Us!

Post by maphew »

TP Link Archer C7(US) AC1750 v3
P/N: 050502189

Firmware Version:
3.14.3 Build 150508 Rel.42275n
Hardware Version:
Archer C7 v3 00000000

Image: gargoyle_1.9.1-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

Provisional success. Worked for an hour after firmware flash and then lost WAN . Power cycle fixed but too early to tell if it is stable now (12 hrs ok). I'll keep this thread updated with my experience:
viewtopic.php?f=8&t=10744

cosylemonade
Posts: 3
Joined: Sun Jan 22, 2017 7:54 pm

Re: Successfully flashed a router? Tell Us!

Post by cosylemonade »

Thanks to the steps provided by bradysquirrel in the TL-WR1043ND V3 thread, I successfully flashed a WR1043ND v3 I just picked up from Newegg for a little over $40. I had to find Windows equivalent tools such as Tftpd32, Putty, and WinSCP to follow the steps. Tftpd32 had a nice easy front-end that also displayed a progress bar on the file transfer when it was picked up by the router.
All features seem to be working well.

I'm primarily using Gargoyle to regulate bandwidth since we live in the country and have very limited data and I have a 12 year old that absolutely doesn't care. The monitoring is fantastic and the quotas have brought peace to the house since we no longer have to stare at it all of the time and regulate and harp on the boy. When his quota is used up, he gets dial-up speed... heh.

Thanks to all!

MrWU
Posts: 1
Joined: Sat Jan 28, 2017 6:35 am

Re: Successfully flashed a router? Tell Us!

Post by MrWU »

On netgear WNDR3700 v3 (broadcom 47xx chip) installation work fine on 1.8 (direct from open WRT 15.05) and also upgrading to 1.9.1.
however some function don't work properly

computerquip
Posts: 1
Joined: Sun Feb 05, 2017 11:43 pm

Re: Successfully flashed a router? Tell Us!

Post by computerquip »

  • Router - Linksys WRT1900ACS (version 2)
  • Gargoyle Build - 1.9.X (Built 20170126-0747 git@ff413a5)
  • Gargoyle Image - gargoyle_1.9.1-mvebu-armada-385-linksys-shelby-squashfs-factory.img

Initially tried DD-WRT. WAN (labeled "Internet" on the router) port didn't work. Could not change router local address without issues with the web UI. Also couldn't change what addresses DHCP server provided without the web server refusing my connections as well. All connections to the router didn't work during this time but I somehow was able to access the router behind it and could access internet. Never figured it out.

I reverted from DD-WRT to stock via Kong's DD-WRT to factory images. From there I updated firmware to latest version 2 factory firmware then flashed Gargoyle which worked out of the box without any problems for at least one day now.

xzxt9q
Posts: 7
Joined: Tue Jan 31, 2017 11:20 pm

Re: Successfully flashed a router? Tell Us!

Post by xzxt9q »

Successful installation on:
Router - SKIVA RT001 (Ralink rt3352F)
Gargoyle Build Version: 1.9.X (Built 20170207-1528 git@cfe11db)
Gargoyle Image : [D-Link DIR-620 D1] - gargoyle_1.9.x-ramips-rt305x-dir-620-d1-squashfs-sysupgrade.bin

This router is acceptable for low speed broadband (DSL). I am using it as AP and print server. Thanks to this forum for helping me get this working.

westapher317
Posts: 2
Joined: Tue Feb 28, 2017 2:34 pm

Re: Successfully flashed a router? Tell Us!

Post by westapher317 »

Successfully flashed a TL-WR1043ND V2.1 with 1.9.2. It was an upgrade from 1.8.1, and I didn't try to preserve any settings.

Only issue I have noted is that the WiFi on/off button does not work. This was an issue with 1.8.0 (see the 1.8.X series changelog for documentation), but in that case the WiFi button was functioning as a duplicate power button, and reset the whole device; this error was fixed in 1.8.1. Now, the WiFi on/off button simply does not appear to do anything when pressed - even held for 30 seconds or more.

I assume it is a similar bug. Would appreciate a fix.

Lantis
Moderator
Posts: 5521
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Successfully flashed a router? Tell Us!

Post by Lantis »

If you think it should return to resetting the device, I can look into why that changed.

If you want it to turn on and off the wifi, that is not a default feature.
It has been discussed many times how to enable such functionality manually.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

ngyeah
Posts: 7
Joined: Tue Feb 28, 2017 7:51 pm

Re: Successfully flashed a router? Tell Us!

Post by ngyeah »

TP Link Archer C7 AC1750 v2

Image: gargoyle_1.9.2-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

Successful

alex3137
Posts: 26
Joined: Tue Feb 21, 2017 10:59 am

Re: Successfully flashed a router? Tell Us!

Post by alex3137 »

Successfully flashed a WDR4300 with Gargoyle 1.9.2, very happy so far.

mrpink57
Posts: 36
Joined: Sun Mar 19, 2017 6:42 pm
Location: a van down the river

Re: Successfully flashed a router? Tell Us!

Post by mrpink57 »

Device: Netgear WNR3500L v1

Firmware: gargoyle_1.9.x-brcm47xx-generic-standard-squashfs.trx

So far everything works, this device is setup at my mothers house and I have not gotten a call about her internet being down.

Things I noticed was after a reboot I had to go to the connection/basic page and save the page to get wifi to come up. Also it does not see wireless N and only b+g. And of course usb does not work which was fine.

Her old setup got her maybe 10/1 (use TCP Vegas eek) and with testing with testmy she was averaging 20/3 on new setup.
Last edited by mrpink57 on Mon Mar 20, 2017 8:40 am, edited 1 time in total.

Post Reply