Cannot install to brand new netgear wndr3800

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

Post Reply
SergeS
Posts: 58
Joined: Tue Aug 07, 2012 9:09 pm

Cannot install to brand new netgear wndr3800

Post by SergeS »

Just bought on ebay the router Netgear wndr3800, with native firmware of course :-). Have tried to load Gargoyle 1.6.1 using file gargoyle_1.6.1-ar71xx-generic-wndr3800-squashfs-factory.img - failed :-/...

Have tried also to load older version (gargoyle_1.4.7-ar71xx-wndr3800-squashfs-factory.img) - same story. Did not do any setting on router, nobody has been connected to it besides me, using wired DHCP connection.

Below is what router tells about itself:
Hardware Version: WNDR3800CH
Firmware Version: V1.0.0.51CH
GUI Language Version: V1.0.0.156

Screenshot of failure is here: http://sergeskor.noip.me/Files/garg-failed.PNG

Actually, i am long time user of gargoyle on the netgear wndr3700v2, but i do not remember any special magic passes i've done when first time loading gargoyle... What may be problem, please help.

pbix
Developer
Posts: 1372
Joined: Fri Aug 21, 2009 5:09 pm

Re: Cannot install to brand new netgear wndr3800

Post by pbix »

It seems this WDNR3800CH is a not the same router as a WDNR3800 and requires a new image type to support it. See this post.

https://forum.openwrt.org/viewtopic.php?id=51025

You could perhaps make the changes noted in the post I reference and build your own version of Gargoyle or if you can build OpenWRT trunk including the change referenced in the post and load that on your router and then flash to Gargoyle.

Curse you Netgear.
Linksys WRT1900ACv2
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

SergeS
Posts: 58
Joined: Tue Aug 07, 2012 9:09 pm

Re: Cannot install to brand new netgear wndr3800

Post by SergeS »

pbix wrote:It seems this WDNR3800CH is a not the same router as a WDNR38000 and requires a new image type to support it. See this post.

https://forum.openwrt.org/viewtopic.php?id=51025

You could perhaps make the changes noted in the post I reference and build your own version of Gargoyle or if you can build OpenWRT trunk including the change referenced in the post and load that on your router and then flash to Gargoyle.

Curse you Netgear.


I have seen this post, thank you. But i could not say i have understand what specifically to do, sorry... I am not so familiar with modern gargoyle technologies ;-). And i did not find anything else about wndr3800ch...

Ok, if i will do it once - will i be able to apply the following gargoyle versions without that headache? Or i have to build my own image every time when new version came out?

May i hope the wndr3800ch router will be included in the list of officially supported routers, as far as wndr3800?

SergeS
Posts: 58
Joined: Tue Aug 07, 2012 9:09 pm

Re: Cannot install to brand new netgear wndr3800

Post by SergeS »

SergeS wrote:
pbix wrote:It seems this WDNR3800CH is a not the same router as a WDNR38000 and requires a new image type to support it. See this post.

https://forum.openwrt.org/viewtopic.php?id=51025

You could perhaps make the changes noted in the post I reference and build your own version of Gargoyle or if you can build OpenWRT trunk including the change referenced in the post and load that on your router and then flash to Gargoyle.

Curse you Netgear.


I have seen this post, thank you. But i could not say i have understand what specifically to do, sorry... I am not so familiar with modern gargoyle technologies ;-). And i did not find anything else about wndr3800ch...

Ok, if i will do it once - will i be able to apply the following gargoyle versions without that headache? Or i have to build my own image every time when new version came out?

May i hope the wndr3800ch router will be included in the list of officially supported routers, as far as wndr3800?


I have look at the gargoyle image, it looks like that:
http://sergeskor.noip.me/Files/garg-failed2.PNG

So, if i will change "WNDR3800" to "WNDR3800CH", shifting the rest of text strings there to area with zeros by two extra characters - should it work? Are there any such thing as a checksum?

Are there anybody successfully load openwrt or gargoyle to the router of that type (wndr3800ch)? I did not find any confirmation of that, so my concern is to know hardware is the same in wndr3800 and wndr3800ch?

I did not see any information about netgear wndr3800ch, what the hell this beast is?

pbix
Developer
Posts: 1372
Joined: Fri Aug 21, 2009 5:09 pm

Re: Cannot install to brand new netgear wndr3800

Post by pbix »

I do not know if that will work or not. You can try I suppose.

I advise you to build OpenWRT for your router from trunk. Once you have OpenWRT loaded you should be able to load Gargoyle without problems.
Linksys WRT1900ACv2
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

SergeS
Posts: 58
Joined: Tue Aug 07, 2012 9:09 pm

Re: Cannot install to brand new netgear wndr3800

Post by SergeS »

pbix wrote:I do not know if that will work or not. You can try I suppose.

I advise you to build OpenWRT for your router from trunk. Once you have OpenWRT loaded you should be able to load Gargoyle without problems.


I have never built the gargoyle/opemwrt image, i don't even know how to do it, what software i should have to compile. If someone who did it before will make it for me - i would try and inform the people here. Please, help who could do it.

robnitro
Posts: 84
Joined: Sat Feb 26, 2011 4:50 pm

Re: Cannot install to brand new netgear wndr3800

Post by robnitro »

WNDR3800CH is a charter broadband version of the WNDR3800. I suppose that is why I got it so cheap on ebay, lol.

Just flash the file here first:
https://forum.openwrt.org/viewtopic.php?id=49390
Then you can opkg update
opkg install luci
Log into openwrt luci web interface
Upgrade firmware with the sysupgrade image.

Nekos
Posts: 1
Joined: Sat Sep 06, 2014 12:21 pm

Re: Cannot install to brand new netgear wndr3800

Post by Nekos »

robnitro wrote:WNDR3800CH is a charter broadband version of the WNDR3800. I suppose that is why I got it so cheap on ebay, lol.

Just flash the file here first:
https://forum.openwrt.org/viewtopic.php?id=49390
Then you can opkg update
opkg install luci
Log into openwrt luci web interface
Upgrade firmware with the sysupgrade image.


Thanks, this procedure works fine! Now i have gargoyle 1.6.2 on WDNR3800CH :D

Post Reply