Security

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

Post Reply
lpks
Posts: 1
Joined: Mon Aug 26, 2013 8:27 am

Security

Post by lpks »

Trying to set up wifi hot spots for a cafe. All working on a TPLINK 901v2. OpenWRT and DDWRT both failed, but gargoyle all good. Thanks.

Here's the issue. I cant prevent visitors from accessing the login page. I have a very long strong password but don't feel safe leaving a login available for years ata a time. If I cut web admin, then remote admin is blocked too. Tried using a firewall rule, but it wont block the address.

My current plan is to block both web interfaces once everything is working. I can save a backup and then just reset the wireless units and restore from backup when necessary. It's a hassle, but I think its safe. Is it? Is there another option?

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Security

Post by ericwong »

I think you can simply turn off the web admin http server using SSH.
I don't know what it the command for gargoyle but I know this works for Openwrt.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

homolka
Posts: 14
Joined: Wed Aug 08, 2012 1:55 pm

Re: Security

Post by homolka »

Connect to the router via ssh

Enter the command:
/etc/init.d/uhttpd stop
/etc/init.d/uhttpd disable

On OpenWRT it works

Or change the web interface port, edit the file /etc/config/uhttpd

# Server configuration
config uhttpd main

# HTTP listen addresses, multiple allowed
list listen_http 0.0.0.0:80
# list listen_http [::]:80

# HTTPS listen addresses, multiple allowed
list listen_https 0.0.0.0:443
# list listen_https [::]:443

Post Reply