wrt350N v1 install

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

wrt350N v1 install

Postby sodapopdima » Fri Apr 01, 2011 1:39 pm

Hi, can someone direct me towards a how-to for installing Gargoyle as a single image upgrade on a Linksys wrt350n v1 with current dd-wrt mini pre sp2 currently installed on it.

is it as simple as an upgrade from the Admin panel, tftp, or other process?

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: wrt350N v1 install

Postby DoesItMatter » Sat Apr 02, 2011 6:08 am

gargoyle_1.3.13-wrt350n_v1-squashfs.bin

Grab that image from the download section

Linksys WRT350N
Chipset Broadcom 4785
RAM 32 MB FLASH 8 MB

Broadcom chipsets are fairly easy to back-forth between
Gargoyle and DD-WRT

Best recommendation for steps:

1) download a backup current DD-WRT build you are using
2) backup your current DD-WRT config
3) reset dd-wrt to defaults
4) from dd-wrt GUI - flash the gargoyle.bin image
5) once you start the flash - wait about 5 minutes
6) try to login to 192.168.1.1 - defaull password = password

If you want to go back to dd-wrt

1) backup your current Gargoyle config
2) reset Gargoyle to defaults
3) flash the dd-wrt .bin file that you originally saved above
4) once again - wait about 5 minutes for flash
5) reload your backup config file for dd-wrt

---------------------

I recommend reset to defaults because both DD-WRT & Gargoyle
default the router IP to 192.168.1.1 - this is just in case you
change the standard IP of the router - makes it easier to flash
back/forth and stay connected if you keep the router IP the same.
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: wrt350N v1 install

Postby sodapopdima » Mon Apr 04, 2011 12:35 am

I seem to be encountering some issues with this.

I noticed I was actually on dd-wrt latest mini sp2 build 14896 so i downgraded to sp1 because I read elsewhere online at openwrt forums that dd-wrt sp2 builds are known to cause problems when changing over. But when trying to upgrade, it keeps bricking the router. After upgrade, it does not hand out an IP, and I keep getting MS internal 169.254.x.x ip from it. I have to keep going in with my serial ttl to usb adapter, interrupting boot, doing an nvram erase, truning on boot_wait, then reinstalling original linksys firmware after the ctheader flash command and catching it in just that correct spot.
--now I am again in a position where I can load dd-wrt on again, but I don't want to try this for a third time.

Any ideas or suggestions why this might be happening. It also happens when i try to upgrade to openwrt after previously having dd-wrt as well.

I can spit out all bootup info from putty while I am serial'd in, if anyone here thinks they can read it and decipher the problem.

Please let me know, would love to really try some of the gargoyle features out, they sound very promising.

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: wrt350N v1 install

Postby sodapopdima » Mon Apr 04, 2011 12:55 am

I am adding a link off my ftp for the serial output in a text file in case this helps, its a complete boot from when plugging in the router power brick until the green light is solid and stops blinking, also no further output is generated.

ftp://dnulman.dyndns.org/Gargoyle%20Ser ... output.txt

I hope someone can help me figure this out

behappy
Posts: 83
Joined: Thu Mar 31, 2011 5:06 pm

Re: wrt350N v1 install

Postby behappy » Mon Apr 04, 2011 3:45 am

It must be so simple as
- Reset to default for yr router (192.168.1.1) getting default pwd from DDWRT
- Fixed IP on yr pc (192.168.1.xx)
- Boot the router in failsafe mode
- Tftp the squashfs img (quickest and safest). Get tftp2 prog. from DDWRT wiki
- Reset the router again (by GUI or mtd erase) so maybe the rest of DDWRT is totally cleared.

My favorite method trying different fw.

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: wrt350N v1 install

Postby sodapopdima » Mon Apr 04, 2011 9:13 am

Everything was default, so no need to set as default, remember I did a complete reinstall to dd-wrt from stock linksys image, after a serial recovery and I made absolutely no other changes. Default user/pass was root/admin I did not change this either.

I even tried to flash two ways from within GUI , one where I chose to reset options to default and once without choosing this even though it was all at default anyway.

Yes I did lock my IP to 192.168.1.x

I can try to boot router in failsafe mode and then try that way with tftp, but I tried this with openwrt and it failed in the same manner.

I think something weird is going on, also I notice that boot_wait is always turned off after a a flash to openwrt/gargoyle.

ghoffman
Posts: 1
Joined: Wed May 18, 2011 8:24 am

Re: wrt350N v1 install

Postby ghoffman » Wed May 18, 2011 8:34 am

does the new version support wrt350n?
prior version resulted in brick requiring jtag....

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: wrt350N v1 install

Postby sodapopdima » Mon May 23, 2011 3:48 am

Just tried the new version, and same issue.

Constant blinking LED power light and whenever plugging in an rj45 cable the reporting LED for the port is always off from the physical port.

Something else is wrong that needs to be addressed, I think this was just an update, but doesn't fix the underlying issue.

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: wrt350N v1 install

Postby sodapopdima » Sun Jun 12, 2011 1:48 am

@DoesItMatter

Is there anything I can do with the router to asses the problem, or help you in maybe trying a new image build to see if it will work.

I already have a full boot sequence with fail messages in that serial output text file in post above.

I would love to get gargoyle on this thing, as I already played with it on my wrt150 (minus a small wireless issue) and I think its awesome.

Please let me know if there is anything I can do, I have full access through Serial if needed (no jtag though), and by now I am an expert at recovering this thing from a bad flash :-)

sodapopdima
Posts: 26
Joined: Fri Apr 01, 2011 1:35 pm

Re: wrt350N v1 install

Postby sodapopdima » Tue Mar 12, 2013 2:14 am

Sorry to stir up an old thread, but I found something accidentally and was wondering if someone here can help with it...

Seems like the switch in this model was built a little differently and this si why so many people end up with having to Serial in to recover when trying openwrt or gargoyle, but someone made a confirmed good image

http://web.archive.org/web/200904021817 ... 191.0.html

Not sure if this can help anyone (or Eric) in making a gargoyle build but I would like to install openwrt on here, but I just don't know the limitation and how far back I need to look for file to then get Gargoyle in on top of that, as k24 builds only work, no k26 builds available.

If I am successful in getting openwrt on here, can someone guide me to adding gargoyle as a set of packages, to whatever the most recent version it could handle?


Return to “Hardware / Installation Issues”

Who is online

Users browsing this forum: No registered users and 5 guests