Page 1 of 1

WRT54GL Bricked?

Posted: Tue Apr 23, 2019 3:22 am
by petubl
Good morning everyone,

I tried to install version 1.6.2 on my WRT54GL and when i tried to set it up as an access point, it was not particularly responsive nor broadcasting a wireless signal, so I thought I would return to DD-WRT. I tried flashing it a couple of times but the flash would not work. Even then, when i was trying to flash it, getting to the GUI interface was difficult, the page would time out, but eventually would connect after a few unsuccessful tries.

Now I cannot get gui access at all. I tried to go into failsafe mode, but while i can ping everything else fails. No telnet connection, no ssh connection (refused) and efforts to flash with TFTP fail as well.

But it is there and something works since I can ping it right?

Any ideas to help this newbie?


Re: WRT54GL Bricked?

Posted: Tue Apr 23, 2019 5:42 am
by Lantis
If you successfully got it to failsafe mode, you must use Telnet, not ssh.
That would be the next thing to try, otherwise you may need to use a serial interface to debrick it.

Re: WRT54GL Bricked?

Posted: Tue Apr 23, 2019 7:38 am
by petubl
Thanks for the response Lantis - I am not sure if i am in failsafe or not - initially the power led is blinking very fast, then the DMZ led comes on and after quite a bit of time the orange led on the logo comes on... That's when i can ping the machine...

How does the serial interface work? What do i need for this?

Re: WRT54GL Bricked?

Posted: Tue Apr 23, 2019 9:25 am
by Lantis
During failsafe you should get no other LEDs except a fast blinking system light and possibly a LAN link indicator.
If you're getting anything other than that, the system is in a different state most likely.

The serial port is described here:

Note that due to the age of the device and incompatibility with modern firmwares, the amount of support i (and everyone else probably) can give is very limited. Sorry

Re: WRT54GL Bricked?

Posted: Tue Apr 23, 2019 1:24 pm
by tapper
I am sorry but the wrt54gl is so old that it cant run new fermwairs. The best thing you can do is try and get your hands on a new router.

Re: WRT54GL Bricked?

Posted: Thu Apr 25, 2019 4:59 am
by petubl
Thanks very much for all the responses guys.

I think that in the end I will retire this router and move on to something else...