Openwrt 19.07 based Gargoyle

Discuss the technical details of Gargoyle and ongoing development

Moderator: Moderators

Lantis
Moderator
Posts: 5538
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

That doesn't sound right.
I think what they are trying to say is that usb3 is enabled by default. However. In our config we quite clearly have it disabled.

So yes while setting it to "=y" is not strictly required, setting it to "is not set" overrides the default and turns it off.

And no, there is still a kmod-usb3 and there's no indication I can see that this functionality has been merged elsewhere (why would they?)
Please seek some clarification.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:That doesn't sound right.
I think what they are trying to say is that usb3 is enabled by default. However. In our config we quite clearly have it disabled.

So yes while setting it to "=y" is not strictly required, setting it to "is not set" overrides the default and turns it off.

And no, there is still a kmod-usb3 and there's no indication I can see that this functionality has been merged elsewhere (why would they?)
Please seek some clarification.


Two things:
1. Only after this change USB became fully functional.
2. In Gargoyle 1.11 this option also set to 'y'.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:I've added code to select the highest protocol in a situation where the upstream network is "mixed"


Finally tested this. Unfortunately not working. If main router unsing WPA3/WPA2 authentication and slave set to WPA3/WPA2 also, slave router not able to connect to main router. If I change authentication to WPA2 on main - slave router got connected without problem. And other way around if main use WPA3/WPA2 and slave set to WPA2 - everything is fine.
So not working situation mixed/mixed. Could you, please, have a look?

Lantis
Moderator
Posts: 5538
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

Can you post your config you're using for Wi-Fi?
The client shouldn't be in mixed mode which confuses me and is why I think it isn't working.
Screenshots is fine.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Lantis
Moderator
Posts: 5538
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

Config on both upstream and downstream devices preferably as well thanks.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:Can you post your config you're using for Wi-Fi?
The client shouldn't be in mixed mode which confuses me and is why I think it isn't working.
Screenshots is fine.


Before posting, probably, unnecessary things, I would like to check that I'm correct in my understanding of how wireless repeater working (I didn't use much before on routers). If main router having mixed authentication (wpa2 and wpa3 clients should be accepted) and repeater (connected via wds) I will set wpa3 authentication. Will wpa2 clients be accepted by repeater? Probably it's stupid question, but I didn't found clear answer and almost everywhere were written that authentication should match on both devices.

Lantis
Moderator
Posts: 5538
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

papka__ wrote:Before posting, probably, unnecessary things, I would like to check that I'm correct in my understanding of how wireless repeater working (I didn't use much before on routers). If main router having mixed authentication (wpa2 and wpa3 clients should be accepted) and repeater (connected via wds) I will set wpa3 authentication. Will wpa2 clients be accepted by repeater? Probably it's stupid question, but I didn't found clear answer and almost everywhere were written that authentication should match on both devices.


Ok, that's an interesting scenario. The code doesn't currently accommodate that.

The way it works is that the Repeater is supposed to mirror the Upstream AP (i.e. repeat it). This includes channel, encryption and password (we let you change the name if you like).
The problem is, there's no such thing as "mixed" encryption when you JOIN an AP. You use one or the other.
So therefore the repeater then also gets the "one or the other" treatment as well.

We can probably fix this, but it's a curly situation.
For example, what if you have a downstream router which can't do WPA3, so it connects as WPA2. It isn't capable of repeating the mixed WPA3/2 signal, so it will only do WPA2, but that's now an unexpected (or at least, strange) behaviour.

For now as a workaround, you can manually edit your repeater config to "sae-mixed" instead of "sae", and then restart your wifi.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Thank you. I will try and will let you know.
However, is it not the same as I would set wpa3/wpa2 authentication on repeater GUI?

Lantis
Moderator
Posts: 5538
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

Maybe, but i don't know how the host will connect in this behaviour. It sounds like "undefined" behaviour.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:Maybe, but i don't know how the host will connect in this behaviour. It sounds like "undefined" behaviour.


That's the thing. Connection happen only if either main router or repeater authentication is distinct. If both mixed - repeater not creating connection to main router. I already tested this.

Post Reply