Openwrt 19.07 based Gargoyle

Discuss the technical details of Gargoyle and ongoing development

Moderator: Moderators

pythonic
Posts: 33
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby pythonic » Sun Sep 01, 2019 6:51 am

In your ipq806x build I notice that you haven't included the image for the Netgear D7800 - any particular reason given that my 1.11.0 build for this device seems to work fine?

Lantis
Moderator
Posts: 5094
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby Lantis » Sun Sep 01, 2019 7:04 am

Generally Gargoyle does not support any modems, so i stuck with that paradigm.
If there's big demand we can add it, but i'm personally charging the person who requests it responsible for answering every single "How do i make the modem work?" post :)
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

yabba235
Posts: 26
Joined: Sun Nov 25, 2012 4:57 pm

Re: Openwrt 19.07 based Gargoyle

Postby yabba235 » Sun Sep 01, 2019 8:27 am

Lantis wrote:Did you try to preserve settings?
Can you please provide the output of:
"cat /etc/config/wireless"
(please make sure to remove any passwords if they are present)
and
"cat /tmp/cached_basic_vars"


Yes, is bug - all working but no wifi, because no "wireless" file in etc/confg and no deamon wifi

root@Gargoyle:~# cat /tmp/cached_basic_vars
var isBcm94704 = false;
var allLanMacs = [];
allLanMacs.push("76:44:01:88:39:e2");
allLanMacs.push("76:44:01:88:39:e2");
var isRamips = false;
var wifiDevG=uciWirelessDevs.length > 0 ? uciWirelessDevs[0] : "";
var wifiDevA="";
var wirelessDriver="";
var GwifiN = false;
var AwifiN = false;
var AwifiAC = false;
var dualBandWireless=false;
var wpad_eap = true;
var wpad_sae = true;
var wpad_owe = true;
var wpad_sb192 = true;
var distribTarget='ath79/generic';
var geo_ipaddress = ""; var geo_countrycode = "";

wifi config do nothing :evil:

I don't know what next step.

Compiling with ath79/usb_large switch

But my router work like no wireless devices, so is 50% success :D

Lantis
Moderator
Posts: 5094
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby Lantis » Sun Sep 01, 2019 9:09 am

"gpkg list-installed | grep ath9k"

you can try running "wifi config" to generate the config file. Doesn't make much sense why it doesn't exist already. I'll flash a WNDR3800 this week to see whether it behaves similarly.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

yabba235
Posts: 26
Joined: Sun Nov 25, 2012 4:57 pm

Re: Openwrt 19.07 based Gargoyle

Postby yabba235 » Sun Sep 01, 2019 9:44 am

Lantis wrote:"gpkg list-installed | grep ath9k"

you can try running "wifi config" to generate the config file. Doesn't make much sense why it doesn't exist already. I'll flash a WNDR3800 this week to see whether it behaves similarly.

From openwrt dmesg:
PPTP driver version 0.8.5
[ 24.766093] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 25.599672] owl-loader 0000:00:11.0: fixup device configuration
[ 25.607520] pci 0000:00:11.0: [168c:0029] type 00 class 0x028000
[ 25.607555] pci 0000:00:11.0: reg 0x10: [mem 0x10000000-0x1000ffff]
[ 25.607612] pci 0000:00:11.0: PME# supported from D0 D3hot
[ 25.608208] pci 0000:00:11.0: BAR 0: assigned [mem 0x10000000-0x1000ffff]
[ 25.615169] ath9k 0000:00:11.0: enabling device (0000 -> 0002)
[ 25.654569] ath: phy0: Ignoring endianness difference in EEPROM magic bytes.
[ 25.663196] ath: EEPROM regdomain: 0x0
[ 25.663200] ath: EEPROM indicates default country code should be used
[ 25.663203] ath: doing EEPROM country->regdmn map search
[ 25.663214] ath: country maps to regdmn code: 0x3a
[ 25.663219] ath: Country alpha2 being used: US
[ 25.663222] ath: Regpair used: 0x3a
[ 25.677795] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 25.679524] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xb0000000, irq=18
[ 25.855314] owl-loader 0000:00:12.0: fixup device configuration
[ 25.863264] pci 0000:00:12.0: [168c:0029] type 00 class 0x028000
[ 25.863300] pci 0000:00:12.0: reg 0x10: [mem 0xffff0000-0xffffffff]
[ 25.863357] pci 0000:00:12.0: PME# supported from D0 D3hot
[ 25.863924] pci 0000:00:12.0: BAR 0: assigned [mem 0x10010000-0x1001ffff]
[ 25.870885] ath9k 0000:00:12.0: enabling device (0000 -> 0002)
[ 25.923564] ath: phy1: Ignoring endianness difference in EEPROM magic bytes.
[ 25.932175] ath: EEPROM regdomain: 0x0
[ 25.932180] ath: EEPROM indicates default country code should be used
[ 25.932183] ath: doing EEPROM country->regdmn map search
[ 25.932193] ath: country maps to regdmn code: 0x3a
[ 25.932198] ath: Country alpha2 being used: US
[ 25.932201] ath: Regpair used: 0x3a
[ 25.948983] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
etc....
This is missing part in dmesg log from my gargoyle 1.13, so I thinking owl-loader module is missing, but why ?

Lantis
Moderator
Posts: 5094
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby Lantis » Sun Sep 01, 2019 9:57 am

Thanks, yes this is likely what is wrong, and it is not set in the config.
Including it should fix, but I won't have time to check until late this week.

Known issues:

* wifi firmware file may not get created on the first boot
after flashing on time to bring wifi normally up. Likely
the overlay jffs2 is not yet ready for creating the
firmware file. "wifi up" may still bring wifi up.
Wifi will work normally at subsequent boots.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

yabba235
Posts: 26
Joined: Sun Nov 25, 2012 4:57 pm

Re: Openwrt 19.07 based Gargoyle

Postby yabba235 » Sun Sep 01, 2019 12:14 pm

Lantis wrote:Thanks, yes this is likely what is wrong, and it is not set in the config.
Including it should fix, but I won't have time to check until late this week.

Known issues:

* wifi firmware file may not get created on the first boot
after flashing on time to bring wifi normally up. Likely
the overlay jffs2 is not yet ready for creating the
firmware file. "wifi up" may still bring wifi up.
Wifi will work normally at subsequent boots.



I am glad that I could help to notice this problem :D

pythonic
Posts: 33
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby pythonic » Mon Sep 02, 2019 8:21 am

Lantis wrote:Generally Gargoyle does not support any modems, so i stuck with that paradigm.
If there's big demand we can add it, but i'm personally charging the person who requests it responsible for answering every single "How do i make the modem work?" post :)

I understand where you're coming from.

It just seems a waste to me as the D7800 is the only Netgear ipq806x model that seems to be available here in Aus, and it has the same router hardware as the R7500v2. As the D7800 has an exclusive WAN port, running it in router-only mode with a decent bridged modem makes it useful if the inbuilt Lantiq modem doesn't perform well (and anecdotally it seems to have a patchy NBN VDSL performance record).

I guess as I own one (and created the build that started this) I'd stand up to respond as you'd request, even though I can build my own images.

Lantis
Moderator
Posts: 5094
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby Lantis » Mon Sep 02, 2019 5:00 pm

I'll add it in as an exception to the rule :)
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

pythonic
Posts: 33
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Postby pythonic » Tue Sep 03, 2019 8:16 am

Thanks! 8-)


Return to “Gargoyle Development”

Who is online

Users browsing this forum: No registered users and 2 guests