Slow / Congested ....

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

ArcticCat
Posts: 12
Joined: Wed Nov 23, 2016 6:45 pm

Slow / Congested ....

Post by ArcticCat »

Hey everyone

first post for me, I'm running gargoyle 1.8.1 on TP-Link TL-WR1043N/ND v2


and I am having a real weird issue, sometimes the whole internet becomes slow as hell opening a new page will take very long and the page browser will just say "connecting" or dns resolution won't pass at all before 2 to 3 refresh.

The weird part is that, even during these times, download speed is pretty stable.

I can't really isolate when is this happening but I am out of ideas, I am suspecting QoS (which I disabled today to test) but I am not sure and I really need QoS or my kids will just suck all the BW :roll:

If anyone can point me in the correct direction I'd be grateful

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Slow / Congested ....

Post by ericwong »

Sounds like DNS related.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

ArcticCat
Posts: 12
Joined: Wed Nov 23, 2016 6:45 pm

Re: Slow / Congested ....

Post by ArcticCat »

Morning Eric, thank you for the reply :)

I had the same feeling and played a lot with DNS what I noticed is that when it happens DNS resolution is super slow or times-out however it happens not consistently and, when it is not, DNS resolution is super fast.

can it be related to QoS upload ?

anything I can do to troubleshoot ?

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Slow / Congested ....

Post by ericwong »

If you are using default DNS, i.e. as supplied by your ISP, try change it to Google DNS 8.8.8.8 or OpenDNS. It could be your ISP DNS causing the problem.

You can change it at the Gargoyle router or your computer. It is easier to nail down the problem if you change it on your computer end for testing.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

ArcticCat
Posts: 12
Joined: Wed Nov 23, 2016 6:45 pm

Re: Slow / Congested ....

Post by ArcticCat »

I've been trying DNS workarounds for weeks, the best (and fastest) way I was able reach was using OpenDNS port 5353

but again, I feel that DNS slowness is a result and not the core issue...

is there anywhere in the logs or something that I can pull-out or check while the issue is happening ?

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Slow / Congested ....

Post by ericwong »

Install the logread plugin and read the log but I am not sure if you can see anything useful there.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

ArcticCat
Posts: 12
Joined: Wed Nov 23, 2016 6:45 pm

Re: Slow / Congested ....

Post by ArcticCat »

Already done that, the only thing I notice is a bunch of

user.err syslog: module is already loaded - cls_fw
user.err syslog: module is already loaded - cls_flow
user.err syslog: module is already loaded - sch_hfsc
user.err syslog: module is already loaded - sch_sfq


I am not sure what they mean but it looks like it happens every time I change/ enable/disable QoS

ispyisail
Moderator
Posts: 4736
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Slow / Congested ....

Post by ispyisail »


Lantis
Moderator
Posts: 5382
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Slow / Congested ....

Post by Lantis »

ArcticCat wrote:Already done that, the only thing I notice is a bunch of

user.err syslog: module is already loaded - cls_fw
user.err syslog: module is already loaded - cls_flow
user.err syslog: module is already loaded - sch_hfsc
user.err syslog: module is already loaded - sch_sfq


I am not sure what they mean but it looks like it happens every time I change/ enable/disable QoS


Harmless, and as you say, part of the QoS startup routine.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

ArcticCat
Posts: 12
Joined: Wed Nov 23, 2016 6:45 pm

Re: Slow / Congested ....

Post by ArcticCat »

Thank you lantis I will try this :(

It is happening again right now :( :(

this is DNS resolution ATM

Code: Select all

nslookup google.com
Server:  Gargoyle.lan


DNS request timed out.
    timeout was 2 seconds.
Name:    google.com
Address:  2a00:1450:4010:c0b::65 (Only IP V6)

nslookup google.com
Server:  Gargoyle.lan

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to Gargoyle.lan timed-out

 nslookup google.com
Server:  Gargoyle.lan

Non-authoritative answer:
DNS request timed out.
    timeout was 2 seconds.
Name:    google.com
Addresses:  74.125.232.232
          74.125.232.230
          74.125.232.225
          74.125.232.228
          74.125.232.224
          74.125.232.226
          74.125.232.238
          74.125.232.231
          74.125.232.229
          74.125.232.233
          74.125.232.227


you see I had to do it 3 times to pass and BW is not full :shock: :shock:

Post Reply