A way to stop connection overloads?

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

Post Reply
foreverstorm
Posts: 20
Joined: Mon Aug 24, 2009 2:17 pm

A way to stop connection overloads?

Post by foreverstorm »

I have been running Gargoyle on my TP Link tl-wr841nd for about a month in my new flat (with about 5 other flatmates) and I get a problem where the router starts to massively slow down (the config page takes ages to load) and so does the throughput to the internet.

I notice that this is perhaps because sometimes people are downloading with p2p and I get in upwards of 500 UDP connections etc.

I was wondering what ways there are to combat this? I have halved the default number of maximum connections and decresed TCP and UDP timeouts to 60sec and 30sec respectively. I have also reduced the UPNP figures to 128kbps up 256kbps down. The QoS is active and I have added capped a couple of users to 10kbps upload. Is there anything more I can do?

I've also noticed the following bugs
1) CPU usage isn't displayed after a while (all numbers are zero)
2) On the bandwidth usage graphs the download graph doesn't show downloading by QoS but upload does
3) The USB thumbdrive isn't detected reliably
4) The router will seize up and stop allowing any network access. I am not sure yet but this may only occur when 40mhz mode is forced to be enabled by entering noscan=1 into the configuration.

pbix
Developer
Posts: 1371
Joined: Fri Aug 21, 2009 5:09 pm

Re: A way to stop connection overloads?

Post by pbix »

What version of Gargoyle are you using.

With 32MB of RAM your router should easily support 500 connections. I doubt this is the problem.

You might also SSH into your router and run logread and dmesg to see if any entries there might assist.
Linksys WRT1900ACv2
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

foreverstorm
Posts: 20
Joined: Mon Aug 24, 2009 2:17 pm

Re: A way to stop connection overloads?

Post by foreverstorm »

I am running 1.3.16. The problem has just culminated in my computer specifically will no longer be recognized by the router. I can get internet for a few seconds after rebooting the router but then it stops responding (although it says I'm still connected to the net).

My wireless network card will connect properly to other networks, but not to the gargoyle one. The only way I can get internet is by using a wireless USB key.

I suspect the web usage database associated with my computer's mac address is corrupted and after the router reboots that part my computer is no longer served properly - but I can't change spoof the mac address on my card to get around this.

So I need some way to clear the routers saves, any way to do this short of a reinstall?

pbix
Developer
Posts: 1371
Joined: Fri Aug 21, 2009 5:09 pm

Re: A way to stop connection overloads?

Post by pbix »

I suspect the simplest and most straight forward way to clear network statistics for you is to reinstall.

Do other users of your router suffer the same issues?
Linksys WRT1900ACv2
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

Post Reply