[SOLVED] TP Link WR1043ND Factory or Sysupgrade from stock?

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

belbo
Posts: 21
Joined: Sat Feb 26, 2011 6:50 pm

[SOLVED] TP Link WR1043ND Factory or Sysupgrade from stock?

Postby belbo » Mon May 30, 2011 9:07 am

Please help me clear up some confusion.

I installed gargoyle (1.3.14) from stock on the WR1043ND using the stock firmware upgrade tool, following the instructions here

http://www.gargoyle-router.com/wiki/doku.php?id=tp-link_tl-wr1043nd.

I used the sysupgrade.bin instead of the factory.bin because that is what the instructions say.

However, some forum posts indicate that the factory.bin should be used when installing from stock. I'm wondering if there is a mistake in the installation instructions and I should really have used the factory.bin.

An example of a post that indicate the factory.bin should be used -

http://www.gargoyle-router.com/phpbb/viewtopic.php?f=8&t=901#p4440

the factory file is fresh flashing (i.e. original stock firmware upgrade)

if you have openwrt or gargoyle installed, you need to use
the sysupgrade file to upgrade via the web gui


The installation instructions themselves say -

Upgrading existing router firmware

gargoyle_1.3.14-ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

Installing new firmware

gargoyle_1.3.14-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin


But that is ambiguous to me, so I followed the example, which says to use sysupgrade.bin.

If anybody can throw some light on this for me I'd very much appreciated it.

belbo
Last edited by belbo on Fri Jun 03, 2011 9:40 am, edited 1 time in total.

nebbia88
Posts: 53
Joined: Thu Feb 17, 2011 6:53 am

Re: TP Link WR1043ND Factory or Sysupgrade from stock?

Postby nebbia88 » Mon May 30, 2011 9:18 am

belbo wrote:An example of a post that indicate the factory.bin should be used -

the factory file is fresh flashing (i.e. original stock firmware upgrade)

if you have openwrt or gargoyle installed, you need to use
the sysupgrade file to upgrade via the web gui

This is the truth.

Unfortunately the Wiki is right here:
Upgrading existing router firmware

gargoyle_1.3.14-ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

Installing new firmware

gargoyle_1.3.14-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin


but WRONG here
Open the original TP-Link configuration.

Select “System Tools” » “Firmware Upgrade”

Select

gargoyle_1.3.14-ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

belbo
Posts: 21
Joined: Sat Feb 26, 2011 6:50 pm

Re: TP Link WR1043ND Factory or Sysupgrade from stock?

Postby belbo » Mon May 30, 2011 9:27 am

Thanks.

What would be the best way for me to rectify? Is it best to go back to stock and then install using the factory.bin? Presumably I shouldn't install factory.bin from the sysupgrade.bin gargoyle install I currently have?

How do we correct the installation instructions, or advise the right people that it needs to be corrected?

nebbia88
Posts: 53
Joined: Thu Feb 17, 2011 6:53 am

Re: TP Link WR1043ND Factory or Sysupgrade from stock?

Postby nebbia88 » Mon May 30, 2011 11:13 am

i think it's better to return to stock and reflash the one with "factory" in the name.
The strange thing is that your router is still alive xD

Anyway you should wait for further suggestions, maybe your router is fine...

belbo
Posts: 21
Joined: Sat Feb 26, 2011 6:50 pm

Re: TP Link WR1043ND Factory or Sysupgrade from stock?

Postby belbo » Fri Jun 03, 2011 9:39 am

Just to say thanks and that I have this all sorted. See my post here -

http://www.gargoyle-router.com/phpbb/viewtopic.php?f=6&t=1358#p6422

I'll mark this thread as solved.

AgeOfGargoyles
Posts: 5
Joined: Mon Jun 06, 2011 9:51 pm

Re: [SOLVED] TP Link WR1043ND Factory or Sysupgrade from stock?

Postby AgeOfGargoyles » Thu Jun 09, 2011 3:03 am

I have the same problem and this thread saves me. Thanks.

nebbia88
Posts: 53
Joined: Thu Feb 17, 2011 6:53 am

Re: [SOLVED] TP Link WR1043ND Factory or Sysupgrade from stock?

Postby nebbia88 » Fri Jun 10, 2011 4:16 am

i can't understand your confusion now that the wiki reports correct instructions


Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 5 guests