4G modem on small flash router help

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

ViBE
Posts: 179
Joined: Sun Apr 19, 2015 6:58 pm

Re: Version 1.13.0 : Based on OpenWrt 19.07.8

Post by ViBE »

but how can i configure the APN via Gargoyle if something is not preconfigured in the modem?

does this log now helps to find out which driver is needed for the Nexx WT3020 to handle the modem?

Lantis
Moderator
Posts: 6352
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.13.0 : Based on OpenWrt 19.07.8

Post by Lantis »

You don’t. It should be configured on the stick itself by navigating to its IP address. Please google and understand the difference between “hi link” and “stick mode”.
With respect, as I mentioned I don’t have enough experience or knowledge to deeply help you with this issue. However, I’m also not that interested in helping a device that is too small to install the plug-in that would 99% positive make your stick work.

I will split your posts into another topic for visibility in the hope someone else can assist you, but I can’t help sorry.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

pythonic
Posts: 140
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: 4G modem on small flash router help

Post by pythonic »

Seems the DWM-222 is a QMI modem so you need the relevant drivers + usb_modeswitch - see here for some more info.

I'd suggest you'll have much more likelihood of getting this going with ROOter (also built on top of OpenWrt, but very much specialising in using 3G/4G/LTE/5G modems). Your modem is mentioned in the forum the ROOter team use and the WT3020F is in their list of supported routers. Once you have it running with ROOter, you may be able to use that setup to help get it running in Gargoyle.

ViBE
Posts: 179
Joined: Sun Apr 19, 2015 6:58 pm

Re: Version 1.13.0 : Based on OpenWrt 19.07.8

Post by ViBE »

Lantis wrote:
Fri Apr 15, 2022 8:41 pm
You don’t. It should be configured on the stick itself by navigating to its IP address. Please google and understand the difference between “hi link” and “stick mode”.
With respect, as I mentioned I don’t have enough experience or knowledge to deeply help you with this issue. However, I’m also not that interested in helping a device that is too small to install the plug-in that would 99% positive make your stick work.

I will split your posts into another topic for visibility in the hope someone else can assist you, but I can’t help sorry.
ah thanks. you moved my comments to a new topic. i was a bit sad cause i thought all deleted.

ViBE
Posts: 179
Joined: Sun Apr 19, 2015 6:58 pm

Re: 4G modem on small flash router help

Post by ViBE »

pythonic wrote:
Sat Apr 16, 2022 7:31 am
Seems the DWM-222 is a QMI modem so you need the relevant drivers + usb_modeswitch - see here for some more info.

I'd suggest you'll have much more likelihood of getting this going with ROOter (also built on top of OpenWrt, but very much specialising in using 3G/4G/LTE/5G modems). Your modem is mentioned in the forum the ROOter team use and the WT3020F is in their list of supported routers. Once you have it running with ROOter, you may be able to use that setup to help get it running in Gargoyle.
it's not as easy. i mean it's not QMI by default. i downloaded several official firmwares and looks like D-Link changed the protocols several times. they used QMI before. i have to downgrade the modem to figure out this. sadly looks like my modem was a warranty cause it's got bricked after an update. i have to wait for the replacement and figure out again which version is exact QMI version.

btw QMI is basically a modern kinda PPP/serial mode?

ViBE
Posts: 179
Joined: Sun Apr 19, 2015 6:58 pm

Re: 4G modem on small flash router help

Post by ViBE »

now i'm trying with another modem and try to install the required packages for NCM/PPP protocol. but somehow the packages are not available:

Code: Select all

root@WT3020:~# opkg install comgt-ncm kmod-usb-net-huawei-cdc-ncm
ERROR: Dependency kmod-usb-serial-option of package comgt-ncm cannot be found, try updating your package lists
root@WT3020:~# opkg install comgt-ncm
ERROR: Dependency kmod-usb-serial-option of package comgt-ncm cannot be found, try updating your package lists
root@WT3020:~# opkg install kmod-usb-net-huawei-cdc-ncm
ERROR: Dependency kmod-usb-net-cdc-ncm of package kmod-usb-net-huawei-cdc-ncm cannot be found, try updating your package lists
root@WT3020:~# opkg install kmod-usb-serial
ERROR: Dependency kernel (= 4.14.261-1-37018b679256107e7ea993bc16cdf0ac) of package kmod-usb-serial is installed,
		but has incompatible version 4.14.261-1-2be1687fe09c2e738b0014968bc8b8b1
root@WT3020:~# opkg install kmod-usb-serial-option
ERROR: Dependency kmod-usb-serial-wwan of package kmod-usb-serial-option cannot be found, try updating your package lists
root@WT3020:~# opkg install kmod-usb-serial-wwan
ERROR: Dependency kmod-usb-serial of package kmod-usb-serial-wwan cannot be found, try updating your package lists
so i'm stuck.

https://openwrt.org/docs/guide-user/net ... n/3gdongle

Post Reply