GL inet AR150 modem support 1.13.x

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

ispyisail
Moderator
Posts: 4960
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: GL inet AR150 modem support 1.13.x

Post by ispyisail »

Code: Select all

root@Gargoyle:~#
root@Gargoyle:~# cat /sys/class/gpio/usb-phy/direction
cat: can't open '/sys/class/gpio/usb-phy/direction': No such file or directory
root@Gargoyle:~#

pythonic
Posts: 107
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by pythonic »

At this stage, I can't offer any more ideas to get this target's USB working.

If you're interested to try a different approach to see if USB will work on the device I can post a patch that adds the AR150 to the ar71xx target definition (as it was with 1.12.x/OpenWrt 18.06) which I've successfully built but can't test. However an ar71xx build - assuming it works - isn't a long term solution as OpenWrt has dropped the ar71xx target completely starting with the 21.02 release with all remaining supported ar71xx devices ported to ath79.

Lantis
Moderator
Posts: 6111
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by Lantis »

a bootlog from a working openwrt install (assuming it works with OpenWrt 19.07) and a bootlog from gargoyle might give some clues.
Maybe gpkg list-installed as well..

I'm not sure either
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

pythonic
Posts: 107
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by pythonic »

I was able to get one of these on special and have done some testing:
  • both ar71xx and ath79 OpenWrt 19.07.8 builds (with the required packages added) can fire up my E8372 and make a network interface available (eth2) though I didn't try actually transferring traffic
  • with @ispysail's 20210815 Gargoyle build (retrieved from @RomanHK's server) the E8372 powers up and gets a connection based on the lights, but there is no network interface created
If I get a chance I'll try building Gargoyle ath79 myself with a few extras included (e.g. usbutils) for diagnostics. Anything else that would be useful?

Logs from both the OpenWrt ath79 (kernel & system) and Gargoyle (dmesg) installs: zip (will probably disappear in a few weeks).

ispyisail
Moderator
Posts: 4960
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: GL inet AR150 modem support 1.13.x

Post by ispyisail »

Thanks guys

I don't know where you guys find the time.

I've been meaning to try the latest Gargoyle (latest OpenWRT service pack) and even testing OpenWRT direct but I've been busy :(

Thanks

Lantis
Moderator
Posts: 6111
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by Lantis »

Much appreciated from myself as well. Despite not being able to go anywhere it has been a busy year.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

pythonic
Posts: 107
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by pythonic »

I believe the following patch to targets/ath79/profiles/usb_large/config should resolve the issue:

Code: Select all

--- config.orig	2021-09-10 23:39:31.984007997 +1000
+++ config	2021-09-20 23:05:14.072298191 +1000
@@ -3220,8 +3220,8 @@
 CONFIG_PACKAGE_kmod-phy-ath79-usb=y
 CONFIG_PACKAGE_kmod-usb-acm=y
 # CONFIG_PACKAGE_kmod-usb-atm is not set
-# CONFIG_PACKAGE_kmod-usb-chipidea is not set
-# CONFIG_PACKAGE_kmod-usb-chipidea2 is not set
+CONFIG_PACKAGE_kmod-usb-chipidea=y
+CONFIG_PACKAGE_kmod-usb-chipidea2=y
 # CONFIG_PACKAGE_kmod-usb-cm109 is not set
 CONFIG_PACKAGE_kmod-usb-core=y
 # CONFIG_PACKAGE_kmod-usb-dwc2 is not set
@@ -3255,6 +3255,7 @@
 # CONFIG_PACKAGE_kmod-usb-net-sr9700 is not set
 # CONFIG_PACKAGE_kmod-usb-ohci is not set
 # CONFIG_PACKAGE_kmod-usb-ohci-pci is not set
+CONFIG_PACKAGE_kmod-usb-phy-nop=y
 CONFIG_PACKAGE_kmod-usb-printer=y
 CONFIG_PACKAGE_kmod-usb-serial=y
 # CONFIG_PACKAGE_kmod-usb-serial-ark3116 is not set
With these extra kmods in the ar150 image I can select my E8372 as the WAN and transfer data. Sorry about the old school approach to patches - I'm still to figure out how to do this with git. :roll:

Lantis
Moderator
Posts: 6111
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by Lantis »

That's ok, it's still a very helpful contribution.
I am not sure usb-phy-nop is required. The other 2 yes that makes sense, although I think it is only chipidea2 (not 1) that is needed.
Any chance you can check with just chipidea2 added please?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

pythonic
Posts: 107
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by pythonic »

chipidea2 won't build without usb-phy-nop - I attempted a build without it which failed complaining about the missing dependency, though whether usb-phy-nop only needs to be "m" rather then "y" I didn't test.

Will be a few days before I can play with deleting chipidea.

Lantis
Moderator
Posts: 6111
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: GL inet AR150 modem support 1.13.x

Post by Lantis »

Nevermind they all depend on each other, I just wasn't reading it properly the first time.
I'll add this over the weekend. Appreciate it!
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply