Qos exempt class

General discussion about Gargoyle, OpenWrt or anything else even remotely related to the project

Moderator: Moderators

GoUser
Posts: 26
Joined: Tue Sep 06, 2011 2:05 pm

Qos exempt class

Postby GoUser » Tue Sep 06, 2011 2:18 pm

My provider gave me unlimited broadband up to 100 Mbit/s access with local Direct Connect. My internet connection is 8 Mbit/s. I've not found a way in QoS to tell to ignore traffic coming to/from some ports and/or IP's, also would be great to not show ignored traffic in bandwidth usage graph (or show it separately).
TP-LINK TL-WR841ND v5 - Gargoyle 1.4.7
TP-LINK TL-WR841ND v7 - Original firmware
TP-LINK TL-WR941ND - Gargoyle 1.4.7
D-LINK DIR-825 b1 - Gargoyle 1.4.7

pbix
Developer
Posts: 1365
Joined: Fri Aug 21, 2009 5:09 pm

Re: Qos exempt class

Postby pbix » Thu Sep 08, 2011 6:37 am

Gargoyle QoS does not have this capability.
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

GoUser
Posts: 26
Joined: Tue Sep 06, 2011 2:05 pm

Re: Qos exempt class

Postby GoUser » Thu Sep 08, 2011 6:57 am

Are there any temporary workarounds for my situation (maybe some script)?
Thanks.
TP-LINK TL-WR841ND v5 - Gargoyle 1.4.7
TP-LINK TL-WR841ND v7 - Original firmware
TP-LINK TL-WR941ND - Gargoyle 1.4.7
D-LINK DIR-825 b1 - Gargoyle 1.4.7

GoUser
Posts: 26
Joined: Tue Sep 06, 2011 2:05 pm

Re: Qos exempt class

Postby GoUser » Thu Dec 08, 2011 12:41 pm

Temporary solution:
1. Login via ssh and do iptables -t mangle -L --line-numbers
Now we can see in Chain qos_ingress section line like:
2 IMQ all -- anywhere anywhere IMQ: todev 0
We need to change not mark traffic from 10.0.0.0/8 (because it is internal high-speed network), so we will replace this line:
2. iptables -t mangle -R qos_ingress 2 -s ! 10.0.0.0/8 -j IMQ --todev 0 (2 because line number was 2).

Do not know if this is good solution, but hey, it works! (Next reboot or change of settings via web interface resets it back)

Unfortunatelly now we have another problem: if users start many downloads ping time to router increases. So it slows down an internet access.
TP-LINK TL-WR841ND v5 - Gargoyle 1.4.7
TP-LINK TL-WR841ND v7 - Original firmware
TP-LINK TL-WR941ND - Gargoyle 1.4.7
D-LINK DIR-825 b1 - Gargoyle 1.4.7

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: Qos exempt class

Postby DoesItMatter » Thu Dec 08, 2011 6:47 pm

What router are you using for Gargoyle?
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

GoUser
Posts: 26
Joined: Tue Sep 06, 2011 2:05 pm

Re: Qos exempt class

Postby GoUser » Thu Dec 08, 2011 7:34 pm

tl-wr841nd v5
TP-LINK TL-WR841ND v5 - Gargoyle 1.4.7
TP-LINK TL-WR841ND v7 - Original firmware
TP-LINK TL-WR941ND - Gargoyle 1.4.7
D-LINK DIR-825 b1 - Gargoyle 1.4.7

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: Qos exempt class

Postby DoesItMatter » Thu Dec 08, 2011 8:19 pm

http://infodepot.wikia.com/wiki/TP-Link_TL-WR841ND_v7.0

You need to upgrade to a different router.

Your router will not allow you to use 100mbit line.

You need a minimum 500+mhz router cpu to hit 100mbit

And that's with no extra features/services running.

Has been tested and verified quite thoroughly in the DD-WRT forums.

Consider a WNDR3700 or WNDR3800 router instead.
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

pbix
Developer
Posts: 1365
Joined: Fri Aug 21, 2009 5:09 pm

Re: Qos exempt class

Postby pbix » Thu Dec 08, 2011 9:41 pm

You can confirm what DoesItMatter suggests by watching your CPU utilization on your router. If it approaches 100% then things will not function properly.

Also what happens if you do not insert your iptables entries. Is all working correctly?
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

GoUser
Posts: 26
Joined: Tue Sep 06, 2011 2:05 pm

Re: Qos exempt class

Postby GoUser » Fri Dec 09, 2011 8:01 am

pbix wrote:You can confirm what DoesItMatter suggests by watching your CPU utilization on your router. If it approaches 100% then things will not function properly.

Also what happens if you do not insert your iptables entries. Is all working correctly?


I can't now test with full 100 mbit/s load. I've tested with 32 mbit/s and cpu usage was about 10% sometimes but not more. Also another behaviour found: I have two routers linked together with wire (seconf router acts as switch). If I start bittorrent (2% in QoS) from client of the second router (not main router) and there is available bandwith so speed can be maximum all OK. If I do the same but from client connected wirelessly to the main router ping time to the main router increases to 300 and more ms (when normal is 1-3 ms). If users of the main router activelly do web surf (78% in QoS) bittorrent slows down and ping time comes back to 1-3 ms.

I see no big overload in CPU (with or without changing iptables entry).
TP-LINK TL-WR841ND v5 - Gargoyle 1.4.7
TP-LINK TL-WR841ND v7 - Original firmware
TP-LINK TL-WR941ND - Gargoyle 1.4.7
D-LINK DIR-825 b1 - Gargoyle 1.4.7

robnitro
Posts: 82
Joined: Sat Feb 26, 2011 4:50 pm

Re: Qos exempt class

Postby robnitro » Thu Dec 15, 2011 3:19 pm

You have a good idea that may help many.
I have the same issue with Verizon FIOS. The Video on Demand IPTV service uses the internet, but it is not counted towards the speed limit. For example, I have a 30mbit line, but when I run 2 HD videos on the cable boxes, they each take around 15mbits and show a total of 50mbits on the router max with around 20 down at the time.

The only fix I have done so far is set the QOS download to the max of 50mbits, and then allow qosmon to throttle it down and up automatically. That is the primary reason I went to gargoyle.

For speed you can disable the bwmon_gargoyle service, but you will lose graphing and can only see traffic realtime in connection list. Before doing this, my router (buffalo G300nh) would be limited.

Open up putty or telnet, whatever you use to go to the terminal of the router.
cd /etc/init.d
bwmon_gargoyle stop
bwmon_gargoyle disable
chmod -x bwmon_gargoyle


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests