TroubleShooter-opkg-update-error

General discussion about Gargoyle, OpenWrt or anything else even remotely related to the project

Moderator: Moderators

Post Reply
cklbjkzkadmin
Posts: 4
Joined: Thu Jul 19, 2018 5:11 am

TroubleShooter-opkg-update-error

Post by cklbjkzkadmin »

Successful avoid opkg update error when it's belong to wget ssl certificate check problem,Main way is patch wget-ssl to avoid ssl certificate check,can do it by edit wget's source code and recompile it or use reverse tool to patch it , and I choosed the last way since I don't need configration cross compile enviroment.but I cannot post a link or pic here..so you may want to check my github for more infomation.

link here,please remove tags to check it,have to bypass forum's link check. :P

https://github.com/Arryboom/wget_nossl_check

ispyisail
Moderator
Posts: 4926
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: TroubleShooter-opkg-update-error

Post by ispyisail »

You have put a lot of work into it?

cklbjkzkadmin
Posts: 4
Joined: Thu Jul 19, 2018 5:11 am

Re: TroubleShooter-opkg-update-error

Post by cklbjkzkadmin »

well I think most time paid was on writing this tutorial :lol:

Lantis
Moderator
Posts: 5951
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: TroubleShooter-opkg-update-error

Post by Lantis »

I appreciate the effort to do this, but it is MUCH simpler to just patch the source and compile.

Also, i think one of your errors would go away by reading this thread: viewtopic.php?f=5&t=11432
Which might remove the need to do this entirely?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

cklbjkzkadmin
Posts: 4
Joined: Thu Jul 19, 2018 5:11 am

Re: TroubleShooter-opkg-update-error

Post by cklbjkzkadmin »

Thanks Lantis :D ,yes I've been followed your directions change the "downloads.openwrt" to "archive.openwrt" in the /etc/opkg.conf in a fresh installed Gargoyle,but doesn't work too,and same error because of invalid certificate,guess letsencrypt's certificate(openwrt..org's certificate was from this certification authority) not in the trust list of our trusted certificate storage.when it comes first I tried download certificate of oppeennwwrt(maybe a black list word?) manually and then import into certs storage,like "cat oppwwrt.pem >> /etc/pki/tls/certs/ca-bundle.crt",but can't find /etc/pki path in our Gargoyle,not very sure there was a certificate storage in our filesystem,so then redirect on modify wget

darui
Posts: 2
Joined: Sun May 03, 2020 3:44 am

Re: TroubleShooter-opkg-update-error

Post by darui »

maybe change some https certs

Post Reply