Version 1.9.1

The latest news about Gargoyle

Moderator: Moderators

User avatar
ericwong
Posts: 428
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Version 1.9.1

Postby ericwong » Tue Jul 19, 2016 10:40 pm

petbrau wrote:
ericwong wrote:There is something wrong with 1.9.1 when QoS is enabled. Without QoS, the router appears to function normally.

If Layer7 rules are used in QoS, this behavior is normal, due to the incorrect implementation of the Layer7 protocol by Eric.
Take a look at
http://www.gargoyle-router.com/phpbb/viewtopic.php?f=8&t=8299


I certainly have L7 rules in my QoS. This make sense now.

Can the moderator add warning to the download page about this behaviour for the corresponding firmware to avoid people getting into reboot loop and not knowing how to fix it.


kernel: finally remove layer7 filter support
it has been non-functional for years and caused numerous memleaks and crashes for people that tried to enable it.
it has no maintained upstream source, and it does not look like it's
going to be fixed any time soon

https://dev.openwrt.org/changeset/45423
Shouldn't there be a replacement for L7 protocol rather than fixing an outdated feature? I remember there was someone discussing about alternative to L7 in the forum before.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

Lantis
Moderator
Posts: 5012
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Postby Lantis » Tue Jul 19, 2016 11:34 pm

Again, on my very long todo list.

It's a big change though. So it's kind of low priority.
I'd rather fix people shooting themselves in the foot with the preserve settings issue first.

And before any of that, I'm also working with another user to get a massive GUI overhaul completed which will make gargoyle much faster, and easier to use across multiple device types (mobile etc) :)
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

User avatar
VAMET
Posts: 35
Joined: Thu Oct 23, 2014 7:25 pm
Location: Gdynia, Poland
Contact:

Re: Version 1.9.1

Postby VAMET » Thu Jul 21, 2016 6:16 am

Dear Friends

Does 1.9.1 fix bandwidth problem, which hasn't been fixed from 1.6.2? I had only 250/20Mbps on 1.6.2, any newer versions have got problem and with them I have only c.a. 180/20Mbps. So what about 1.9.1?

Sincerely
VAMET

Lantis
Moderator
Posts: 5012
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Postby Lantis » Thu Jul 21, 2016 7:30 am

There are no improvements for that issue
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

foxyboy
Posts: 59
Joined: Tue Dec 22, 2015 10:23 am
Location: Ireland

Re: Version 1.9.1

Postby foxyboy » Thu Jul 21, 2016 10:33 am

After upgrading my TL-WR1043ND v2.1 from V1.9.0. to V1.9.1 with Parameters being saved, I found I had to re-install some plugins-ins wheich had been installed to usb.

They were listed as Instaleld but were not available in GUI etc

An uninstall and re-install did the trick :-)
Linksys WRT1200AC v1 Gargoyle 1.11.X (Built 20180818)
TP-Link WR1043ND v2.1 Gargoyle 1.10
Ubiquiti Airrouter 1.9.X

meazz1
Posts: 65
Joined: Mon Dec 07, 2015 4:40 pm
Location: Auburn, GA. USA

Re: Version 1.9.1

Postby meazz1 » Thu Jul 21, 2016 10:28 pm

foxyboy wrote:After upgrading my TL-WR1043ND v2.1 from V1.9.0. to V1.9.1 with Parameters being saved, I found I had to re-install some plugins-ins wheich had been installed to usb.

They were listed as Instaleld but were not available in GUI etc

An uninstall and re-install did the trick :-)


How did you install on USB? Can you give me a brief instruction? I also have a 1043 V3 running gargoyle 1.9.1.

arejaytee
Posts: 17
Joined: Tue Jan 07, 2014 4:59 am

Re: Version 1.9.1

Postby arejaytee » Sat Jul 23, 2016 8:21 am

Lantis wrote:I'm also working with another user to get a massive GUI overhaul completed which will make gargoyle much faster, and easier to use across multiple device types (mobile etc) :)


Like the interface on this? https://www.synology.com/en-uk/products/RT1900ac ! I kid but damn i wish we could have some of the extra gargoyle features on that!

sp_archer
Posts: 4
Joined: Thu Jun 20, 2013 10:44 am

Re: Version 1.9.1

Postby sp_archer » Sun Jul 24, 2016 8:33 am

TP-Link TL-WDR3600 v1 - flashed successfully, works fine.

mpp
Posts: 4
Joined: Tue Jul 26, 2016 12:48 pm

Re: Version 1.9.1

Postby mpp » Tue Jul 26, 2016 1:23 pm

Hello all,

I am new here. I was pleased to find a flash for my TP-Link Archer C7 V2 router which has a very strong wireless signal. I purchased this router off of the original owner who had it for a couple of months on April 5, 2015.

Since my ISP has imposed 150-gigabyte limit on my monthly bandwidth usage, I must assure that we do not go over that limit. The grandkids are now visiting out of province and I want to assure that they are limited to their downloads in order to tow the line. Now, The first time I attempted to impose download limits on my grandchildren, the Archer factory software proceeded to freeze internet activity to anyone on the network. Obviously, I needed to remove the download restriction to get the use of my wireless network again.

It is for this reason, I turned to Gargoyle in hopes of better monitoring my network and being able to successfully impose download limits on chosen users. I will have to play around with this a little to figure out how best to do it.

I currently have the router flashed with version 1.8.1. I understand that this is termed as a stable release. I like the idea of having stable software running on the router. The flash worked brilliantly on the first attempt. Kudos to the developers and the all the hard work of those who made this possible.

I have read that 1.9.1 "Handles wireless AC routers properly". I assume this means that 1.8.1 does not handle AC routers such as mine properly. Please correct me if my understanding is correct.

I also read that the 1.9.1 software hangs the new 2016 Archer C7 router (ish). Since we do a lot of streaming I would like to have the AC wireless handled properly. I just want to assure that my router can handle the 1.9.1 release before I flash it. Can someone, please offer some assurance that I can flash the 1.9.1 version without having my Archer C7 V2 hang on me?

Thank you very much in advance.

Regards.

:)

Lantis
Moderator
Posts: 5012
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Postby Lantis » Tue Jul 26, 2016 4:37 pm

It should be fine as long as you don't preserve your settings when you upgrade
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases


Return to “News”

Who is online

Users browsing this forum: No registered users and 2 guests