Version 1.7.2

The latest news about Gargoyle

Moderator: Moderators

User avatar
apvm
Posts: 90
Joined: Thu Apr 30, 2015 7:30 am

Re: Version 1.7.2

Postby apvm » Wed Jul 22, 2015 12:47 am

Just updated to 1.7.2 and restored saved configuration from 1.7.x 1043nd v1.7 by the way where is the adlock located, can't find it.

tapper
Moderator
Posts: 1064
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Version 1.7.2

Postby tapper » Wed Jul 22, 2015 1:56 am

apvm wrote:Just updated to 1.7.2 and restored saved configuration from 1.7.x 1043nd v1.7 by the way where is the adlock located, can't find it.


Hi after you have installed it from the plugins page it should show up under firewall.
Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

User avatar
apvm
Posts: 90
Joined: Thu Apr 30, 2015 7:30 am

Re: Version 1.7.2

Postby apvm » Wed Jul 22, 2015 2:19 am

tapper wrote:
apvm wrote:Just updated to 1.7.2 and restored saved configuration from 1.7.x 1043nd v1.7 by the way where is the adlock located, can't find it.


Hi after you have installed it from the plugins page it should show up under firewall.


Thanks, I thought it was preinstalled.

StyXziBITiz
Posts: 3
Joined: Sun Jul 19, 2015 1:54 pm

Re: Version 1.7.2

Postby StyXziBITiz » Wed Jul 22, 2015 9:34 am

It would be nice if the TOR-Plugin issue could be fixed

TP Link Archer C5 and C7

nworbnhoj
Posts: 914
Joined: Mon Jul 21, 2014 10:08 am
Location: Australia
Contact:

Re: Version 1.7.2

Postby nworbnhoj » Wed Jul 22, 2015 5:24 pm

nworbnhoj wrote:Successfully installed on TL-WDR3600 including 3G, Tor, Dynamic DNS, port forwarding, Adblock, Quotas, QoS, USB Storage.
I am also broadcasting a Guest network on 2.4GHz only, with WPA2 PSK. From time to time (2-24hrs) this Guest network stops broadcasting despite having 4-6 wifi client connected. The primary wifi SSID continues to operate correctly (Dual Band 20MHz ch11 & 40MHz (2nd channel above) ch157).
/etc/init.d/network restart resolves the issue.
I have not been able to identify any relevant log entries when the problem occurs.
Any more info I can collect?
Can you help someone else get Gargoyle up and running?
TL-WDR3600 : Gargoyle 1.9.0 : NBN FixedWireless
TL-WR1043ND-V2 : Gargoyle 1.8.0 : 3G Huawei E160E

olivier2
Posts: 3
Joined: Thu Mar 26, 2015 11:26 pm

Re: Version 1.7.2

Postby olivier2 » Fri Jul 24, 2015 7:11 pm

Successfully installed 1.7.2 on a WDR4300 along with the Tor plugin and everything works perfectly! Kudos for a great job.

However, the Tor package in the plugin is version 0.2.5.10 from October 2014. It has been superseded by three stables versions since then: 0.2.5.11, 0.2.5.12 and the latest stable 0.2.6.10. (See https://dist.torproject.org)

Can the plugin be updated to the latest Tor, 0.2.6.10?
Or is this something that we, as users, can do manually by ourselves?

No one likes to run old/outdated/insecure packages on this brand-spanking new Gargoyle.

joequant
Posts: 16
Joined: Thu Mar 05, 2015 12:57 am

Re: Version 1.7.2

Postby joequant » Sat Jul 25, 2015 1:30 pm

Just a report on 1.7.2

I upgraded from 1.7.1 to 1.7.2 on my TP-Link TL-WR1043N/ND v1

I tried to keep the system settings, and that seemed to causing instability as the router would reboot every minute. I went back to 1.7.1 and reflashed not keeping the system settings, and everything seems to be working well.

joequant
Posts: 16
Joined: Thu Mar 05, 2015 12:57 am

Re: Version 1.7.2

Postby joequant » Sat Jul 25, 2015 1:32 pm

jachsz wrote:Any one upgraded to 1.7.2 to TP-Link TL-WR1043N/ND V1. Any problem expected?


Yes. I did it. The only gotcha was that it was very unstable when I tried to preserve system settings, so it would be better to do backup/restore of system settings and not to try to preserve the settings.

Other than that everything is nice.

Lantis
Moderator
Posts: 4958
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.7.2

Postby Lantis » Sat Jul 25, 2015 8:22 pm

I'm going to update the first post to recommend people don't preserve settings. I did mention this but it's obviously being missed.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

tanemann
Posts: 5
Joined: Sun Apr 05, 2015 5:43 am

Re: Version 1.7.2

Postby tanemann » Sun Jul 26, 2015 5:12 am

QMI support still seems to be broken, but I got it working after these two fixes:
In cache_basic_vars.sh the line

Code: Select all

echo "qmiInterface=\"$qmi_if\";"

should be be

Code: Select all

echo "qmiInterface=\"$qmi_if\";" >> "$out_file"


The file /utility/scan_qmidevices.sh is still missing, so scanning for QMI devices doesn't work at all on the Connection -> Basic page. In my case it should output /dev/cdc-wdm0. When I enter that manually as the device, I get a working LTE connection.


Return to “News”

Who is online

Users browsing this forum: No registered users and 3 guests