Version 1.7.0 - Barrier Breaker

The latest news about Gargoyle

Moderator: Moderators

nieroster
Posts: 27
Joined: Sun Apr 14, 2013 10:56 am

Re: Version 1.7.0 - Barrier Breaker

Postby nieroster » Mon Jan 05, 2015 2:28 pm

First of all: Thank you Eric! Finally we get a BB build of Gargoyle!

What i've noticed is that my USB Printer does not show up in this build, using a Netgear WNDR3700 + HP Photosmart D5160.

It did work on ispyisail's build from January 3rd though.

nieroster

EDIT:

here are the log entries when plugging in the printer:

Code: Select all

Tue Jan  6 12:30:00 2015 kern.info kernel: [  149.810000] usb 1-1: new high-speed USB device number 2 using ehci-platform
Tue Jan  6 12:30:00 2015 kern.info kernel: [  149.970000] usblp 1-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x03F0 pid 0xC402
Tue Jan  6 12:30:00 2015 kern.info kernel: [  149.980000] usb-storage 1-1:1.2: USB Mass Storage device detected
Tue Jan  6 12:30:00 2015 kern.info kernel: [  150.000000] scsi0 : usb-storage 1-1:1.2
Tue Jan  6 12:30:01 2015 kern.notice kernel: [  151.000000] scsi 0:0:0:0: Direct-Access     HP       Photosmart D5100 1.00 PQ: 0 ANSI: 2
Tue Jan  6 12:30:01 2015 kern.notice kernel: [  151.010000] sd 0:0:0:0: [sda] Attached SCSI removable disk
Tue Jan  6 12:30:21 2015 user.err syslog: Unkown action change
Tue Jan  6 12:30:21 2015 user.err syslog: Unkown action change

Maybe it's the integrated card reader which irritates gargoyle.
Last edited by nieroster on Tue Jan 06, 2015 7:34 am, edited 1 time in total.

zero
Posts: 1
Joined: Mon Jan 05, 2015 3:11 pm

Re: Version 1.7.0 - Barrier Breaker

Postby zero » Mon Jan 05, 2015 3:18 pm

There seems to be problem with plugins, i can install it but I can not remove it after, using web-gui or opkg. trying to uninstall plugin from opkg result in segmentation fault.
The only plugins sucessfully installed and uninstalled is themes (in this case i use light-theme).

my details :
- plugin-root in usb flash drive formatted as ext4 in dev/sda1
- i also have swap partition in /dev/sda2
- using tp-link tl-wdr4300 v1
- tried firmware upgrade from sysupgrade or factory 1.7.0 without preserving any setting, the plugin is removed, but after I installed it again it became uninstallable.
- previous version (1.6.2 <) the plugins can be installed and removed successfully.

any ideas?

ispyisail
Moderator
Posts: 4562
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.7.0 - Barrier Breaker

Postby ispyisail » Mon Jan 05, 2015 3:39 pm

Eric is in the Zone

It appears that he is patching as fast as you guys are reporting

Next build will be up in a few minutes

phgerin
Posts: 101
Joined: Sun Dec 21, 2014 2:03 pm

Re: Version 1.7.0 - Barrier Breaker

Postby phgerin » Mon Jan 05, 2015 3:47 pm

Download speed reported via UPNP is still broken after a few hours (maybe after 4GB transfert).

nworbnhoj
Posts: 914
Joined: Mon Jul 21, 2014 10:08 am
Location: Australia
Contact:

Re: Version 1.7.0 - Barrier Breaker

Postby nworbnhoj » Mon Jan 05, 2015 4:32 pm

Thank you Eric for all the great work - appreciate it!

I loaded 1.7.0 onto a TP-Link TL-WR1043N/ND v2 successfully.

However, when configured as a Gateway, the Internet/WAN interface does not offer a 3G (GSM) option despite a Huawei E160E modem being plugged into the USB port. The modem has power and the status light indicates that a 3G signal is available.

I have rolled back to Gargoyle 1.6.2 where the 3G connection works with the Huawei E160E modem.

Continued at http://www.gargoyle-router.com/phpbb/viewtopic.php?f=11&t=6563
Last edited by nworbnhoj on Tue Jan 06, 2015 5:05 am, edited 1 time in total.
Can you help someone else get Gargoyle up and running?
TL-WDR3600 : Gargoyle 1.9.0 : NBN FixedWireless
TL-WR1043ND-V2 : Gargoyle 1.8.0 : 3G Huawei E160E

ispyisail
Moderator
Posts: 4562
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.7.0 - Barrier Breaker

Postby ispyisail » Mon Jan 05, 2015 4:57 pm


ispyisail
Moderator
Posts: 4562
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.7.0 - Barrier Breaker

Postby ispyisail » Mon Jan 05, 2015 4:59 pm

nworbnhoj wrote:Thank you Eric for all the great work - appreciate it!

I loaded 1.7.0 onto a TP-Link TL-WR1043N/ND v2 successfully.

However, when configured as a Gateway, the Internet/WAN interface does not offer a 3G (GSM) option despite a Huawei E160E modem being plugged into the USB port. The modem has power and the status light indicates that a 3G signal is available.

I have rolled back to Gargoyle 1.6.2 where the 3G connection works with the Huawei E160E modem.


Can you check

Code: Select all

logread


just after you plug you 3g dongle in?

Volaris
Posts: 163
Joined: Thu May 01, 2014 1:02 pm

Re: Version 1.7.0 - Barrier Breaker

Postby Volaris » Mon Jan 05, 2015 5:22 pm

Thanks for the update!

I updated my Linksys WRT400N from 1.6.1 to 1.7 (it didn't like 1.6.2) and it seems to work fine. 5GHz works much better now (range and tx rate actually maxes out!).

My only concern is that CPU usage seems a bit high? Registering 0.25-0.75 (saw it go up to 1.65) CPU usage, even with low usage on my slow connection (not logging anything other than default, either). Previously I recall those numbers rarely going above 0.20. Router has a 680MHz CPU. Are these normal numbers?
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Andy
Posts: 21
Joined: Wed Oct 01, 2014 10:51 pm

Re: Version 1.7.0 - Barrier Breaker

Postby Andy » Mon Jan 05, 2015 5:32 pm

Flashed onto a WDR3600 and works fine so far!
Last edited by Andy on Mon Jan 05, 2015 6:05 pm, edited 2 times in total.

User avatar
djt_nz
Posts: 26
Joined: Mon May 07, 2012 1:00 am
Location: New Zealand

Re: Version 1.7.0 - Barrier Breaker

Postby djt_nz » Mon Jan 05, 2015 5:41 pm

Before I start a custom build can someone confirm if the bb branch has been merged back into master. So I no longer need to do a "git checkout bb"
I don't use git much, more of a svn man, find git a bit confusing at times :cry:
TL-WR1043ND V1.8 (Gargoyle 1.7.X git@701d7f5) djt build


Return to “News”

Who is online

Users browsing this forum: No registered users and 3 guests