Version 1.6.1 - Heartbleed Fix

The latest news about Gargoyle

Moderator: Moderators

Eric
Site Admin
Posts: 1441
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.6.1 - Heartbleed Fix

Post by Eric »

I'm not sure how the uci setting for fallback language is getting wiped out, but I just committed an update to the i18n haserl code so this shouldn't ever happen, and the language should default to English if it can't load the current language specified in UCI.

ispyisail, also see my post above responding to gumball3000 above, there should be a fairly simple fix if you ssh into the router and run the commands I have listed.

leraptor06
Posts: 1
Joined: Mon Apr 28, 2014 10:54 am

Re: Version 1.6.1 - Heartbleed Fix

Post by leraptor06 »

Hello,
i was using a TP-Link TL-WR1043N/ND v1 with the "old" firmware 1.5 and all was fine. But now with the 1.61 i need to reboot every day in order to have a wireless connection. :cry:

erez669
Posts: 112
Joined: Sun May 12, 2013 4:52 pm

Re: Version 1.6.1 - Heartbleed Fix

Post by erez669 »

which version exactly? i consider to downgrade the firmware to get stable connection on wifi without the daily schedule reboot.

swensonator
Posts: 3
Joined: Mon Apr 28, 2014 5:18 pm

Re: Version 1.6.1 - Heartbleed Fix

Post by swensonator »

I have the same problem as leraptor06.

TL-WR1043ND v1.8 requires reboot in order for wireless to connect using 1.6.1 (i.e. every time I wake up my laptop I need to reboot router). Problem did not exist with 1.5.11 (never used 1.6.0). Everything else works as expected after the upgrade. The wireless signal is broadcasting (ssid is seen), but I get a "timeout" error if I try to force connect.

Cyclops
Posts: 3
Joined: Thu May 01, 2014 3:14 pm

Re: Version 1.6.1 - Heartbleed Fix

Post by Cyclops »

I have two TP-Link WR1043ND, a v1.1 and a v1.6 and both have been working fine so far. The v1.1 has been with the 1.6.0 version for a month or so, the v1.6 was just freshly installed to extend the network but seems ok.

erez669
Posts: 112
Joined: Sun May 12, 2013 4:52 pm

Re: Version 1.6.1 - Heartbleed Fix

Post by erez669 »

i decided to revert back to the stock firmware, until issues was resolved.
TP-LINK released new firmware version that i testing now.

User avatar
KREAT0R
Posts: 39
Joined: Wed Sep 05, 2012 2:27 am
Location: Argentina

Re: Version 1.6.1 - Heartbleed Fix

Post by KREAT0R »

Works perfects. Thx

Image
Last edited by KREAT0R on Sun May 04, 2014 7:35 pm, edited 1 time in total.
Router test: wr841nd v5

dieres
Posts: 12
Joined: Wed Nov 03, 2010 8:33 am

Re: Version 1.6.1 - Heartbleed Fix

Post by dieres »

There seems to be a bug in wireless repater mode. If some client logs into gargoyle and not the repeated ssid, the gargoyle router and all behind it, is no more accessable until reboot. From logging in to fail it lasts ca. 10 sec.

iptables?

tplink wrd 4300 to repeat a fritzbox 7390.

gumball3000
Posts: 28
Joined: Mon Apr 08, 2013 8:20 am

Re: Version 1.6.1 - Heartbleed Fix

Post by gumball3000 »

swensonator wrote:I have the same problem as leraptor06.

TL-WR1043ND v1.8 requires reboot in order for wireless to connect using 1.6.1 (i.e. every time I wake up my laptop I need to reboot router). Problem did not exist with 1.5.11 (never used 1.6.0). Everything else works as expected after the upgrade. The wireless signal is broadcasting (ssid is seen), but I get a "timeout" error if I try to force connect.

I also got this problem
Wi-fi was stable on my TL-WR1043ND v1.8 with Gargoyle 1.6.0, on 1.6.1 i cannot connect my phone anymore to the router, i also get timeout and I need to reboot the router to fix it

mpmc
Posts: 7
Joined: Sun Oct 30, 2011 11:40 am

Re: Version 1.6.1 - Heartbleed Fix

Post by mpmc »

leraptor06 wrote:Hello,
i was using a TP-Link TL-WR1043N/ND v1 with the "old" firmware 1.5 and all was fine. But now with the 1.61 i need to reboot every day in order to have a wireless connection. :cry:
I have a TP-Link TL-WR1043ND v1.7 and suffer from the same issue :cry:

Post Reply