Version 1.6.1 - Heartbleed Fix

The latest news about Gargoyle

Moderator: Moderators

Dev_BR
Posts: 87
Joined: Fri Jan 27, 2012 6:55 am

Re: Version 1.6.1 - Heartbleed Fix

Postby Dev_BR » Wed Apr 23, 2014 7:52 pm

Hi all

I just Updated a WDR3600 and WR3420 for v1.6.1 and all seems nice.

If you use TOR, please read this topic for feature request, please
viewtopic.php?f=13&t=5585

Bazou
Posts: 8
Joined: Wed Nov 21, 2012 10:36 am

Re: Version 1.6.1 - Heartbleed Fix

Postby Bazou » Thu Apr 24, 2014 7:48 am

Hi all,
I've successfully upgraded my wzr-hp-g450h to 1.6.1.

Thanks.

rt_rex
Posts: 44
Joined: Mon Aug 15, 2011 9:39 am

Re: Version 1.6.1 - Heartbleed Fix

Postby rt_rex » Thu Apr 24, 2014 8:34 am

I just installed Gargoyle 1.6.1 on my Alix 2c2 and it only shows only one wifi to configure in the web interface.
I am using two AR5414 mini pci cards (abg).
On the console there is also only one interface.

This is the first time i use gargoyle on this platform are there any tricks to make it show the two wifi's ?
WIFI Link @ 76 km

http://youtu.be/rrXanzlro78

Eric
Site Admin
Posts: 1436
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.6.1 - Heartbleed Fix

Postby Eric » Thu Apr 24, 2014 10:11 am

gumball3000: I've tested again, and still can't reproduce the error. One way to correct it is to ssh into the router and then run:

Code: Select all

uci set gargoyle.global.fallback_lang=English-EN
uci set gargoyle.global.language=English-EN
uci commit


tapper: I'm not sure exactly what's going on -- I tried to reproduce with your exact setup, and it seems to be working for me. One thing you might try is to disable your swap partition, since the 1043 v2 has 64MB of memory, which should be (just barely) enough to run Tor. I've noticed in the past that while using swap increases the number of applications that can run simultaneously, it also can make things less stable because memory access time increases dramatically. It's possible that slow swap access is causing problems -- try disabling the swap and see if this helps.

Dev_BR: The gargoyle tor plugin version is 1.6.1-1, which refers to the version number for the web interface that controls tor. The underlying Tor version in Gargoyle 1.6.1 is 0.2.4.21. If you ssh into the router and run /usr/sbin/tor --version you will see "Tor version 0.2.4.21 (git-505962724c05445f)."

rt_rex: Unfortunately gargoyle currently only supports configuring one wireless card at a time right now, with the exception of routers that have dual band support. Because they are expensive, development for alix boards, and others that have slots for multiple wifi cards has not been a top priority.

mtr
Posts: 29
Joined: Sun Oct 28, 2012 1:14 pm

Re: Version 1.6.1 - Heartbleed Fix

Postby mtr » Thu Apr 24, 2014 11:46 am

I've upgraded my TL1043ND v1.8 from v1.6.0 to v1.6.1 without issues so far :mrgreen:

Dev_BR
Posts: 87
Joined: Fri Jan 27, 2012 6:55 am

Re: Version 1.6.1 - Heartbleed Fix

Postby Dev_BR » Thu Apr 24, 2014 1:45 pm

I installed 1.6.1 twice before submit this possible bug.

Router: WDR 3600

There is a problem on web interface, it seems like a draft.
I cant install other Theme neither select other theme already installed.
It install new theme, but not show on list.

Dev_BR
Posts: 87
Joined: Fri Jan 27, 2012 6:55 am

Re: Version 1.6.1 - Heartbleed Fix

Postby Dev_BR » Thu Apr 24, 2014 3:41 pm

Its no more install TOR on WDR3600

External USB used as pluging root: 873.348MBytes Free

TOR: 721.151 kBytes

Dev_BR
Posts: 87
Joined: Fri Jan 27, 2012 6:55 am

Re: Version 1.6.1 - Heartbleed Fix

Postby Dev_BR » Thu Apr 24, 2014 5:28 pm

Apparently, all related problems I faced with WDR3600 are solved after send a fisrtboot command, and reinstall firmware, without attempt to preserve old configuration.

And, after format USB disk for 10% Swap and 90% Storage, and setup Plugins to USB disk, I installed TOR, OpenVPN, DLNA, Webcam and a couple of themes.

There is just a minor problem to turn TOR on and off.
Sometimes it shows TOR enabled (for your ip), but its not using TOR network. Same happens for Disabled state (its still using TOR but shows as disabled)

After log in/ log out router, TOR state become correct.

ispyisail
Moderator
Posts: 4599
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.6.1 - Heartbleed Fix

Postby ispyisail » Fri Apr 25, 2014 3:46 am

gumball3000 wrote:[BUG REPORT]
After i choose Restore Default Configuration the router doesn't reboot by itself, and if i try to access the default link, i receive the following message:
haserl CGI Error

The fallback language was not set for gargoyle.global.fallback_lang


I had to reboot the rooter via SSH.


I have this exact error happen to me :(

ispyisail
Moderator
Posts: 4599
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.6.1 - Heartbleed Fix

Postby ispyisail » Fri Apr 25, 2014 3:49 am

For some reason one of my routers is having trouble pulling an IP address on the WAN port. (other routers working fine)

When I tried to reset the router I got the above error (post above)

:(


Return to “News”

Who is online

Users browsing this forum: No registered users and 1 guest