Version 1.5.10

The latest news about Gargoyle

Moderator: Moderators

P-O
Posts: 18
Joined: Thu Dec 06, 2012 5:30 am

Re: Version 1.5.10

Post by P-O »

Hi!

I have a setup with a Gigagabit backbone. One D-Link DGS-1005 and one DGS-1008D switch. I use one Ubiquiti Airrouter as access point with stock firmware and one with Gargoyle as a Gateway and wireless access point now updated to 1.5.10.

This setup has worked extremly well. The Airrouters seems to be very reliable from a company that manufacture enterprise Wlan equipment.
The stock firmware has a built in wireless spectrum analyzer, this is one of the reasons for having one as a wireless bridge.
The Airrouter is AR7241/AR9285 based with a CPU-speed of 400MHz and 8/32 memory. Wlan up to 150Mbps. 1 USB 2.0 4+1 100Mbps LAN ports.
It was easy to flash it with Gargoyle.

I got a problem with frequent (minutes or seconds) wireless dropouts after the upgrade from 1.5.9 to 1.5.10. By reducíng the wireless power from max (27dBm) to 23dBm the problem was solved.

I have two issues right now:

1: The high resolution timeframe bandwith data seems to be limited to only a few connected stations after a couple of minutes. It might be a memory issue.

2: It seems impossible to use USB as added memory. The USB storage plugin seems to need 4.8MB of memory and this is not available.

Otherwise everything works perfect!!
I have set up QoS rukes for TV-streaming , backup.....

Gargoyle is an incredible good router software!

Thanks!

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: Version 1.5.10

Post by DoesItMatter »

Right, you can't use USB memory to increase the router memory.

I THINK you can add some SWAP space to your USB though.

Best is to use a linux machine or boot with a live CD and re-partition
the USB device to have a 64MB or 128MB swap partition

If you reboot the router, it should make use of the swap space

I've done this, but I've never loaded the router enough to validate
whether or not the swap space helped.
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

pmerrill
Posts: 287
Joined: Wed Feb 15, 2012 8:23 pm

Re: Version 1.5.10

Post by pmerrill »

gargoyler wrote:That is what I thought when I read it. I am sticking with Gargoyle, TP-Link can either do something about problems their customs are confronting them with (wireless issues on the 1043nd are all over the web) or else it's no more TP-Link for me.


I really think the problem may lie with the 1043nd hardware. The 1043nd uses a Atheros AR9132 running at 400MHz, which is not overly fast. My belief is that due to the speed, there are some occasional problems due to the combination of the hardware and software. For example, the software may generate too much load on the CPU at some point such that interrupts may be lost or packets go missing. This then causes re-transmits and the router gets into a state that it doesn't handle properly.

It you get a faster CPU (mine is the TP-Link 4300 running at 560Mhz), then the problems do not occur because the CPU does not "get behind".

I worked on microprocessors and firmware in real-time systems for many years and the hardest problem with an underpowered CPU is dealing with all the interrupts and having to process the demand in time. We always had a problem with missing interrupts (meaning that one cannot process the interrupts fast enough), and the error recovery once that happens can be very tricky. I'm not sure about the OPEN WRT code but we always had to code those interrupt routines in assembler, not C, because of the inefficiencies that C introduced (loading the stack with all registers on the call of a subroutine takes too long).

Net upshot, dump the 1043nd in favour of a faster CPU, like the TP-Link 4300 or the Netgear 3700v2, which has a 680MHz AR7161.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

demoralized
Posts: 23
Joined: Mon May 20, 2013 2:16 am

Re: Version 1.5.10

Post by demoralized »

Well looks like my router is a bad one. 1.5.10 is still unstable for WR1043ND 1.10

Pluged back my WRT160N v3 with dd-wrt 21676.

Now i wil use the other as a beta testing.

remind1
Posts: 2
Joined: Thu Jul 04, 2013 12:08 pm

Re: Version 1.5.10

Post by remind1 »

I have a problem on TP-LINK 740N v4.23 and v4.26 and v2.0 741ND. After a while, the wifi network is no longer visible. The device works in AP mode. Let's remove this vulnerability? Version 1.5.10.

demetris
Posts: 17
Joined: Fri Feb 11, 2011 3:12 am

Re: Version 1.5.10

Post by demetris »

41 days, 15 hours, 38 minutes on 1043ND, no problems what so ever.
Working flawlessly.

demoralized
Posts: 23
Joined: Mon May 20, 2013 2:16 am

Re: Version 1.5.10

Post by demoralized »

What HW version?

sajjadhalai
Posts: 108
Joined: Sun Apr 08, 2012 6:54 am

Re: Version 1.5.10

Post by sajjadhalai »

I compiled 1.5.10 manually.. .. and i Set from config
1- garoyle_plugin_openvpn as Manual install
2- gargoyle-plugin-Tor as Manual install
//
problem was happening that. when i use quota and throttle speed...
when the quota is cmpleted then it always shutdown,, but i didnot set it on shutdown internet acces, but i set it to throttle Speed..SO it is not working on throtiling speed.

when i installed open vpn and tor.. then it worked... why throttling speed in quota has link with vpn or tor..
plz make them indepenadant

supedupe
Posts: 2
Joined: Tue Jul 09, 2013 2:32 pm

Re: Version 1.5.10

Post by supedupe »

I haven't seen anyone mention it so I just wanted to say that it appears theres a new 1043nd HW version out, I just ordered one last week and it arrived as version 1.11. I was able to flash it with 1.5.10 just fine, after making sure openwrt was compatible with 1.11. 1.11 requires Attitude Adjustment 12.09 final. Gargoyle 1.5.10 is the only version that has it; if you do not use 1.5.10 (or later when they're released in the future) you are likely to brick your 1.11 1043nd.

It has been stable for about a week so far.

gargoyler
Posts: 8
Joined: Thu Jun 20, 2013 8:14 am

Re: Version 1.5.10

Post by gargoyler »

Well, after some weeks of good luck, my 1043nd v 1.8 is acting up again. Every few days (sometimes every day) my wireless connections cripples to 2 mb/s and won't go any faster. Only a reboot fixes the issue. I've set a scheduled reboot every night, but even ater the reboot it sometimes happens. I've updated to version 1.5.10, maybe this will solve the problem but I am kind of getting tired of this device. I've also inceased the maximum number of connections on the router, as there is a lot of filesharing going on in this house. I will give the device a go for another month, but after that I'm probably goiung to buy a new router. I just can't believe the number of problems I've read about this router on other forums, but on this forum as well. The funny thing is, it worked perfectly the first couple of months I had it... Like a person, the older it gets, the more problems it gets..

Post Reply