Version 1.5.9 - Plugins Interface

The latest news about Gargoyle

Moderator: Moderators

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - OpenVPN

Post by yc3948 »

Many thanks! I find the problem! After I upgrade OpenVPN client software to openvpn-install-2.3.0-I001-i686 it works!!! :D :D :D

7PBHChD wrote:
yc3948 wrote:I try tracert command when I use Gargoyle OpenVPN traffic not go
through Gargoyle OpenVPN server at all!!! :oops: :oops: :oops:

And I try you solution, but unfortunately it not working for me, did you test it? Thanks

7PBHChD wrote:No. I mean did you go to the web link I gave and denied access to your clients or any of your router clients have access through the router?
My fault was I deny all access except for certain clients.
So I permitted OpenVPN client address on that page to allow him have access to the Internet.
If you did not restrict access and your OpenVPN client still not go through your router you can change route in /etc/config/ccd/<Nameofyourclientnconfg> from 'push "route 192.168.1.0 255.255.255.0 10.8.0.1" ' to 'push "route 0.0.0.0 0.0.0.0 10.8.0.1" '. After that reconnect your OpenVPN clent and check its IP.

Yes. I tested the route and it works flawlessly.
But now, I do not use custom route at all.
The issue was in restrictions that applied to the OpenVPN client in my configuration, as i restrict all Internet and Intranet access by default.
After I allowed traffic for OpenVPN client and set option 'Clients Use VPN For:' to 'All Client Traffic' I can use Internet through my router.
What client are you connecting to OpenVPN?
can you give its routes info?
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Post by yc3948 »

Last edited by yc3948 on Sat Jan 19, 2013 4:50 am, edited 1 time in total.
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - OpenVPN

Post by yc3948 »

OpenVPN problems fixed. http://www.gargoyle-router.com/gargoyle ... 39622d205d

7PBHChD wrote:
yc3948 wrote:I try tracert command when I use Gargoyle OpenVPN traffic not go
through Gargoyle OpenVPN server at all!!! :oops: :oops: :oops:

And I try you solution, but unfortunately it not working for me, did you test it? Thanks

7PBHChD wrote:No. I mean did you go to the web link I gave and denied access to your clients or any of your router clients have access through the router?
My fault was I deny all access except for certain clients.
So I permitted OpenVPN client address on that page to allow him have access to the Internet.
If you did not restrict access and your OpenVPN client still not go through your router you can change route in /etc/config/ccd/<Nameofyourclientnconfg> from 'push "route 192.168.1.0 255.255.255.0 10.8.0.1" ' to 'push "route 0.0.0.0 0.0.0.0 10.8.0.1" '. After that reconnect your OpenVPN clent and check its IP.

Yes. I tested the route and it works flawlessly.
But now, I do not use custom route at all.
The issue was in restrictions that applied to the OpenVPN client in my configuration, as i restrict all Internet and Intranet access by default.
After I allowed traffic for OpenVPN client and set option 'Clients Use VPN For:' to 'All Client Traffic' I can use Internet through my router.
What client are you connecting to OpenVPN?
can you give its routes info?
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

ispyisail
Moderator
Posts: 4882
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.5.9 - Plugins Interface

Post by ispyisail »


yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Post by yc3948 »

thanks for share, I'm happy with 1.5.9+ http://www.gargoyle-router.com/gargoyle ... 39622d205d updated ;)

ispyisail wrote:update

viewtopic.php?f=14&t=3727
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

buddee
Posts: 50
Joined: Sat Oct 01, 2011 8:13 am

Re: Version 1.5.9 - Plugins Interface

Post by buddee »

ispyisail wrote:update

viewtopic.php?f=14&t=3727


Excellent, this is fixing the issue i mentioned earlier in this thread, i can now reboot on the wzr-hp-g300nh v1 and wireless doesn't go to disabled after a reboot. Thank you!

buddee
Posts: 50
Joined: Sat Oct 01, 2011 8:13 am

Re: Version 1.5.9 - Plugins Interface

Post by buddee »

actually scratch that, problem still exists with wzr-hp-g300nh v1, when i reboot the wireless comes back up as disabled.

shastar
Posts: 6
Joined: Tue Jul 12, 2011 11:07 am

Re: Version 1.5.9 - Plugins Interface

Post by shastar »

Have flashed 1.5.9 on the TP-Link wr2543nd without problems. Everything seems to be working correctly. Except 5GHz mode (channel 13 to 165) Never worked with gargoyle on this router. Works well with TP-Link original firmware.

Very good job to all involved with the gargoyle.
http://db.tt/hgKEJOHq

ohh..my english is bad...

mtr
Posts: 29
Joined: Sun Oct 28, 2012 1:14 pm

Re: Version 1.5.9 - Plugins Interface

Post by mtr »

I'm using Gargoyle 1.5.9 and No-IP.org updating suddenly stop working.

So, I changed this config (on /etc/ddns_providers.conf) based on http://www.noip.com/integrate/request:

Code: Select all

service no-ip.com
    url_template    https://dynupdate.no-ip.com/ducupdate.php?username=[[USERNAME]]&pass=[[PASSWORD]]&h[]=[[DOMAIN]]&ip=[[IP]]
    required_variables    domain username password
    required_variable_names    Domain Name,Username,Password
    success_regexp    /:01/


to this config:

Code: Select all

service no-ip.com
   url_template         https://[[USERNAME]]:[[PASSWORD]]@dynupdate.no-ip.com/nic/update?hostname=[[DOMAIN]]&myip=[[IP]]
   required_variables      domain username password
   required_variable_names      Domain Name,Username,Password
   success_regexp         /^(good|nochg)/


and works like a charm.

Eric
Site Admin
Posts: 1441
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.5.9 - Plugins Interface

Post by Eric »

FireVortex: Thanks for bringing this to my attention, and for providing a working fix. I love when bug reports include a solution! I've updated the No-IP code as suggested and it will be included in the next release.

Post Reply