Version 1.5.9 - Plugins Interface

The latest news about Gargoyle

Moderator: Moderators

lceron80
Posts: 112
Joined: Sun Jul 24, 2011 3:42 pm

Re: Version 1.5.9 - Plugins Interface

Post by lceron80 »

Cezary wrote:File permissions in template. I've sent fix to repo: https://github.com/obsy/gargoyle/commit ... c7ab1ea0a3


Thanks a lot cesary
1x wndr3700v4 exp. 1.9.x
1x wndr3800 exp. 1.9.x
1x wndr4300v1 exp. 1.9.x
1x wndrmacv2 exp. 1.9.x

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Post by yc3948 »

Many thanks for the 1f082daf, it fix openvpn :D :D :D
Cezary wrote:File permissions in template. I've sent fix to repo: https://github.com/obsy/gargoyle/commit ... c7ab1ea0a3
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

Cezary
Posts: 133
Joined: Thu Sep 11, 2008 12:57 pm
Location: Poland
Contact:

Re: Version 1.5.9 - Plugins Interface

Post by Cezary »

You're welcome.

pmerrill
Posts: 289
Joined: Wed Feb 15, 2012 8:23 pm

Re: Version 1.5.9 - Plugins Interface

Post by pmerrill »

If I want to downgrade from 1.5.9 to 1.5.8, can I backup the 1.5.9 setup and restore to 1.5.8? I am not using any of the new 1.5.9 functionality, so I'm hoping this will work to save some time.

I'm having too many problems with 1.5.9 so want to see if 1.5.8 is better on my router.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: Version 1.5.9 - Plugins Interface

Post by DoesItMatter »

pmerrill wrote:If I want to downgrade from 1.5.9 to 1.5.8, can I backup the 1.5.9 setup and restore to 1.5.8? I am not using any of the new 1.5.9 functionality, so I'm hoping this will work to save some time.

I'm having too many problems with 1.5.9 so want to see if 1.5.8 is better on my router.


1.5.6 is the last Backfire OpenWRT branch for Gargoyle

You should be able to flash between 1.5.7 / 1.5.8 / 1.5.9
and keep the configuration files - but I've encountered random glitches
between upgrades.

Safest is always reset to defaults, and fresh flash without keeping settings

If anything is acting up with your wireless - try going back to 1.5.6
but you CANNOT keep your 1,5,7+ config files - have to fresh config.
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

pmerrill
Posts: 289
Joined: Wed Feb 15, 2012 8:23 pm

Re: Version 1.5.9 - Plugins Interface

Post by pmerrill »

pmerrill wrote:If I want to downgrade from 1.5.9 to 1.5.8, can I backup the 1.5.9 setup and restore to 1.5.8? I am not using any of the new 1.5.9 functionality, so I'm hoping this will work to save some time.

I'm having too many problems with 1.5.9 so want to see if 1.5.8 is better on my router.


So reverted to 1.5.8 tonight and no luck. The error with connecting to an xBox and my wireless printer is the same, it does not want to connect. I suspect a problem with AA that I will just need to wait to get fixed.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.5.9 - Plugins Interface

Post by ispyisail »

update

viewtopic.php?f=14&t=3823

small update

geekgirl
Posts: 8
Joined: Sun Mar 14, 2010 11:54 pm

Re: Version 1.5.9 - Plugins Interface

Post by geekgirl »

Tried to build 1.5.6 with "make custom" (defined target as ar7, and added base gargoyle packages)


Code: Select all

checking for mips-openwrt-linux-gcc... mips-openwrt-linux-uclibc-gcc
libipt_bandwidth.c:40:48: warning: linux/netfilter_ipv4/ipt_bandwidth.h: No such file or directory


Edit:
seems custom-src/.config was being overwritten with config from targets/custom/profiles/default/config which was for atheros instead of the ar7 target i chose when doing make custom
Last edited by geekgirl on Sun Feb 10, 2013 2:14 am, edited 1 time in total.

RaymondLok
Posts: 3
Joined: Mon May 14, 2012 11:16 am

Re: Version 1.5.9 - Plugins Interface

Post by RaymondLok »

Dear all,

I did upgrade to 1.5.9 for my TP link 1043ND and setup the openvpn.

But I found a problem,

1. When I use the default 1194 port, that is fine
2. Before power reset/soft restart the router, I did change the port to 16888. The openvpn status is shown "Running, connected...". So it works fine while I connected my openvpn client
3. After reboot, it will show "Running, NOT conected..."
4. I need to disable the openvpn and configure to default 1194 port to let it be Running and connected
5. Then I need to manually configure back to 16888 port. Otherwise, it will show "the port was conflict with sth..." alarm message

Any help? thanks a lot.

geekgirl
Posts: 8
Joined: Sun Mar 14, 2010 11:54 pm

Re: Version 1.5.9 - Plugins Interface

Post by geekgirl »

1.5.6 install fails

Code: Select all

configure: error: The kernel source directory /usr/src/tarballs/gargoyle-1.5.6/gargoyle/custom-src/build_dir/linux-ar7/linux-2.6.32.27 is not patched with netlink.patch to support ipset
make[4]: *** [/usr/src/tarballs/gargoyle-1.5.6/gargoyle/custom-src/build_dir/linux-ar7/ipset-6.11/.configured_] Error 1
make[4]: Leaving directory `/usr/src/tarballs/gargoyle-1.5.6/gargoyle/custom-src/package/net/ipset'
make[3]: *** [package/net/ipset/compile] Error 2

Post Reply