Version 1.5.9 - Plugins Interface

The latest news about Gargoyle

Moderator: Moderators

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Postby yc3948 » Mon Jan 21, 2013 4:22 pm

I use No-ip.com and 1043ND too, I tested it just 5 minutes ago with 1.5.9 I didn't find this problem! Do we still need make the change?

FireVortex wrote:I'm using Gargoyle 1.5.9 and No-IP.org updating suddenly stop working.

So, I changed this config (on /etc/ddns_providers.conf) based on http://www.noip.com/integrate/request:

Code: Select all

service no-ip.com
    url_template    https://dynupdate.no-ip.com/ducupdate.php?username=[[USERNAME]]&pass=[[PASSWORD]]&h[]=[[DOMAIN]]&ip=[[IP]]
    required_variables    domain username password
    required_variable_names    Domain Name,Username,Password
    success_regexp    /:01/


to this config:

Code: Select all

service no-ip.com
   url_template         https://[[USERNAME]]:[[PASSWORD]]@dynupdate.no-ip.com/nic/update?hostname=[[DOMAIN]]&myip=[[IP]]
   required_variables      domain username password
   required_variable_names      Domain Name,Username,Password
   success_regexp         /^(good|nochg)/


and works like a charm.
Last edited by yc3948 on Mon Jan 21, 2013 5:01 pm, edited 1 time in total.
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Postby yc3948 » Mon Jan 21, 2013 4:24 pm

Did you test this problem? Why I can't find on my 1043ND with 1.5.9? I use no-ip too.

Eric wrote:FireVortex: Thanks for bringing this to my attention, and for providing a working fix. I love when bug reports include a solution! I've updated the No-IP code as suggested and it will be included in the next release.
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

mtr
Posts: 29
Joined: Sun Oct 28, 2012 1:14 pm

Re: Version 1.5.9 - Plugins Interface

Postby mtr » Mon Jan 21, 2013 10:25 pm

yc3948 wrote:I use No-ip.com and 1043ND too, I tested it just 5 minutes ago with 1.5.9 I didn't find this problem! Do we still need make the change?


I've tried with several No-IP domains with same results: no updating at all.

The No-IP.com site says:
Our protocol is in an open format used by other service providers. The open protocol has been altered by adding a few additional parameters to enhance the No-IP experience. Moving to an open format well help system integrators deploy the No-IP service in their products without having to manage different update methods. If a system already uses the open protocol a simple change of the server name is all that is needed.


Site algo warns:
When making an update it is important that your http request include an HTTP User-Agent to help No-IP identify different clients that access the system. Clients that do not supply a User-Agent risk being blocked from the system.

User avatar
maguvu
Posts: 11
Joined: Wed Oct 24, 2012 1:13 am
Location: Dubai, UAE.

Re: Version 1.5.9 - Plugins Interface

Postby maguvu » Tue Jan 22, 2013 2:40 am

Eric, I want to thank you for your professionalism and consistently good work.
TP-Link TL-WDR4300 Version 1.0,Firmware :Gargoyle Version 1.6.1
TP-Link TL-WR1043ND Version 1.0,Firmware :Gargoyle Version 1.6.1
OS : Linux Ubuntu 14.04 LTS

Mr.nsingh2
Posts: 2
Joined: Thu Jan 17, 2013 11:29 am

Re: Version 1.5.9 - Plugins Interface

Postby Mr.nsingh2 » Tue Jan 22, 2013 4:17 am

Mr.nsingh2 wrote:Hello,

This is my first time posting. I have been using Gargoyle for little over 6 months. I have found Gargoyle to be an amazing solution. It gave second life to my router. Thanks Eric and everyone involved.

I Successfully installed 1.5.9 on TP-Link TL-MR3220.v1. Themes look great, especially the "Green" one.

Having one issue: When using "force clients to use router DNS servers", the clients are still using the router Local ip as DNS instead of ISP's DNS servers. How do I get the router to shell out DNS server IP's of my choice to the clients in this 1.5.9. release?

All help will be appreciated.

Regards,

N.Singh


PS: Had to revert back to 1.5.8 due to problems with 1.5.9 my internet stop working after few hours. I think it is a DNS problem with the router. 1.5.8. is working stable so far.

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Postby yc3948 » Tue Jan 22, 2013 4:34 pm

Do you know when No-IP make this change? And it only affect free hosts(No-IP Free) or affect all hosts? Because my hosts( No-IP Plus) working fine until now. Thanks
FireVortex wrote:
yc3948 wrote:I use No-ip.com and 1043ND too, I tested it just 5 minutes ago with 1.5.9 I didn't find this problem! Do we still need make the change?


I've tried with several No-IP domains with same results: no updating at all.

The No-IP.com site says:
Our protocol is in an open format used by other service providers. The open protocol has been altered by adding a few additional parameters to enhance the No-IP experience. Moving to an open format well help system integrators deploy the No-IP service in their products without having to manage different update methods. If a system already uses the open protocol a simple change of the server name is all that is needed.


Site algo warns:
When making an update it is important that your http request include an HTTP User-Agent to help No-IP identify different clients that access the system. Clients that do not supply a User-Agent risk being blocked from the system.
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.9 - Plugins Interface

Postby yc3948 » Tue Jan 22, 2013 4:42 pm

try opne dns as 8.8.8.8 and 8.8.4.4 from google ;)
Mr.nsingh2 wrote:
Mr.nsingh2 wrote:Hello,

This is my first time posting. I have been using Gargoyle for little over 6 months. I have found Gargoyle to be an amazing solution. It gave second life to my router. Thanks Eric and everyone involved.

I Successfully installed 1.5.9 on TP-Link TL-MR3220.v1. Themes look great, especially the "Green" one.

Having one issue: When using "force clients to use router DNS servers", the clients are still using the router Local ip as DNS instead of ISP's DNS servers. How do I get the router to shell out DNS server IP's of my choice to the clients in this 1.5.9. release?

All help will be appreciated.

Regards,

N.Singh


PS: Had to revert back to 1.5.8 due to problems with 1.5.9 my internet stop working after few hours. I think it is a DNS problem with the router. 1.5.8. is working stable so far.
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

ispyisail
Moderator
Posts: 4592
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.5.9 - Plugins Interface

Postby ispyisail » Tue Jan 22, 2013 7:06 pm


yousaf465
Posts: 49
Joined: Mon Nov 26, 2012 5:19 am

Re: Version 1.5.9 - Plugins Interface

Postby yousaf465 » Wed Jan 23, 2013 7:05 am

I can't see System/plugins menu :( Using 1.5.9 Tp-link 741ND.

Edit: Slved by resetting to default configration.
Last edited by yousaf465 on Fri Jan 25, 2013 11:58 pm, edited 1 time in total.

mtr
Posts: 29
Joined: Sun Oct 28, 2012 1:14 pm

Re: Version 1.5.9 - Plugins Interface

Postby mtr » Wed Jan 23, 2013 10:37 am

yc3948 wrote:Do you know when No-IP make this change? And it only affect free hosts(No-IP Free) or affect all hosts? Because my hosts( No-IP Plus) working fine until now. Thanks


Sorry, I've no idea. Plus, I only have a Free Account :( (created few years ago) and I don't/can't test it with a Plus Account.


Return to “News”

Who is online

Users browsing this forum: No registered users and 2 guests