Version 1.5.7 -- OpenWRT "Attitude Adjustment"

The latest news about Gargoyle

Moderator: Moderators

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by ericwong »

olo wrote:- It's a pity that there's no USB option on Broadcom devices. USB works fine on original Asus firmware.


There is an USB storage option on Gargoyle. I am not sure if the package is included in the 1.5.7 build you installed but if you build your own ROM, there is an option to include the USB gargoyle web UI.

Or maybe you can manually install the required package.

It is probably called "plugin-gargoyle-usb-storage", at least this is the name used in menuconfig..
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

Eric
Site Admin
Posts: 1441
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by Eric »

I've identified and fixed the DNS related bugs reported by KREAT0R and olo. Fixes will be included in the next release.

jorgemiguel4
Posts: 85
Joined: Thu Dec 29, 2011 2:17 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by jorgemiguel4 »

Eric wrote:I've identified and fixed the DNS related bugs reported by KREAT0R and olo. Fixes will be included in the next release.

Thanks.

Building...


edit:
I think I have found a new bug. Using PPPoE, it won't show correct IP Address nor Default Gateway on status page. ACC will not work correctly because of this too unless I set Gateway manually.

Image



Another thing, PPPoE connection takes a lot more time to connect than on 1.5.6 version.
There are lots of Timeout waiting for PADO packets and Unable to complete PPPoE Discovery in log.

hellbound1988
Posts: 38
Joined: Thu Jan 13, 2011 11:39 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by hellbound1988 »

access restrictions wont work on TP-link WR941ND running 1.5.7 It was working on previous build. My goal is to block URL(s) based on keywords.

Thanks eric for the awesome firmware.

regards

Slacker
Posts: 55
Joined: Mon Aug 20, 2012 2:00 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by Slacker »

Seconding the above post on a 1043ND. For me, no rule gets added after saving the URL blocking rule (In both Firefox and IE10).


Also: "Connected hosts" under "Hosts With Active Connections" shows a rather impressive list. Most of those only having one UDP connection. All those hosts, save for 2 are not on my internal network.
I believe this is due to Transmission running on the router, but it did not happen on 1.5.4 or 1.4.7.

Wild Rat
Posts: 40
Joined: Fri Feb 17, 2012 9:43 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by Wild Rat »

About USB printer connected to router:

Code: Select all

Sep 23 16:56:53 Hellgate kern.info kernel: [78535.490000] usb 1-1.4.2: new full-speed USB device number 6 using ehci-platform
Sep 23 16:56:53 Hellgate kern.info kernel: [78535.610000] usblp0: USB Bidirectional printer dev 6 if 0 alt 1 proto 2 vid 0x067B pid 0x2305
Sep 23 16:56:53 Hellgate lpr.err p9100d[5103]: socket: Address family not supported by protocol


About Samba shared disk access error:

Code: Select all

Sep 23 17:04:46 Hellgate user.err syslog: error starting threads: errno 89 (Function not implemented)

excelsi
Posts: 29
Joined: Sat Sep 08, 2012 7:44 am

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by excelsi »

OpenVPN Problems are not fixed. I have an 1043ND and prolbems after first reboot after OpenVPN Configuration. The configuration is without problems but after reboot of the router its completly unresponsive without any ping. The only thing thats helps out its telnet and firstboot for configuration reset.

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by yc3948 »

Check this:
viewtopic.php?f=3&t=3023&p=13805#p13820

excelsi wrote:OpenVPN Problems are not fixed. I have an 1043ND and prolbems after first reboot after OpenVPN Configuration. The configuration is without problems but after reboot of the router its completly unresponsive without any ping. The only thing thats helps out its telnet and firstboot for configuration reset.
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

excelsi
Posts: 29
Joined: Sat Sep 08, 2012 7:44 am

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by excelsi »

Hi yc3948,

thanks for your reply. I dont use quotas and the client use vpn for setting is set on the suggested setting.
But the problem is still the same as before :(

excelsi
Posts: 29
Joined: Sat Sep 08, 2012 7:44 am

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by excelsi »

Hi,

maybe i can provide some logs from the boot after the vpn configuration to give you some help for fixing the problem. Can somebody tell me where i can find these logs from the command line after i established a telnet seessions to the router?

Post Reply