Version 1.5.7 -- OpenWRT "Attitude Adjustment"

The latest news about Gargoyle

Moderator: Moderators

wetwilly
Posts: 5
Joined: Thu Aug 02, 2012 8:19 am
Location: Sweden

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by wetwilly »

Flashed my 1043ND and so far its running fine.

Although it seems to have broken the 3g Modem support. It locates the device but doesn't do the modeswitch thing, and 3G option is not visible under WAN configuration.
Fonera 2100 - Gargoyle 1.4.7 - Wifi AP
TP-Link WR 1043ND - Gargoyle 1.5.7 - OpenVPN client
Linksys E4200 - Toastman Tomato v1.28.0499 - OpenVPN client
Virtual - pfSense 2.1 beta - OpenVPN Peer to Peer server (SSL/TLS-auth)

Slacker
Posts: 55
Joined: Mon Aug 20, 2012 2:00 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by Slacker »

But keep in mind the qos configuration page WILL disappear again if you try to configure it.. It is hit and miss affair.. typically it will blank out if you use multiple window to configure the qos.

Creating classes and rules are OK, just not editing in IE10. Firefox 14.01 works just fine for me.

Do you know you need to do a reboot after the router have booted successfully after flashing the firmware? I mean reboot again after flashing is completed and the router reboot by itself..

I did not know this and I think I haven't been affected by it(or just didn't notice), but the bandwidth behavior magically "fixed" itself somewhat. I'll edit my original post to reflect that.

Eric
Site Admin
Posts: 1441
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by Eric »

ericwong: I will look further into the QoS issues, it does seem that there is something strange going on there.

Also, the source link is for the attitude adjustment branch. That branch got merged into master. The link you are looking for is: http://www.gargoyle-router.com/gargoyle ... rev=master

yc3948
Posts: 164
Joined: Sat Sep 10, 2011 1:04 am

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by yc3948 »

Hi Eric

Could you please fix this?

1.5.7 have same problem as 1.5.6

viewtopic.php?f=3&t=3023&p=13805#p13820
Buffalo WZR-HP-G300NH2 DD-WRT v24SP2-MULTI (10/31/11) std
Buffalo WZR-HP-G300NH Gargoyle 1.5.9+1f082daf
Linksys WRT54GL Gargoyle 1.4.4
TP-Link TL-WR1043ND Gargoyle 1.5.9+1f082daf

User avatar
KREAT0R
Posts: 39
Joined: Wed Sep 05, 2012 2:27 am
Location: Argentina

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by KREAT0R »

For now found these problems:
* Problems with DNS settings (manual or default OpenDNS or Google), with my isp dns working properly.
The configure is duplicated on the web and also appears my isp's dns.
While it appears the dns OpenDNS repeated, the test did not go anywhere.
Leave a screenshot of the web with OpenDNS.
Image

edit: configuring DNS manually via ssh or scp, walk properly.
Now appears dns lan and wan, why are repeated anywhere.


* Another thing that happens is when clear history of "Web Monitor", it takes much longer than in the version 1.5.6


* Now saves settings to "Connection" the router restarts (which in the previous version did not do it).

By the time those things, because I had not much time to test.
Tested on the 841nd v5 router.

PD: translation by google.
Router test: wr841nd v5

lceron80
Posts: 112
Joined: Sun Jul 24, 2011 3:42 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by lceron80 »

tried flashing my wzr-hp-g300nh2 with no luck. everytime it says invalid firmware from buffalo gui. :roll:
1x wndr3700v4 exp. 1.9.x
1x wndr3800 exp. 1.9.x
1x wndr4300v1 exp. 1.9.x
1x wndrmacv2 exp. 1.9.x

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by ericwong »

lceron80 wrote:tried flashing my wzr-hp-g300nh2 with no luck. everytime it says invalid firmware from buffalo gui. :roll:


Try the factory bin.

New potential bug:
I have been using my rt305x gargoyle router from the attitude_adjustment branch, for about a week.. without rebooting.

Today, the router suddenly "stopped working".
I look in the kernel log and found this.

Code: Select all

[421548.350000] net_ratelimit: 53 callbacks suppressed
[421548.360000] nf_conntrack: table full, dropping packet.
[421548.410000] nf_conntrack: table full, dropping packet.
[421548.420000] nf_conntrack: table full, dropping packet.
[421548.430000] nf_conntrack: table full, dropping packet.
[421548.510000] nf_conntrack: table full, dropping packet.
[421548.740000] nf_conntrack: table full, dropping packet.
[421548.800000] nf_conntrack: table full, dropping packet.
[421548.840000] nf_conntrack: table full, dropping packet.
[421548.900000] nf_conntrack: table full, dropping packet.
[421548.930000] nf_conntrack: table full, dropping packet.
[421553.460000] net_ratelimit: 72 callbacks suppressed
[421553.470000] nf_conntrack: table full, dropping packet.
[421553.610000] nf_conntrack: table full, dropping packet.
[421553.790000] nf_conntrack: table full, dropping packet.
[421553.860000] nf_conntrack: table full, dropping packet.
root@Gargoyle:~#


No idea what happened there or what causes this... I am just reporting this and see if someone knows what happened or how to reproduce this.

Rebooting the router fixed the issue though.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

pbix
Developer
Posts: 1372
Joined: Fri Aug 21, 2009 5:09 pm

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by pbix »

Looks like your conntrack table overflowed.

At least double the number of contrack entries on your Firewall->Connection Limits page.
Linksys WRT1900ACv2
Netgear WNDR3700v2
TP Link 1043ND v3
TP-Link TL-WDR3600 v1
Buffalo WZR-HP-G300NH2
WRT54G-TM

User avatar
ericwong
Posts: 429
Joined: Sat Aug 25, 2012 6:15 am
Location: Melbourne, Australia
Contact:

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by ericwong »

pbix wrote:Looks like your conntrack table overflowed.

At least double the number of contrack entries on your Firewall->Connection Limits page.


OK, thanks.. I have increased the maximum number of connections to 8000.

I didn't realize this means the number of connections.
Eric Wong

PM me if you need to buy Gargoyle router in Australia/NZ, willing to pay me to help you on your Gargoyle configurations or build custom configured ROM with pre-installed app or try to fix your bricked router. Yes, I am looking for job/work.

User avatar
olo
Posts: 31
Joined: Mon Mar 14, 2011 7:51 am

Re: Version 1.5.7 -- OpenWRT "Attitude Adjustment"

Post by olo »

I think there's a problem with displaying the DNS settings on Status > Overview page:
Image
Best regards,
Olo
---
Asus WL-500-gP V2 @ v1.7.0 - WiFi - unable to enable.
TP-Link TL-WR1043ND - so far so good :)

Post Reply