Version 1.5.1 & 1.4.4

The latest news about Gargoyle

Moderator: Moderators

behappy
Posts: 83
Joined: Thu Mar 31, 2011 5:06 pm

Re: Version 1.5.1 & 1.4.4

Postby behappy » Fri Dec 16, 2011 4:32 am

Trailblazer wrote:Thanks for your response. I use OpenDNS servers configured under 'Custom DNS Servers'. I don't know how to change dnsmasq. How?

Where is sysctl.conf and what should I set the conntrack timeout to?


Here is my setup. Search and file the same file name from SSH to the router, ex. WinSCP. Don't know why I can't post w. attachment?

- dnsmasq under /etc/init.d
- section
....
/usr/sbin/dnsmasq $args && {
rm -f /tmp/resolv.conf
[ -n "$DOMAIN" ] && echo "search $DOMAIN" >> /tmp/resolv.conf
here> DNS_SERVERS="$DNS_SERVERS xx.xx.xx.xx"
here> DNS_SERVERS="$DNS_SERVERS xx.xx.xx.xx"
here> DNS_SERVERS="$DNS_SERVERS xx.xx.xx.xx"
# DNS_SERVERS="$DNS_SERVERS 127.0.0.1"
for DNS_SERVER in $DNS_SERVERS ; do
echo "nameserver $DNS_SERVER" >> /tmp/resolv.conf
done

Similar for S60dnsmas.q under /etc/rc.d
- sysctl.conf under /etc
kernel.panic=3
net.ipv4.conf.default.arp_ignore=1
net.ipv4.conf.all.arp_ignore=1
net.ipv4.ip_forward=1
net.ipv4.icmp_echo_ignore_broadcasts=1
net.ipv4.icmp_ignore_bogus_error_responses=1
net.ipv4.tcp_ecn=0
net.ipv4.tcp_fin_timeout=30
net.ipv4.tcp_keepalive_time=120
net.ipv4.tcp_syncookies=1
net.ipv4.tcp_timestamps=0
net.core.netdev_max_backlog=30
net.netfilter.nf_conntrack_checksum=0
net.ipv4.netfilter.ip_conntrack_checksum=0
net.ipv4.netfilter.ip_conntrack_udp_timeout=60
# net.ipv6.conf.all.forwarding=1

# disable bridge firewalling by default
net.bridge.bridge-nf-call-arptables=0
net.bridge.bridge-nf-call-ip6tables=0
net.bridge.bridge-nf-call-iptables=0

net.ipv4.tcp_tw_reuse=1
net.ipv4.netfilter.ip_conntrack_tcp_timeout_syn_sent=30
net.ipv4.netfilter.ip_conntrack_tcp_timeout_syn_recv=30
net.ipv4.netfilter.ip_conntrack_tcp_timeout_fin_wait=30
net.ipv4.netfilter.ip_conntrack_tcp_timeout_time_wait=30
net.ipv4.netfilter.ip_conntrack_tcp_timeout_close=10
net.ipv4.netfilter.ip_conntrack_tcp_timeout_close_wait=30
net.ipv4.netfilter.ip_conntrack_tcp_timeout_last_ack=30

net.ipv4.ip_conntrack_max=8192
net.ipv4.netfilter.ip_conntrack_max=8192
net.ipv4.netfilter.ip_conntrack_tcp_timeout_established=600
net.ipv4.netfilter.ip_conntrack_udp_timeout_stream=180

dcoomans
Posts: 3
Joined: Thu Dec 15, 2011 8:49 am

Re: Version 1.5.1 & 1.4.4

Postby dcoomans » Fri Dec 16, 2011 4:58 am

DoesItMatter wrote:
Gargoyle 1.4.4 should work with your WRT160NL

Support was added from 1.4.0

Best way to find out info is to read the very first page/post of
each of the release announcements.

Eric will detail all the fixes / current backfire versions / drivers etc.


Router WRT160nl up and running with 1.4.4 since yesterday.
All seems to work well, including portforwarding and DDNS (dyndns.com). Speed up to 140 Mbps wireless

AVSTDR
Posts: 6
Joined: Sat Dec 17, 2011 5:59 am

Re: Version 1.5.1 & 1.4.4

Postby AVSTDR » Sat Dec 17, 2011 6:10 am

Hi. It's my first time on this forum.
Using your firmware on my tp-link WR1043ND. It is very stable configuration for me. But i have some problems
1. When copying files by lan cable from laptop to PC copy speed goes down from good 40-50mb to 3-4 mb.
2. wi-fi powered off (some times after long use time, sometimes just after 1 hour of use). Just reboot can solve problem.
And i whant to know some things
1. Is it possible to use IPTV and what i need to do. Do you plan add IPTV function in firmware
2. Version 1.5.1 has "USB Printer configuration". What i need to do to instal my printer (router don't recognize my printer), or this function work with printers only? Ш have multi-functional epson device (printer+scaner)

Thank's

ispyisail
Moderator
Posts: 4194
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.5.1 & 1.4.4

Postby ispyisail » Sat Dec 17, 2011 6:50 am

AVSTDR wrote:Hi. It's my first time on this forum.
Using your firmware on my tp-link WR1043ND. It is very stable configuration for me. But i have some problems
1. When copying files by lan cable from laptop to PC copy speed goes down from good 40-50mb to 3-4 mb.
2. wi-fi powered off (some times after long use time, sometimes just after 1 hour of use). Just reboot can solve problem.
And i whant to know some things
1. Is it possible to use IPTV and what i need to do. Do you plan add IPTV function in firmware
2. Version 1.5.1 has "USB Printer configuration". What i need to do to instal my printer (router don't recognize my printer), or this function work with printers only? Ш have multi-functional epson device (printer+scaner)

Thank's

Which version are you using?

AVSTDR
Posts: 6
Joined: Sat Dec 17, 2011 5:59 am

Re: Version 1.5.1 & 1.4.4

Postby AVSTDR » Sat Dec 17, 2011 7:13 am

ispyisail wrote:
AVSTDR wrote:Hi. It's my first time on this forum.
Using your firmware on my tp-link WR1043ND. It is very stable configuration for me. But i have some problems
1. When copying files by lan cable from laptop to PC copy speed goes down from good 40-50mb to 3-4 mb.
2. wi-fi powered off (some times after long use time, sometimes just after 1 hour of use). Just reboot can solve problem.
And i whant to know some things
1. Is it possible to use IPTV and what i need to do. Do you plan add IPTV function in firmware
2. Version 1.5.1 has "USB Printer configuration". What i need to do to instal my printer (router don't recognize my printer), or this function work with printers only? Ш have multi-functional epson device (printer+scaner)

Thank's

Which version are you using?

I used 1.5.1, now i on 1.4.4. On 1.4.4 wi-fi works longer than 1.5.1

ispyisail
Moderator
Posts: 4194
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.5.1 & 1.4.4

Postby ispyisail » Sat Dec 17, 2011 7:17 am

I used 1.5.1, now i on 1.4.4. On 1.4.4 wi-fi works longer than 1.5.1


Were you using WPA2-PSK?

I'm using the same router with the same firmware with no problems but im using "none" for encryption

AVSTDR
Posts: 6
Joined: Sat Dec 17, 2011 5:59 am

Re: Version 1.5.1 & 1.4.4

Postby AVSTDR » Sat Dec 17, 2011 7:48 am

ispyisail wrote:
I used 1.5.1, now i on 1.4.4. On 1.4.4 wi-fi works longer than 1.5.1


Were you using WPA2-PSK?

I'm using the same router with the same firmware with no problems but im using "none" for encryption


Yes, wpa2-psk. Thank for idea, i will try use none for encriptoin.
And what about IPTV or printer? Did you try to use?

dcoomans
Posts: 3
Joined: Thu Dec 15, 2011 8:49 am

Re: Version 1.5.1 & 1.4.4

Postby dcoomans » Sat Dec 17, 2011 7:50 am

switched to dd-wrt build 17461 17-08-2011
i had problems copying files on local network, dropout wifi

ispyisail
Moderator
Posts: 4194
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.5.1 & 1.4.4

Postby ispyisail » Sat Dec 17, 2011 8:57 am

2. Version 1.5.1 has "USB Printer configuration". What i need to do to instal my printer (router don't recognize my printer), or this function work with printers only? Ш have multi-functional epson device (printer+scaner)


SSH into you router and run

## plug the printer into the usb port(s) ##

Code: Select all

dmesg

# ... should now show you an output like this ...
[...]

Code: Select all

printer.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04B8 pid 0x0005
printer.c: v0.13: USB Printer Device Class driver
usb.c: USB disconnect on device 01:02.0-1 address 2

Dragon31337
Posts: 16
Joined: Sun Oct 30, 2011 10:14 am

Re: Version 1.5.1 & 1.4.4

Postby Dragon31337 » Tue Dec 20, 2011 1:14 pm

45 days up on 1.5.0.
Will continue with 1.5.1! Great job!
Finally DynDNS is fixed (I hope)
TL-WR1043ND v1.8 - Gargoyle 1.5.8


Return to “News”

Who is online

Users browsing this forum: No registered users and 8 guests