Version 1.5.0 & 1.4.3

The latest news about Gargoyle

Moderator: Moderators

Posts: 41
Joined: Tue Mar 09, 2010 4:12 pm

Re: Version 1.5.0 & 1.4.3

Postby NGowner » Thu Nov 03, 2011 10:39 am

Eric wrote:The new stable 1.4.3 is also available, which contains a few minor bugfixes and the latest wireless driver/fixes updates from the OpenWrt Backfire branch.

New in 1.4.3:
  • Fixes "Monitor Only" option in web usage monitor

Nope. Upgraded to 1.4.3 last night. Still doesn't work for me.

I set up a range of IP addresses to monitor. Nothing. Take the range away, and it monitors just fine. Still seems to be broken.


Posts: 15
Joined: Sun Sep 25, 2011 9:20 pm

Re: Version 1.5.0 & 1.4.3

Postby wkweksl » Fri Nov 04, 2011 12:40 am

Updated 1.4.2 -> 1.5.0 on WR-1043 v1.8. Stable so far.
TP-Link WR-1043ND 1.8 - Gargoyle 1.5.6

Posts: 17
Joined: Fri Apr 29, 2011 7:34 am

Re: Version 1.5.0 & 1.4.3

Postby qtr » Fri Nov 04, 2011 1:25 am

caeci11ius wrote:Qtr, the differences are as follows:

You shouldn't need to go into the terminal and run iw list to see these changes btw, they should be visible from within Gargoyle (and have been for quite a few versions now)...

Let me know if you still can't get channels 12 and 13, and we'll see if we can work out why...

caeci11ius, channels 12 & 13 are still not working. BTW, with Gargoyle v1.4.2 & v1.5.0 channels 12, 13 & 14 already show up even before the regulatory.bin was replaced. The "iw list" before & after the replacement both shows channels 12, 13 & 14 as (passive scanning). Another thing I noted is that the "iw list" shows (20.0 dBm) for the 2.4GHz frequencies but Gargoyle still shows (0 - 17dBm) probably written in the program as a label so it doesn't change.

In the weekend I'll do the bit checking of your regulatory.bin against the one from the German site to see if there's any different.

PS: I checked the MD5 hash for both files they are the same. So I would say the are the same.

Posts: 77
Joined: Fri Dec 03, 2010 5:47 am
Location: Canberra, Australia

Re: Version 1.5.0 & 1.4.3

Postby caeci11ius » Fri Nov 04, 2011 3:01 am

qtr: if MD5 hash is the same, they're (with a very high degree of certainty) the same. No need to check further. What were your before and after values for the power output on the low 5GHz channels (e.g. 36 and the few above that, the ones under 100)? Should have been 17dBm before, and 23 after. Power limit of 20dBm is pretty common around the world for the 2.4GHz channels, so wouldn't pay too much attention to that.

I may be wrong here, but I think passive scanning means it can look for a router SSID running on that channel, and if it finds one can connect to it but that it can't signal prior to finding local infrastructure on the channel. Not much good for running an AP, but handy if you take your laptop overseas and are looking to connect to one...

My output from iw list is (on 2.4GHz):

* 2412 MHz [1] (20.0 dBm)
* 2417 MHz [2] (20.0 dBm)
* 2422 MHz [3] (20.0 dBm)
* 2427 MHz [4] (20.0 dBm)
* 2432 MHz [5] (20.0 dBm)
* 2437 MHz [6] (20.0 dBm)
* 2442 MHz [7] (20.0 dBm)
* 2447 MHz [8] (20.0 dBm)
* 2452 MHz [9] (20.0 dBm)
* 2457 MHz [10] (20.0 dBm)
* 2462 MHz [11] (20.0 dBm)
* 2467 MHz [12] (20.0 dBm)
* 2472 MHz [13] (20.0 dBm)
* 2484 MHz [14] (disabled)

and on 5GHz:

* 5180 MHz [36] (23.0 dBm)
* 5200 MHz [40] (23.0 dBm)
* 5220 MHz [44] (23.0 dBm)
* 5240 MHz [48] (23.0 dBm)
* 5260 MHz [52] (23.0 dBm) (passive scanning, no IBSS, radar detection)
* 5280 MHz [56] (23.0 dBm) (passive scanning, no IBSS, radar detection)
* 5300 MHz [60] (23.0 dBm) (passive scanning, no IBSS, radar detection)
* 5320 MHz [64] (23.0 dBm) (passive scanning, no IBSS, radar detection)
* 5500 MHz [100] (disabled)
* 5520 MHz [104] (disabled)
* 5540 MHz [108] (disabled)
* 5560 MHz [112] (disabled)
* 5580 MHz [116] (disabled)
* 5600 MHz [120] (disabled)
* 5620 MHz [124] (disabled)
* 5640 MHz [128] (disabled)
* 5660 MHz [132] (disabled)
* 5680 MHz [136] (disabled)
* 5700 MHz [140] (disabled)
* 5745 MHz [149] (30.0 dBm)
* 5765 MHz [153] (30.0 dBm)
* 5785 MHz [157] (30.0 dBm)
* 5805 MHz [161] (30.0 dBm)
* 5825 MHz [165] (30.0 dBm)

My config for wireless is (maybe this will help):

config 'wifi-device' 'radio0'
option 'type' 'mac80211'
option 'macaddr' '30:46:9a:0f:5b:54'
option 'hwmode' '11ng'
option 'htmode' 'HT20'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'TX-STBC'
list 'ht_capab' 'RX-STBC1'
list 'ht_capab' 'DSSS_CCK-40'
option 'channel' '9'
option 'country' 'AU'

config 'wifi-device' 'radio1'
option 'type' 'mac80211'
option 'macaddr' '30:46:9a:0f:5b:56'
option 'hwmode' '11na'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'TX-STBC'
list 'ht_capab' 'RX-STBC1'
list 'ht_capab' 'DSSS_CCK-40'
option 'channel' '149'
option 'htmode' 'HT40+'
option 'country' 'AU'

config 'wifi-iface' 'ap_g'
option 'device' 'radio0'
option 'mode' 'ap'
option 'network' 'lan'
option 'wds' '1'
option 'ssid' 'Number3'
option 'encryption' 'psk2'
option 'key' 'xxxxxxxx'

config 'wifi-iface' 'ap_a'
option 'device' 'radio1'
option 'mode' 'ap'
option 'network' 'lan'
option 'ssid' 'Number3-5GHz'
option 'encryption' 'psk2'
option 'key' 'xxxxxxxx'

Posts: 1
Joined: Fri Nov 04, 2011 6:42 am

Re: Version 1.5.0 & 1.4.3

Postby SantaFox » Fri Nov 04, 2011 6:44 am

What about WRT350Nv2.1 on this release? Backfire 10.03.01rc6 works well on this router.

Posts: 2
Joined: Wed Aug 17, 2011 2:54 am

Re: Version 1.5.0 & 1.4.3

Postby pistok » Sun Nov 06, 2011 7:33 am

Updated 1.4.0 -> 1.5.0 on TP-Link 741 v2.1. Stable.

Posts: 43
Joined: Mon Aug 15, 2011 9:39 am

Re: Version 1.5.0 & 1.4.3

Postby rt_rex » Sun Nov 06, 2011 7:29 pm

If you want 13 channels and your router is an AR71xx bit of gear, you'll need my modified regulatory.bin from . Read the bit about wireless regulatory issues on that will explain why. Remember to correctly set your country code (preferably before installing it!).

Thanks caeci11ius, however after setting "option 'country' 'AU' " on my WNDR3700v1, and replace the regulatory.bin with one from I find no different from "iw list" prior and after. :(

Hi qtr. This definitely works on my WNDR3700v1. Are you putting the country option in the device section of the config? That's where it ought to go...perhaps you've been putting it in the iface section? You also need to put it in for both devices...don't forget to do that (as otherwise your 5ghz may be non-compliant). Finally, if you're still having problems, check that the file for direct download is the same as the one on rapidshare. I only uploaded the rapid one, so I can't vouch for the other. Just're Aussie right? If not, you should probably also use your local country code and not AU...

All steps i have made are here viewtopic.php?f=5&t=1670

the lastest one was this :
edit /etc/modules.d/50-madwifi and change to "ath_ahb countrycode=620 outdoor=1" (Portugal country code) and Reboot .

I will see the 14 channels available in the webfif of Gargoyle, but the wireless interface won't start.

I remind you i am runnig old foneras(2100 and 2200)
WIFI Link @ 76 km

Posts: 77
Joined: Fri Dec 03, 2010 5:47 am
Location: Canberra, Australia

Re: Version 1.5.0 & 1.4.3

Postby caeci11ius » Sun Nov 06, 2011 7:59 pm

Rt-rex, qtr and I are working through his issues in a private discussion. I will update my instructions for the wndr3700 on the OpenWRT wiki if necessary when I work out what is going wrong for him. I really don't know anything about your will need to research yourself to find out if they use crda like ar71xx gear to set the regulatory domain, and hence can benefit from a modified regulatory.bin. Feel free to try it out, but I make no promises and your results may vary...

Posts: 292
Joined: Sun Feb 27, 2011 11:18 am

Re: Version 1.5.0 & 1.4.3

Postby mix » Mon Nov 07, 2011 11:00 am

Anyone know why the Wake on LAN list of Hosts shows my isp's WAN Gateway as a host that is available? It shouldn't be on this list. Using 1.4.3
WRT54GL v1.1
Gargoyle 1.4.7

Posts: 8
Joined: Fri Mar 18, 2011 10:09 am

Re: Version 1.5.0 & 1.4.3

Postby KingViper » Mon Nov 07, 2011 12:24 pm

I'm incurring an issue with an access point losing connectivity to the main router. (Or so it seems) My network setup looks like to this.

WNDR3700 Router broadcasting wireless and performing DHCP
WNDR3700 Router wired into the main one as an AP broadcasting wireless
WNDR3700 Router as client bridge not rebroadcasting

All routers are running 1.5.0 The router acting as the access point is the one I seem to have problems with (it's centrally located and therefore is the one I generally automatically connect to) I can connect to it, but it doesn't seem to get a DHCP assigned address from the main router; however, rebooting the AP makes things work again. I was previously on 1.4.2 and had similar issues. 1.3.16 worked before that, so I'll try going back and seeing how that pans out again.

Return to “News”

Who is online

Users browsing this forum: No registered users and 2 guests