Version 1.11.0 : Based on OpenWrt 18.06

The latest news about Gargoyle

Moderator: Moderators

ispyisail
Moderator
Posts: 4598
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ispyisail » Fri Feb 22, 2019 2:09 pm

@goatman64

Did you preserve setting on upgrade?

goatman64
Posts: 4
Joined: Mon Dec 25, 2017 3:46 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby goatman64 » Fri Feb 22, 2019 2:11 pm

Yes, I checked the box to preserve settings.

ispyisail
Moderator
Posts: 4598
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ispyisail » Fri Feb 22, 2019 2:13 pm

goatman64 wrote:Yes, I checked the box to preserve settings.


And that is the problem.....................

You need to do a fresh build from scratch

ispyisail
Moderator
Posts: 4598
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ispyisail » Fri Feb 22, 2019 2:24 pm

I've made an edit to the original post

Lantis
Moderator
Posts: 4962
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby Lantis » Fri Feb 22, 2019 4:54 pm

ispyisail wrote:I've made an edit to the original post


No need to edit the picture it was ok as is.
Anything < 1.11.0 (i.e. 1.10.0 or lower) is incompatible. Now it looks like 1.10.0 is ok lol
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

ViBE
Posts: 152
Joined: Sun Apr 19, 2015 6:58 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ViBE » Fri Feb 22, 2019 5:36 pm

after i updated my Xiaomi Mi Router 3G i got a few error messages:

Code: Select all

Collected errors:
 * opkg_conf_parse_file: Duplicate src declaration (gargoyle http://www.gargoyle-router.com/packages/gargoyle-1.11.0/ramips/default). Skipping.
 * pkg_get_installed_files: Failed to open //usr/lib/opkg/info/terminfo.list: No such file or directory.


Fri Feb 22 19:06:26 2019 daemon.err uhttpd[2317]:  * opkg_conf_parse_file: Duplicate src declaration (gargoyle http://www.gargoyle-router.com/packages/gargoyle-1.11.0/ramips/default). Skipping.
Fri Feb 22 19:06:26 2019 daemon.err uhttpd[2317]:  * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/management/Packages.gz, wget returned 8.

Fri Feb 22 19:25:48 2019 daemon.err odhcp6c[2055]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

Fri Feb 22 19:28:10 2019 daemon.err uhttpd[14860]: Collected errors:
Fri Feb 22 19:28:10 2019 daemon.err uhttpd[14860]:  * opkg_conf_parse_file: Duplicate src declaration (gargoyle http://www.gargoyle-router.com/packages/gargoyle-1.11.0/ramips/default). Skipping.


a few should be related with IPv6 i guess. but that's not clear how or what cause this. the router connect to the ISP but clients cannot access internet.

and some of these related with opkg. can i fix these somehow?

noticed a cosmetic problem. at the DDNS page the refresh date shows in dd/mm. but on system level i set yyyy/mm/dd. btw now i would like to request the yyyy. mm. dd. format cause in my country that's the standard. are there any chance to add it?

oh and another time uptime bug(?) https://i.imgur.com/SEGiTwu.jpg

ispyisail
Moderator
Posts: 4598
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ispyisail » Sat Feb 23, 2019 12:58 am

@ViBE

You should start a new thread if you want to talk about a custom build.

It makes official builds look bad

ViBE
Posts: 152
Joined: Sun Apr 19, 2015 6:58 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ViBE » Sat Feb 23, 2019 6:17 am

ispyisail wrote:@ViBE

You should start a new thread if you want to talk about a custom build.

It makes official builds look bad

how do you mean? 1.11.0 is not official?

goatman64
Posts: 4
Joined: Mon Dec 25, 2017 3:46 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby goatman64 » Sat Feb 23, 2019 12:49 pm

Apologies for the confusion on settings preservation. For some reason I thought 1.10+ was ok. My bad.

1.11.0 up and running on a TP-Link TL-WDR4300 v1.

No issues ... again thanks for all the work on gargoyle!

User avatar
RomanHK
Posts: 340
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby RomanHK » Sat Feb 23, 2019 3:01 pm

@ViBE

Edit the /etc/opkg.conf file and rewrite the following:

Code: Select all

src/gz openwrt_18.06-snapshot_base http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/base
src/gz openwrt_18.06-snapshot_luci http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/luci
src/gz openwrt_18.06-snapshot_packages http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/packages
src/gz openwrt_18.06-snapshot_routing http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/routing
src/gz openwrt_18.06-snapshot_telephony http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/telephony

src/gz openwrt_18.06-snapshot_targets http://downloads.openwrt.org/releases/18.06-SNAPSHOT/targets/ramips/mt7621/packages

src/gz gargoyle http://www.gargoyle-router.com/packages/gargoyle-1.11.0/ramips/default
src/gz gargoyle_kernel_specific http://www.gargoyle-router.com/packages/gargoyle-1.11.0/ramips/default_kernelspecific

dest root /
dest ram /tmp
dest plugin_root /plugin_root
lists_dir ext /var/opkg-lists
option overlay_root /overlay



This will solve the installation of opkg packages.
Turris Omnia with Gargoyle 1.11.x
Linksys WRT3200ACM with Gargoyle 1.11.x
TL-WR1043ND v2 with Gargoyle 1.10.0


Return to “News”

Who is online

Users browsing this forum: No registered users and 3 guests