Version 1.11.0 : Based on OpenWrt 18.06

The latest news about Gargoyle

Moderator: Moderators

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by raven »

raven wrote:
RomanHK wrote:
raven wrote:1. Yes, but sometimes client gets the ip sometimes don't, and everytime I disable and re-enable lan dhcp server the problem solved
2. No, i didn't, i configure the router only through gui

The reason why i post it here because this is 1.11 thread discussing about bugs or else

So if I understand it, the Internet works for clients and it is just a cosmetic defect of displaying your name and IP address.

Then I recommend, make a static reservation for each client. It has a lot of advantages as well as after the reboot the IPs are assigned to the same clients, the network statistics will always be assigned to the same clients, etc.
Image


Yes internet works but most of the times didn't, if i use static ip to the client, the problem solved everything works but what i want to know is why this doesn't happen in 1.10 so i guess there is "something" not right in 1.11 needs to be fixed. I'll post my dhcp network as your request later


network config

Code: Select all

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd1b:9750:3e20::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth1'
   option proto 'static'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option ipaddr '192.168.50.1'
   option dns '192.168.50.1'

config interface 'wan'
   option proto 'dhcp'
   option ifname 'eth2'
   option ipv6 '0'
   option macaddr 'e4:95:6e:44:ae:4e'

config interface 'wan6'
   option ifname 'eth0'
   option proto 'dhcpv6'


dhcp config

Code: Select all

config dnsmasq
   option domainneeded '1'
   option boguspriv '1'
   option filterwin2k '0'
   option localise_queries '1'
   option rebind_protection '1'
   option rebind_localhost '1'
   option local '/lan/'
   option domain 'lan'
   option expandhosts '1'
   option nonegcache '0'
   option authoritative '1'
   option readethers '1'
   option leasefile '/tmp/dhcp.leases'
   option resolvfile '/tmp/resolv.conf.auto'
   option nonwildcard '1'
   option localservice '1'
   list server '/.bit/178.32.31.41'
   list server '/.bit/106.187.47.17'
   list server '/.bit/176.58.118.172'
   list server '/.glue/66.244.95.20'
   list server '/.glue/95.211.32.162'
   list server '/.glue/95.142.171.235'
   list server '/.parody/66.244.95.20'
   list server '/.parody/95.211.32.162'
   list server '/.parody/95.142.171.235'
   list server '/.dyn/66.244.95.20'
   list server '/.dyn/95.211.32.162'
   list server '/.dyn/95.142.171.235'
   list server '/.bbs/66.244.95.20'
   list server '/.bbs/95.211.32.162'
   list server '/.bbs/95.142.171.235'
   list server '/.free/66.244.95.20'
   list server '/.free/95.211.32.162'
   list server '/.free/95.142.171.235'
   list server '/.fur/66.244.95.20'
   list server '/.fur/95.211.32.162'
   list server '/.fur/95.142.171.235'
   list server '/.geek/66.244.95.20'
   list server '/.geek/95.211.32.162'
   list server '/.geek/95.142.171.235'
   list server '/.gopher/66.244.95.20'
   list server '/.gopher/95.211.32.162'
   list server '/.gopher/95.142.171.235'
   list server '/.indy/66.244.95.20'
   list server '/.indy/95.211.32.162'
   list server '/.indy/95.142.171.235'
   list server '/.ing/66.244.95.20'
   list server '/.ing/95.211.32.162'
   list server '/.ing/95.142.171.235'
   list server '/.null/66.244.95.20'
   list server '/.null/95.211.32.162'
   list server '/.null/95.142.171.235'
   list server '/.oss/66.244.95.20'
   list server '/.oss/95.211.32.162'
   list server '/.oss/95.142.171.235'
   list server '/.micro/66.244.95.20'
   list server '/.micro/95.211.32.162'
   list server '/.micro/95.142.171.235'
   list rebind_domain '.bit'
   list rebind_domain '.glue'
   list rebind_domain '.parody'
   list rebind_domain '.dyn'
   list rebind_domain '.bbs'
   list rebind_domain '.free'
   list rebind_domain '.fur'
   list rebind_domain '.geek'
   list rebind_domain '.gopher'
   list rebind_domain '.indy'
   list rebind_domain '.ing'
   list rebind_domain '.null'
   list rebind_domain '.oss'
   list rebind_domain '.micro'
   list addnhosts '/plugin_root/adblock/block.hosts'

config dhcp 'lan'
   option interface 'lan'
   option start '100'
   option limit '150'
   option leasetime '12h'

config dhcp 'wan'
   option interface 'wan'
   option ignore '1'

RomanHK
Posts: 667
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by RomanHK »

raven wrote:Yes internet works but most of the times didn't, if i use static ip to the client, the problem solved everything works but what i want to know is why this doesn't happen in 1.10 so i guess there is "something" not right in 1.11 needs to be fixed. I'll post my dhcp network as your request later

To what I have already written (static reservation), do not use Adblock, version 1.11.0 is RAM-intensive.
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by raven »

RomanHK wrote:
raven wrote:Yes internet works but most of the times didn't, if i use static ip to the client, the problem solved everything works but what i want to know is why this doesn't happen in 1.10 so i guess there is "something" not right in 1.11 needs to be fixed. I'll post my dhcp network as your request later

To what I have already written (static reservation), do not use Adblock, version 1.11.0 is RAM-intensive.


Thanks Roman, i'll use static ip while waiting for 1.11 stable version

jackspm
Posts: 9
Joined: Sat Jul 05, 2014 12:08 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by jackspm »

Lantis wrote:
If you plug in a USB stick, go to the System->USB Storage page, click Unmount All, then follow the instructions on the same page (it should refresh after unmount) to setup external plugin root and swap.

To remove plugin sources, you can comment out the lines in /etc/opkg.conf


Any recommendation of size and speed of the flash drive?

Daeron
Posts: 28
Joined: Mon Oct 31, 2016 5:30 am

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by Daeron »

Just reporting back that removing the adblock plugin and disabling the plugin sources other than gargoyle's own have made running 1.11 fairly stable. Still feels slower than before, but I haven't noticed any particularly glitchy behavior.

(TL-WR1043ND v1)
Last edited by Daeron on Sat Mar 30, 2019 12:33 pm, edited 1 time in total.

ghorvath
Posts: 46
Joined: Thu Sep 29, 2016 12:03 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by ghorvath »

ghorvath wrote:Thanks for this version! I successfully updated 1.11.X RC5 on a Youku YK1.

There is a new issue with the wireless (don't remember having it for RC5, didn't test for that, though). If I copy some big files through wireless from one local machine to another local machine, then after some undeterministic time (usually seconds, could be hours) two things happen: wireless breaks (machines connecting via wireless will keep the wireless connection, but won't see any other local machine, not even the router) and the router is not distributing the internet to any of the local machines, anymore (no matter if they connected via cable or wireless). Those machines that are connected to the router by cable can see each other and the router, so I can use one to login into the router and reboot it, which usually solves the issue until the next wireless bulk transfer. Sometimes multiple reboots are needed.

Did anyone experience a similar issue? Should I give some more specifics about my router/setup to help debugging this issue? If yes, then what?

Thanks!


Anyone was able to reproduce this?

RomanHK
Posts: 667
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by RomanHK »

ghorvath wrote:Anyone was able to reproduce this?

This is an atipic router (https://openwrt.org/toh/hwdata/youku/youku_yk1)

1) Do not use a backup setting
2) Set another static channel (e.g. 5)
3) Do not have far clients (weak clients can disconnect)

If nothing helps, try OpenWrt 18.06 to see if there is a problem in OpenWrt (http://downloads.openwrt.org/releases/1 ... pgrade.bin).
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

marcb
Posts: 19
Joined: Wed Sep 18, 2013 12:19 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by marcb »

Hi everyone
I have a Xiaomi R3G with OpenWRT 18.06.2... can I flash Gargoyle directly?
Last edited by marcb on Tue Apr 02, 2019 1:52 pm, edited 1 time in total.

RomanHK
Posts: 667
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by RomanHK »

marcb wrote:Hi everyone
I have a Xiaomi R3G with OpenWRT 18.06.2... can I flash the
Gargoyle directly?

You can try directly from the GUI gargoyle_1.11.0-ramips-mt7621-mir3g-squashfs-sysupgrade.tar and if it doesn't work you will need to execute the command sysupgrade -F (force) via ssh eg:

Code: Select all

sysupgrade -F /tmp/gargoyle_1.11.0-ramips-mt7621-mir3g-squashfs-sysupgrade.tar
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

ViBE
Posts: 154
Joined: Sun Apr 19, 2015 6:58 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Post by ViBE »

may i already noticed, not sure: on the bandwidth site if i set the time frame to months it shows the date in mm yyyy format. is it possible to swap this too? in hungarian we use yyyy mm format. aligning this column to the left would be also cool.

Post Reply