gargoyle-ispy 2016-May-12 09:22.torrent

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 5588
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by Lantis »

can I get an
opkg list-installed | grep ath10k
From one/both of you please?

If it turns up no results, you can manually install the driver from the same download location and reboot.
May have to delete the wifi config and type "wifi detect" after rebooting to get the 5ghz stuff to show up.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

kkuramoto
Posts: 8
Joined: Sun Jan 10, 2016 10:50 pm

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by kkuramoto »

Lantis, the command returned the following:

root@Archer C7:~# opkg list-installed | grep ath10k
ath10k-firmware-qca988x - 2014-11-13-77f72b5f7dd940386d9e619a17904987759b7186-1

Trailblazer
Posts: 111
Joined: Wed Mar 09, 2011 3:12 am

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by Trailblazer »

Lantis wrote:
Trailblazer wrote:NZ and AUS working together...I thought you guys were in mortal combat? :lol:


As long as we don't talk about sport we're ok :P


That's what I thought!! Yeah, you guys are down there at the bottom of the earth together, I'm sure that you work together, until it Football time! I had the fortune of visiting NZ in 2005. Really love the place. No nukes, none of the food contains pesticides (or so I was told), beautiful scenery, mellow cool people. I really dug it.

Okay, I will test this tomorrow and let you know.

I will make it my task to come up with a script that will work on the C7 and share it with the community. I did it for my Buffalo router many years ago.
Netgear WNDR3700V2 Gargoyle 1.10.0
TP-LINK Archer C7 v4 Gargoyle 1.11.x RC4

Trailblazer
Posts: 111
Joined: Wed Mar 09, 2011 3:12 am

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by Trailblazer »

This is from the April 22nd build...

root@Gargoyle:~# opkg list-installed | grep ath10k
kmod-ath10k - 3.18.23+2015-03-09-3-e1db6ee298665b84b93b7b84b72d3363
Netgear WNDR3700V2 Gargoyle 1.10.0
TP-LINK Archer C7 v4 Gargoyle 1.11.x RC4

Lantis
Moderator
Posts: 5588
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by Lantis »

So they recently split the ath10k firmware 3 ways. There's now a specific one for the Archer. If you just include it, it never fires up.
I'm wondering if you now need both.

Can I get an
"uci show wireless" from you on April 22?
Make sure you remove your password.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

ispyisail
Moderator
Posts: 4833
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by ispyisail »

No nukes, none of the food contains pesticides (or so I was told), beautiful scenery, mellow cool people. I really dug it.


I wouldn't be so sure about the pesticides statement. The rest sounds reasonable.

I wish I had picked up my C7 for tests now, sorry

Lantis
Moderator
Posts: 5588
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by Lantis »

I've got the Archer thing figured out (i think). Building now.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Lantis
Moderator
Posts: 5588
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by Lantis »

copy paste of my original post, because the same warnings apply. This time though, i think i've nailed the issue. new firmwares uploaded at the same location. 2016-05-22 06:34 last modified date.

---------------------------------------------------------------------------------------

@ all Archer C7 V2 users who experienced wifi issues with this build...

If you have time, please try out this build here:
http://lantisproject.com/gargoyle_ar71xx/testingbuilds/

Please do not preserve settings when upgrading to this version. The wifi config will break it. It is safe to create a backup and manually reapply all config files except for wifi config file.

If this build loads correctly and 5ghz wifi works + the GUI behaves as expected then i will push it to the main gargoyle code.

If it does not work as expected, then just downgrade back to the last known good version.

Please get back to me with any results good or bad.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

trance89
Posts: 12
Joined: Tue May 07, 2013 3:58 am

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by trance89 »

using this ispy build on my 841nd v8 for more than a week in wireless repeater mode (client bridge) and is working perfectly, main router is wdr3600 v1.5 with latest stable openwrt cc
not like latest official builds, they are full of bugs, official 1.9.0 bricks the 841 v8, the router is totally unusable after sysupgrade but after clean tftp recovery too (with factory gargoyle firm), the "stable" 1.8.1 wasn't stable in the same repeater mode, frequently lost connection to the main router and when i wanted to restore default config nothing happened, tried this 2 times after clean install
so this may12 build is much more stable than latest official builds, big thanks to ispy for these updated builds :)

calculoso
Posts: 32
Joined: Wed Mar 12, 2014 8:30 am

Re: gargoyle-ispy 2016-May-12 09:22.torrent

Post by calculoso »

@Lantis: Looks like it worked.

root@Gargoyle:~# opkg list-installed | grep ath10k
ath10k-firmware-qca988x - 2014-11-13-77f72b5f7dd940386d9e619a17904987759b7186-1
kmod-ath10k - 3.18.29+2016-01-10-1-3615c37379ca3162465671af3197f04b
root@Gargoyle:~#

Wireless config shows both 2.4ghz B+G+N and 5ghz A+N+AC

I'll monitor it for the next couple of days. The last debug build caused Wifi to not be on this morning, needing a power cycle of the router to come back (didn't try a reboot)

Post Reply