gargoyle-ispy 2015-November-18 08:37.torrent

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 5174
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby Lantis » Tue Nov 24, 2015 8:31 pm

https://github.com/lantis1008/gargoyle/ ... 1a19ecc917

Would love if someone would give this a look over and spot any mistakes.
If anyone wanted to give it a test that would be good too.

The main usage case i haven't been able to test is:
- single band wireless (no 5ghz)
- dual band wireless, without 802.11N on either band (does this exist?)


The configs that get written seem good, i didn't test bridge mode because people are still complaining that it isn't working properly anyway?
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

nworbnhoj
Posts: 914
Joined: Mon Jul 21, 2014 10:08 am
Location: Australia
Contact:

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby nworbnhoj » Wed Nov 25, 2015 3:58 am

Lantis wrote:https://github.com/lantis1008/gargoyle/ ... 1a19ecc917
Thats a lotta code!
I scp these 3 files directly into my WDR3600 and I see
2.4GHz Disabled, B+G, B+G+N with 20MHz, 40MHz above & below
5GHz Disabled, A, A+N with 20MHz, 40MHz above & below
I ran some superficial tests on a variety of wifi combinations.
There were no overt failures :-)
Can you help someone else get Gargoyle up and running?
TL-WDR3600 : Gargoyle 1.9.0 : NBN FixedWireless
TL-WR1043ND-V2 : Gargoyle 1.8.0 : 3G Huawei E160E

ispyisail
Moderator
Posts: 4702
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby ispyisail » Wed Nov 25, 2015 4:57 am

when you are ready i'll push a build

Lantis
Moderator
Posts: 5174
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby Lantis » Wed Nov 25, 2015 5:10 am

I have a HUGE presentation to make tomorrow, so maybe tomorrow afternoon I'll push it to Eric and let him take a look. If anyone will pick up on my stupidity it will be him lol.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

ralhabsi
Posts: 1
Joined: Wed Nov 25, 2015 9:11 am

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby ralhabsi » Wed Nov 25, 2015 9:49 am

The build seems to run faster than 1.7.2.
I copied the 3 files to my WDR3600 router. There seems to be a bug. All the options are visible but once I reselect the options the page is displayed correctly. I will try to Restore Default Configuration later and see if the bug exists.

Wireless Bridge/Repeater options are visible
Image

Other connect via type options are visible
Image

nworbnhoj
Posts: 914
Joined: Mon Jul 21, 2014 10:08 am
Location: Australia
Contact:

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby nworbnhoj » Wed Nov 25, 2015 2:20 pm

ralhabsi wrote:There seems to be a bug. All the options are visible but once I reselect the options the page is displayed correctly.
Probably because one of the new fields was not defined in your installation and it caused a browser error (try firefox - tools - webdeveloper - debugger). I saw a similar thing but I thought for a different reason (my copy error). It may be that a variable has not been initialised on properly on a new installation - or it may be be simply because we roughly inserted the files into a working installation and did not reboot
Can you help someone else get Gargoyle up and running?
TL-WDR3600 : Gargoyle 1.9.0 : NBN FixedWireless
TL-WR1043ND-V2 : Gargoyle 1.8.0 : 3G Huawei E160E

Lantis
Moderator
Posts: 5174
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby Lantis » Wed Nov 25, 2015 3:32 pm

Yep that happens when one of the new variables isn't defined.
I'd suggest clear cache and reload.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

darkfibre
Posts: 17
Joined: Mon Nov 09, 2015 10:35 am
Location: Christmas Island

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby darkfibre » Sat Nov 28, 2015 11:01 pm

I've noticed a few people on here are running the WRT1900AC.
I have set up one with 1.9.0 (For someone else) and its running ok.
I will be doing some work on it shortly and have 2 questions.

1.9.0 or 1.9.x recomendations please.
And can a config from 1.9.0 go straight back into 1.9.x?

Thanks.

Lantis
Moderator
Posts: 5174
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby Lantis » Sun Nov 29, 2015 12:21 am

configs are compatible.

i'd recommend my personal build available at http://lantisproject.com/gargoyle_mvebu/
which has the latest version of the wifi driver which is significantly more stable. It also includes the GUI changes discussed above.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

darkfibre
Posts: 17
Joined: Mon Nov 09, 2015 10:35 am
Location: Christmas Island

Re: gargoyle-ispy 2015-November-18 08:37.torrent

Postby darkfibre » Sun Nov 29, 2015 12:26 am

Thanks for that... Will give it a go..

Safe to restore config from 1.9.0?


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 3 guests