CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

ispyisail
Moderator
Posts: 4633
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby ispyisail » Mon Oct 19, 2015 2:45 pm

+1

Volaris
Posts: 163
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Tue Oct 20, 2015 11:13 am

It failed promptly overnight, so I wasn't able to see the log right away. Bunch of lines containing the following, though.

daemon.debug hostapd: wlan0: STA xx WPA: EAPOL-Key timeout
daemon.debug hostapd: wlan0: STA xx WPA: sending 1/4 msg of 4-Way Handshake
daemon.debug hostapd: wlan0: STA xx IEEE 802.1X: did not Ack EAPOL-Key frame (broadcast index=XX)

---

Does anyone know if the following line (A)

echo '0' > '/sys/kernel/debug/ieee80211/phy0/ath9k/ani'

should work exactly the same as the following? (B)

echo 0 >/sys/kernel/debug/ieee80211/phy0/ath9k/ani

Reason I ask is because searching with those error lines above led me to a bunch of threads with people with the same symptoms as my router. Seems like this issue has been widespread for the past few years with some fixes working for some but not others.

However, many recommend adding line B above to /etc/rc.local, however, upon checking I found line A was already there. Regardless, I changed it to line B and restarted.

Sources:
https://dev.openwrt.org/ticket/12372
https://dev.openwrt.org/ticket/15464
viewtopic.php?f=11&t=4667
viewtopic.php?f=11&t=5658
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Volaris
Posts: 163
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Thu Oct 22, 2015 12:06 am

The change above didn't fix it. Lasted 1 day 10 hours.

I've been reading into this and there's another person with a Buffalo router (among other people with other routers) who had the same issue here (also states it started after BB and not in AA):
https://dev.openwrt.org/ticket/16638

It was labeled a duplicate and told to follow the ticket here:
https://dev.openwrt.org/ticket/15464

Towards the end of that page, he posted it was fixed with the changes in 41815:
https://dev.openwrt.org/changeset/41815

Am I correct in thinking that stable Gargoyle 1.8 should have that implemented since it came out after that?
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Volaris
Posts: 163
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Sun Oct 25, 2015 12:07 pm

Volaris wrote:Does anyone know if the following line (A)

echo '0' > '/sys/kernel/debug/ieee80211/phy0/ath9k/ani'

should work exactly the same as the following? (B)

echo 0 >/sys/kernel/debug/ieee80211/phy0/ath9k/ani

Reason I ask is because searching with those error lines above led me to a bunch of threads with people with the same symptoms as my router. Seems like this issue has been widespread for the past few years with some fixes working for some but not others.

However, many recommend adding line B above to /etc/rc.local, however, upon checking I found line A was already there. Regardless, I changed it to line B and restarted.

Sources:
https://dev.openwrt.org/ticket/12372
https://dev.openwrt.org/ticket/15464
viewtopic.php?f=11&t=4667
viewtopic.php?f=11&t=5658

I tried switching:

echo '0' > '/sys/kernel/debug/ieee80211/phy0/ath9k/ani'

to:

echo 0 >/sys/kernel/debug/ieee80211/phy0/ath9k/ani

and it still failed after a day and a few hours.

But I removed any mention of them whatsoever from /etc/rc.local and this is the longest wireless has been stable for me:

Image

I'll keep it going until it reaches a week to see if that's the fix.

Apart from that, that doesn't fix the GUI issue on the connection page (where it defaults to BG wireless and changing to N or B doesn't affect the router at all [always broadcasts N] and GUI returns to BG).
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Volaris
Posts: 163
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Wed Oct 28, 2015 1:46 pm

Image

After nearly a week, I feel comfortable enough to say that removing the "disable ani" line from /etc/rc.local has fixed wireless stability issues on 1.8 (so maybe also on 1.7?). The line in there by default is:

echo '0' > '/sys/kernel/debug/ieee80211/phy0/ath9k/ani'

Deleting it, saving the file, and restarting the router worked. Perhaps it interfered with the ath9k fix (https://dev.openwrt.org/changeset/41815) provided to this problem (https://dev.openwrt.org/ticket/15464)? Might be a good thing to try on other ath9k routers if they suffer from this same problem.

Anywho, I've been itching to try 1.9 ever since the first release didn't work, so I felt it was a good time to move on to 1.9.

Image

It installed perfectly. The connections page no longer defaults wifi to BG - it only has BGN now. I went ahead and removed the disable ani line and restarted the router. :D

-----------
UPDATE

Image

Just to provide confirmation, I installed Gargoyle 1.9 and removed the ani line, and it ran perfectly for the past 13 days. So the fix seems to work 1.7 to 1.9 :D

As of 1.8.1 and 1.9 this has been fixed and you no longer have to edit or remove anything to disable ani. But if you're on any other build and want to remove the disable ani line, just use WinSCP to go to /etc/rc.local on your router and delete the following line from that file. Then reboot your router.
echo '0' > '/sys/kernel/debug/ieee80211/phy0/ath9k/ani'
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 3 guests