Email notifications plugin revisited

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Fredkup
Posts: 20
Joined: Sat Sep 19, 2015 8:55 pm

Re: Email notifications plugin revisited

Postby Fredkup » Fri Oct 16, 2015 7:19 pm

Thanks again Lantis, tried it from another Laptop with Firefox and it worked. Cleared all browsing data in Chrome and it also worked. Sometimes it pays to check the obvious first before digging into the program. Still no email in System menu but I can live with that.
Manfred

Lantis
Moderator
Posts: 5011
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Email notifications plugin revisited

Postby Lantis » Fri Oct 16, 2015 7:21 pm

Lol. Oh well we got there in the end. ;)

I'll post the code for you to add it to the menu manually.



uci set gargoyle.display.system_email_notifications="Email"
uci set gargoyle.scripts.system_email_notifications='email.sh'
uci set gargoyle.system.email_notifications='380'
uci commit
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

dpint
Posts: 32
Joined: Fri Oct 31, 2014 10:48 am

Re: Email notifications plugin revisited

Postby dpint » Mon Oct 19, 2015 3:13 am

There were some new fixes since I last posted in this thread. I have just uploaded new .ipks to a server. Install them or follow instructions Lantis posted above.

Swimmer
Posts: 40
Joined: Tue Mar 05, 2013 10:36 am

Re: Email notifications plugin revisited

Postby Swimmer » Wed Nov 11, 2015 9:58 am

How can i install this plugin without download?

I'm currently with few storage

I tried to add the homepage of ipk to the plugins (web) and do a opkg update but I cant seam to see the plugin to install
Proud owner of Tp-Link TL-WR1043N

dpint
Posts: 32
Joined: Fri Oct 31, 2014 10:48 am

Re: Email notifications plugin revisited

Postby dpint » Fri Nov 13, 2015 5:30 am

Swimmer wrote:How can i install this plugin without download?

I'm currently with few storage

I tried to add the homepage of ipk to the plugins (web) and do a opkg update but I cant seam to see the plugin to install


What do you mean by saying that you want to install this plugin without download? You can use wget to download it (wget -O /tmp/plugin.ipk urltoipk) and then use opkg to install it (opkg install /tmp/plugin.ipk).

darkfibre
Posts: 17
Joined: Mon Nov 09, 2015 10:35 am
Location: Christmas Island

Re: Email notifications plugin revisited

Postby darkfibre » Sat Nov 14, 2015 11:04 pm

Hi,
Newbie here. I have set up Email Notifications 1.0-1 via the plug ins menu.
Gargoyle Version:1.8.0
Model:TP-Link TL-WR1043N/ND v2

Server aspmx.l.google.com
Port 25 No auth

This server will accept ANY host as long as it send to a gmail.com address.

Test messages work just fine.
Scheduled messages do not.

Schedule:
Selected timer mode: daily schedule (every day is the same).
E-mail will be sent on - Daily at 09:15
E-mail will be sent on - Daily at 10:00
E-mail will be sent on - Daily at 11:00
E-mail will be sent on - Daily at 12:00

I've run out of ideas.

Thanks

Cliff

Swimmer
Posts: 40
Joined: Tue Mar 05, 2013 10:36 am

Re: Email notifications plugin revisited

Postby Swimmer » Sun Nov 15, 2015 3:53 pm

dpint wrote:
Swimmer wrote:How can i install this plugin without download?

I'm currently with few storage

I tried to add the homepage of ipk to the plugins (web) and do a opkg update but I cant seam to see the plugin to install


What do you mean by saying that you want to install this plugin without download? You can use wget to download it (wget -O /tmp/plugin.ipk urltoipk) and then use opkg to install it (opkg install /tmp/plugin.ipk).


Hello there,

If I download the plugin, I will not have space to install it. That is why i wanted to install without perform the download first.
Proud owner of Tp-Link TL-WR1043N

dpint
Posts: 32
Joined: Fri Oct 31, 2014 10:48 am

Re: Email notifications plugin revisited

Postby dpint » Tue Nov 17, 2015 4:56 am

@darkfibre

Look at the few posts I previously posted in this thread and install updated version of plugin.

@Swimmer

You can install it manually by creating files in the same folders as in the link below, although I don't think this will help you as you should have enough space in /tmp folder to download and install the package.

https://github.com/ericpaulbishop/gargo ... ions/files

greenidge
Posts: 1
Joined: Wed Nov 25, 2015 7:51 pm

Re: Email notifications plugin revisited

Postby greenidge » Fri Nov 27, 2015 8:23 pm

Did a lot of testing today but can't get the plugin to work. I flashed a WDR3600 with 1.81 and 1.9 and installed the non SSL plugin through plugin's menu and also did a manually via the instructions on this thread and the updated version from http://dpint.si/storage/gargoyle/plugin ... fications/ . I can get test messages to work to a local SMTP server but can't get any scheduled messages to send. I had no success with the SSL version on a test message on either of the routers or firmware versions. I also flashed a DIR825 with 1.81 and 1.9 and get the same behavior. I have done the installs with just a basic configuration on the routers ie no real configuration other then a PPPOE connection and then edited my local lan IP. It seems I should be able to get it work given others experience with 1.8 and 1.9 but am striking out on two routers.

darkfibre
Posts: 17
Joined: Mon Nov 09, 2015 10:35 am
Location: Christmas Island

Re: Email notifications plugin revisited

Postby darkfibre » Fri Nov 27, 2015 10:19 pm

greenidge wrote:Did a lot of testing today but can't get the plugin to work. I flashed a WDR3600 with 1.81 and 1.9 and installed the non SSL plugin through plugin's menu and also did a manually via the instructions on this thread and the updated version from http://dpint.si/storage/gargoyle/plugin ... fications/ . I can get test messages to work to a local SMTP server but can't get any scheduled messages to send. I had no success with the SSL version on a test message on either of the routers or firmware versions. I also flashed a DIR825 with 1.81 and 1.9 and get the same behavior. I have done the installs with just a basic configuration on the routers ie no real configuration other then a PPPOE connection and then edited my local lan IP. It seems I should be able to get it work given others experience with 1.8 and 1.9 but am striking out on two routers.


This in my experience on an UBNT airGateway with 1.8.1 with both the plugin, then the download on a clean flash. Will be trying it on another type of router soon. Tests emails work, but not sheduled ones.


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 1 guest