Gargoyle-images-06042014.7z

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: Gargoyle-images-06042014.7z

Postby DoesItMatter » Fri Jun 06, 2014 10:52 pm

I can post a trunk build of OpenWRT if anyone wants to see
whether or not it solves their wireless problems

I cannot post Trunk + Gargoyle - that would be WAY too much work
as Trunk (Barrier Breaker) and Attitude Adjustment are very different

If you are having wireless issues, you need to consider trying to
build your own Trunk builds and test, because if there are issues
with Trunk, then whenever Barrier Breaker goes Official, you
would still have wireless issues in newer Gargoyle versions.

Testing out Trunk now will let you know whether or not you
will have to stick with stock firmware for the foreseeable future.
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

pmerrill
Posts: 267
Joined: Wed Feb 15, 2012 8:23 pm

Re: Gargoyle-images-06042014.7z

Postby pmerrill » Sat Jun 07, 2014 3:52 am

Ok, status update, working for the last 10 hours, have not got syslog messages to confirm anything solid but so far it seems to be working.

I have included copies of the complete files where I made my changes to ispyisail's latest release (r40877). Names changed of course to protect the innocent.

/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option macaddr 'xx:xx:xx:xx:xx:xx'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option channel '1'
option htmode 'HT40+'
option distance 500

config wifi-device 'radio1'
option type 'mac80211'
option channel '36'
option hwmode '11na'
option macaddr 'xx:xx:xx:xx:xx:xx'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option htmode 'HT40+'
option distance 500

config wifi-iface 'ap_g'
option device 'radio0'
option mode 'ap'
option network 'lan'
option ssid 'downstairs'
option encryption 'psk2'
option disassoc_low_ack 0
option key 'xxxxxxxx'

config wifi-iface 'ap_a'
option device 'radio1'
option mode 'ap'
option network 'lan'
option ssid 'downstairs-5GHz'
option encryption 'psk2'
option disassoc_low_ack 0
option key 'xxxxxxxx'

With regard to the distance option, perhaps being a little aggressive but did not leave it at the default 2000. The option disassoc_low_ack 0 seems to be a key because when it's not there wifi does not work very well at all.

My /etc/rc.local file also looks as follows:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
echo 0 >/sys/kernel/debug/ieee80211/phy0/ath9k/ani
echo 0 >/sys/kernel/debug/ieee80211/phy1/ath9k/ani
exit 0

These two lines turn off ani for the 2.4GHz radio and the 5.0GHz radio.

Tomorrow, I will direct syslog output to my Synology NAS so I can see if it's really fixed the problem.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

TedEd1
Posts: 3
Joined: Mon Nov 12, 2012 4:58 am

Re: Gargoyle-images-06042014.7z

Postby TedEd1 » Sat Jun 07, 2014 6:55 am

I haven't tried Gargoyle in about a year. TP WDR4300 V1. Flashed current. Xbox 360 still crap on N. XBOX G works but not ideal.

tapper
Moderator
Posts: 1042
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Gargoyle-images-06042014.7z

Postby tapper » Sat Jun 07, 2014 11:02 am

Hi what is option disassoc_low_ack 0? thanks
TP-Link WR1043ND v2.1 Gargoyle 1.6.2
Western Digital My Net N750 Gargoyle 1.9x
TP-Link TL-WDR3600 V1.5 Gargoyle 1.9x
TP-Link Archer C7 Gargoyle 1.9x
Linksys WRT1900AC V2 Gargoyle 1.9x
Linksys WRT3200ACM LEDE 17.1

dieselz
Posts: 40
Joined: Fri Jun 07, 2013 3:39 am
Contact:

Re: Gargoyle-images-06042014.7z

Postby dieselz » Sat Jun 07, 2014 4:17 pm

pmerrill wrote:Ok, status update, working for the last 10 hours, have not got syslog messages to confirm anything solid but so far it seems to be working.

I have included copies of the complete files where I made my changes to ispyisail's latest release (r40877). Names changed of course to protect the innocent.

/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option macaddr 'xx:xx:xx:xx:xx:xx'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option channel '1'
option htmode 'HT40+'
option distance 500

config wifi-device 'radio1'
option type 'mac80211'
option channel '36'
option hwmode '11na'
option macaddr 'xx:xx:xx:xx:xx:xx'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option htmode 'HT40+'
option distance 500

config wifi-iface 'ap_g'
option device 'radio0'
option mode 'ap'
option network 'lan'
option ssid 'downstairs'
option encryption 'psk2'
option disassoc_low_ack 0
option key 'xxxxxxxx'

config wifi-iface 'ap_a'
option device 'radio1'
option mode 'ap'
option network 'lan'
option ssid 'downstairs-5GHz'
option encryption 'psk2'
option disassoc_low_ack 0
option key 'xxxxxxxx'

With regard to the distance option, perhaps being a little aggressive but did not leave it at the default 2000. The option disassoc_low_ack 0 seems to be a key because when it's not there wifi does not work very well at all.

My /etc/rc.local file also looks as follows:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
echo 0 >/sys/kernel/debug/ieee80211/phy0/ath9k/ani
echo 0 >/sys/kernel/debug/ieee80211/phy1/ath9k/ani
exit 0

These two lines turn off ani for the 2.4GHz radio and the 5.0GHz radio.

Tomorrow, I will direct syslog output to my Synology NAS so I can see if it's really fixed the problem.


THANK YOU!
its working better than i have ever seen on that router now thanks a million, hope it stays that way, will report anything new.
thank you.
**just want to report couple weird things, i set my channel to 7 and it shows on devices channel 1, the other thing is i didn't notice it at first but all my wireless devices are connected at exactly 11mbs.
also that amazing signal is back to normal now after an hour of dreamy signal and when i try to apply the channel hack it says "Unable to find regulatory rules (already patched?)" and when i reboot no channel 13 and the power still at 27dBm
TP-Link WDR4300 H/W Rev.1.6 Gargoyle-iSpy 1.9.x / Netgear WNDR4300 Gargoyle-iSpy 1.9.x

pmerrill
Posts: 267
Joined: Wed Feb 15, 2012 8:23 pm

Re: Gargoyle-images-06042014.7z

Postby pmerrill » Sat Jun 07, 2014 5:49 pm

tapper wrote:Hi what is option disassoc_low_ack 0? thanks


If the router does not get an ACK message back during the normal network chatter, then it will disconnect the client. That's one of the reasons why the clients are falling of the perch. This disables this feature, so missing ACKs do not cause disassociation.

It does not fix the problem of missing ACKs though..that's the real problem that needs to be fixed in OpenWRT. From trolling though the OpenWRT bug reports, it seems that trunk has this problem (BB) as well as AA, so until they fix their problem all we can do is patch settings.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

pmerrill
Posts: 267
Joined: Wed Feb 15, 2012 8:23 pm

Re: Gargoyle-images-06042014.7z

Postby pmerrill » Sat Jun 07, 2014 5:56 pm

i set my channel to 7 and it shows on devices channel 1, the other thing is i didn't notice it at first but all my wireless devices are connected at exactly 11mbs.


This is not good, 11Mbs indicates you are running in 11b mode. Are you sure you have the line:

Code: Select all

option hwmode '11ng'

in your settings.

The channel 7/1 thing is also curious. Don't think that should be happening. Perhaps post your settings from the Gargoyle settings page under Connections > Basic and we can have a look.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

dieselz
Posts: 40
Joined: Fri Jun 07, 2013 3:39 am
Contact:

Re: Gargoyle-images-06042014.7z

Postby dieselz » Sat Jun 07, 2014 6:09 pm

pmerrill wrote:
i set my channel to 7 and it shows on devices channel 1, the other thing is i didn't notice it at first but all my wireless devices are connected at exactly 11mbs.


This is not good, 11Mbs indicates you are running in 11b mode. Are you sure you have the line:

Code: Select all

option hwmode '11ng'

in your settings.

The channel 7/1 thing is also curious. Don't think that should be happening. Perhaps post your settings from the Gargoyle settings page under Connections > Basic and we can have a look.


i made sure i got that line and i did not go near it anyway, as for my router's settings at basic its very basic, i am downloading ispy's new release right now fingers crossed.
will report at his post.
Thank you.
TP-Link WDR4300 H/W Rev.1.6 Gargoyle-iSpy 1.9.x / Netgear WNDR4300 Gargoyle-iSpy 1.9.x

Eric
Site Admin
Posts: 1435
Joined: Sat Jun 14, 2008 1:14 pm

Re: Gargoyle-images-06042014.7z

Postby Eric » Sat Jun 07, 2014 7:37 pm

pmerrill -- Thank you for finding a workaround for some of the wifi issues people have reported. For some reason, I rarely if ever run into these issues on my own network so it's really hard to debug. You would think this would be a good thing, but not being able to reproduce (and therefore test potential solutions for) reported bugs is rather frustrating.

I would be curious about the independent effect of the disassoc_low_ack and the distance parameter are. I suspect that the disassoc_low_ack issue is the main culprit here -- if you remove the distance parameter so it goes back to the default but keep the dissassoc_low_ack parameter set to zero, what happens? Do you see a performance drop, or does everything continue to work properly?

I will update Gargoyle so this parameter gets set automatically in future versions of Gargoyle, to at least mitigate this problem, even if it's not a full solution.

dieselz
Posts: 40
Joined: Fri Jun 07, 2013 3:39 am
Contact:

Re: Gargoyle-images-06042014.7z

Postby dieselz » Sun Jun 08, 2014 3:01 pm

@pmerrill
is it possible to have that 11b mode i don't care if each devices gets equal 11mb but at least i get to have that amazing signal i had, if so what do i do?
TP-Link WDR4300 H/W Rev.1.6 Gargoyle-iSpy 1.9.x / Netgear WNDR4300 Gargoyle-iSpy 1.9.x


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 1 guest