Gargoyle-ispy 2013-May-02.7z

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

User avatar
powerlogy
Posts: 66
Joined: Wed Aug 22, 2012 12:04 pm
Location: Turkey

Re: Gargoyle-ispy 2013-May-02.7z

Post by powerlogy »

Swimmer wrote:
wwenigma wrote:Do you read forum? :)


Yes I do but I didn't understood that eric answer was for me.

@Everyone

Why is this happening (the multi-core problem)? Does anyone has a clue?

I don't know but i did a second rebuild with

Code: Select all

 num_build_threads=4
, yes i have quad core system.

Slacker
Posts: 55
Joined: Mon Aug 20, 2012 2:00 pm

Re: Gargoyle-ispy 2013-May-02.7z

Post by Slacker »

EDIT: Deleted retardness.
Building ar71xx with single-core modification in build.sh now.

Slacker
Posts: 55
Joined: Mon Aug 20, 2012 2:00 pm

Re: Gargoyle-ispy 2013-May-02.7z

Post by Slacker »

Building ar71xx on a Debian 6 VM box. Nothing has been modified in this box as far as build environment.
Fresh git clone. Makefile modified so distclean doesn't delete downloads. make distclean ran between builds, except after that 1st failed one.

make FULL_BUILD=true ar71xx.usb_large

Limiting to 1 thread works, but OMFG THE PAIN!
Unmodified build.sh fails.
After the multithreaded build bombs, make V=99 in ar71xx-src builds without error, same result as ispyisail.
Limiting to 4 threads fails.
Limiting to 2 threads fails.

Peculiar. I'm going to do some more playing, going back in openwrt builds.

Slacker
Posts: 55
Joined: Mon Aug 20, 2012 2:00 pm

Re: Gargoyle-ispy 2013-May-02.7z

Post by Slacker »

Well, that was fun.
Building with stock git pull, latest Gargoyle, using:
make FULL_BUILD=true ar71xx.usb_large

Here's the scoop:

36354 - works
36464 - works
36465 - works
36470 - fails
36472 - fails
36500 - fails
36599 - fails

So, something changed in 36470 that breaks multithreaded compiling of gargoyle.
Hope this helps pin it down.

manwinder
Posts: 11
Joined: Tue Feb 19, 2013 1:32 am

Re: Gargoyle-ispy 2013-May-02.7z

Post by manwinder »

has this fixed the xbox wireless issue with the tp link wdr4300, or is that a problem on the openwrt side, that they need to fix. Thanks :D

Post Reply