Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

pythonic
Posts: 87
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by pythonic »

Maniac wrote:Anyway, Lantis, your 1.13.X build is working fine after applying the CPU tweak. The only issue I'm having is that when I reboot the router, it can't see the
cable modem anymore. If I type "192.168.100.1" into the browser it can't find the modem and it's unable to get an IP address until I reboot the modem.
I recall reading an OpenWrt thread (which I now can't find :roll: ) in which reference was made to an issue specific to the EA8500 with resetting the switch during reboot as a result of a patch - commit of said patch had been reversed early in the 18.06 branch but not in master and the 19.07 branch until sometime in the last few weeks. I suspect the reversal was after 19.07-rc1 (which I understand would have been the base of the Lantis 1.13.x build you're now running) but before 19.07-rc2; if so this should be corrected when Lantis next updates his build.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

@Lantis: This is in DHCP (wired) mode @Lantis.

I noticed the 5 GHz wireless is not working on the 1.13.x build. 2.4 GHz wireless works. 5 GHz DID work on pythonic's 1.11.x build. (I didn't notice until now because I have multiple 5GHz APs).

@pythonic I never tried 1.11.0 with this specific router, but it works on my old WNDRMACv2.

I will try an OpenWrt Build.

And thanks for the info about the switch!

pythonic
Posts: 87
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by pythonic »

Maniac wrote:I noticed the 5 GHz wireless is not working on the 1.13.x build. 2.4 GHz wireless works. 5 GHz DID work on pythonic's 1.11.x build. (I didn't notice until now because I have multiple 5GHz APs).
Just an observation that 1.13.x should be using the ct radio driver and firmware, rather than the original ath10k driver/firmware used in 1.11.x/1.12. In principle this should be transparent, but maybe there are some problems still. If you tried the 160MHz bandwidth option (if that is showing), you might want to try 80MHz instead. I'm not sure whether the 160MHz support is there in the 19.07-rc1 base for that 1.13.x build.
Maniac wrote:@pythonic I never tried 1.11.0 with this specific router, but it works on my old WNDRMACv2.

I will try an OpenWrt Build.
If you want to try my 1.11.0 build for the EA8500 to see whether that has the problem as well, send me a PM listing the files you need and I'll find a way of getting them to you (I still have the build package but had to remove it from my website for space reasons).

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

Ohh! I figured out more about the wireless issue. On the 1.11.X build, I was using channel 100 (a DFS channel) which worked just fine. On the 1.13.X build, the *only* channel that transmits seems to be 36. If I choose 52 (DFS), 100 (DFS), or even 149 (a normal channel), nothing transmits.

I am using 80MHz, 160 does not show up.

Lantis
Moderator
Posts: 5998
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

Are you waiting for the CAC to complete? It won't transmit immediately.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

My router had been up for a while, it never transmitted. Also, note, it doesn't transmit on channel 149 either - which is not a DFS channel.

Lantis
Moderator
Posts: 5998
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

Would need a logread to understand if there's anything wrong
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

I can try to get that for you if you tell me where to look.

Lantis
Moderator
Posts: 5998
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

The easiest way is to connect to the command line for the router, then issue a "wifi" command (to reload the wifi).
Count to 60, then issue a "logread" command.

Copy and paste everything that comes back to me and we'll take a look.

Obviously as this reloads the wifi, best to do this over LAN
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

I sent you a PM, thanks!

Post Reply