Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 6023
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

Thanks, can you also please provide

Code: Select all

cat /etc/config/wireless
And

Code: Select all

iw phy0 info
iw phy1 info
and

Code: Select all

iw reg get
and

Code: Select all

cat /tmp/cached_basic_vars
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

Sure, I'll do that this afternoon.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

PM sent

Lantis
Moderator
Posts: 6023
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

From the looks of things, your router is just following the regulatory rules it thinks are being enforced:

Code: Select all

Frequencies:
    * 5180 MHz [36] (20.0 dBm)
    * 5200 MHz [40] (20.0 dBm)
    * 5220 MHz [44] (20.0 dBm)
    * 5240 MHz [48] (20.0 dBm)
    * 5260 MHz [52] (20.0 dBm) (no IR, radar detection)
    * 5280 MHz [56] (20.0 dBm) (no IR, radar detection)
    * 5300 MHz [60] (20.0 dBm) (no IR, radar detection)
    * 5320 MHz [64] (20.0 dBm) (no IR, radar detection)
    * 5500 MHz [100] (20.0 dBm) (no IR, radar detection)
    * 5520 MHz [104] (20.0 dBm) (no IR, radar detection)
    * 5540 MHz [108] (20.0 dBm) (no IR, radar detection)
    * 5560 MHz [112] (20.0 dBm) (no IR, radar detection)
    * 5580 MHz [116] (20.0 dBm) (no IR, radar detection)
    * 5600 MHz [120] (20.0 dBm) (no IR, radar detection)
    * 5620 MHz [124] (20.0 dBm) (no IR, radar detection)
    * 5640 MHz [128] (20.0 dBm) (no IR, radar detection)
    * 5660 MHz [132] (20.0 dBm) (no IR, radar detection)
    * 5680 MHz [136] (20.0 dBm) (no IR, radar detection)
    * 5700 MHz [140] (20.0 dBm) (no IR, radar detection)
    * 5720 MHz [144] (20.0 dBm) (no IR, radar detection)
    * 5745 MHz [149] (20.0 dBm) (no IR)
    * 5765 MHz [153] (20.0 dBm) (no IR)
    * 5785 MHz [157] (20.0 dBm) (no IR)
    * 5805 MHz [161] (20.0 dBm) (no IR)
    * 5825 MHz [165] (20.0 dBm) (no IR)
    * 5845 MHz [169] (disabled)
    * 5865 MHz [173] (disabled)
no IR means "No initiate radiation", which means you can't transmit on that channel... UNLESS... your router spots another AP already transmitting on that channel.
The idea is that it's like a "world roaming" profile that tries to follow what other routers say is "ok".

There probably needs to be an enhancement to Gargoyle to not show you those channels too... but it's a bit weird.

Anyway, i think the real issue here is that your country code should be set to your actual country instead of "00". So lets try that. Do you know your country code, and how to set it?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

I'm in the US, and I think the code is just "US", but I don't know how to set it.

It's funny you mention that, in 1.11.X, there was a dropdown to select the country in the WiFi section. 1.13.X doesn't have that.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

I'm going to look at this more, but I set the country to "US" via "iw reg set US", but the wifi still won't work on channel 149.

Lantis
Moderator
Posts: 6023
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

Need to set it in your wifi config as well.

Code: Select all

uci set wireless.radio0.country='US'
uci set wireless.radio1.country='US'
uci commit wireless
wifi
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Maniac
Posts: 72
Joined: Wed Sep 02, 2009 7:52 pm

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Maniac »

Yes, just figured that out. I was not aware of those commands. I manually edited /etc/config/wireless to set the country code to 'US'.

Now both channels 100 & 149 work, thanks! So it appears the root issue is that the country code selection is not showing up in the UI.

Thank you for your help!

boldga
Posts: 21
Joined: Sat Sep 18, 2010 10:05 am

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by boldga »

I also found this kind of reboot problem on R7800, but I wasn't aware that it's a software problem until i saw Maniac's post.

after many tests, Now I can reboot my R7800 at least in two ways:
1. I use anydesk(http://www.anydesk.com) to remote control PCs. after I enable the option "Search local network for other anydesk clients" and then use it to connect to another PC within local network, router reboot.

2. when I use Edge to browse this website: https://www.retailmenot.com/view/aliexpress.com,
and then click any link of "get deal" or "show coupon code", router reboot.

I think this bug maybe relate to the NAT loopback not fully supported problom I mentioned here:
viewtopic.php?f=14&t=11988&p=54523&hili ... lly#p54523

because these two bugs have same pattern:
a. They only happen on DHCP mode,not on PPPoE mode.
b. They only happen on wired devices, not on wireless devices.

Lantis
Moderator
Posts: 6023
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.12.0 for ipq806x architecture routers

Post by Lantis »

Maniac wrote:Yes, just figured that out. I was not aware of those commands. I manually edited /etc/config/wireless to set the country code to 'US'.

Now both channels 100 & 149 work, thanks! So it appears the root issue is that the country code selection is not showing up in the UI.

Thank you for your help!
So the way it is supposed to work is on first boot Gargoyle tries to detect what country you are from and offer that option. If it can't detect it, the option isn't provided. Once you pick one, the option is gone (pick once to avoid abuse).
Since yours was unknowingly/manually/otherwise set to 00, even if Gargoyle figured out you were in the US it was never going to ask you again.

Just an unfortunate edge case in the protection. Know a bit more about what to look for now.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply