1.11.0.x gargoyle-ispy 2019-April-05 01

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

ispyisail
Moderator
Posts: 4678
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

1.11.0.x gargoyle-ispy 2019-April-05 01

Postby ispyisail » Sat Apr 06, 2019 4:30 pm

USE AT YOUR OWN RISK

WARNING: DO NOT PRESERVE SETTINGS

Now includes packages

Do not install on 4MB routers

1.11.0.x gargoyle-ispy 2019-April-05 01
Torrent
http://bit.ly/2uNszqp

magnet:?xt=urn:btih:8214b2ba651f253043f3f4e896a81753be378b82&dn=1.11.0.x%20gargoyle-ispy%202019-April-05%2001.7z&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80&tr=udp%3a%2f%2fopen.demonii.com%3a1337&tr=udp%3a%2f%2ftracker.coppersurfer.tk%3a6969&tr=udp%3a%2f%2ftracker.leechers-paradise.org%3a6969&tr=udp%3a%2f%2ftracker.coppersurfer.tk%3a6969%2fannounce&tr=udp%3a%2f%2ftracker.open-internet.nl%3a6969%2fannounce&tr=udp%3a%2f%2fallesanddro.de%3a1337%2fannounce&tr=udp%3a%2f%2f9.rarbg.to%3a2710%2fannounce


Routers
http://bit.ly/2uPDVKj

Changelog
(see creation date for commit date)

https://github.com/ericpaulbishop/gargo ... its/master

edu
Posts: 41
Joined: Fri Jun 20, 2014 4:09 am

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby edu » Sun Apr 07, 2019 8:12 pm

46 views, no comment!
What's up with you people?
Flashing in the morning and reporting, hope it will be as stable as previous build.

Thank you ispy!

edu
Posts: 41
Joined: Fri Jun 20, 2014 4:09 am

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby edu » Sun Apr 07, 2019 11:16 pm

TP-Link TL-WDR4300 v1 flashed successfuly.
After a reboot, plugins where detected but not loaded.
They appear as installed but they're not functional - uninstalled and reinstalled them and everything seens fine to me.

Lantis
Moderator
Posts: 5130
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby Lantis » Mon Apr 08, 2019 1:28 am

Is this using an external plugin root?
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

RomanHK
Posts: 436
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby RomanHK » Mon Apr 08, 2019 3:39 am

edu wrote:They appear as installed but they're not functional - uninstalled and reinstalled them and everything seens fine to me.
Lantis wrote:Is this using an external plugin root?

This happens using backup before installing plugins.
Turris Omnia with Gargoyle 1.11.X (1.13.X in test mode)
Linksys WRT3200ACM with Gargoyle 1.11.X
TL-WR1043ND v2 with Gargoyle 1.10.0

Lantis
Moderator
Posts: 5130
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby Lantis » Mon Apr 08, 2019 4:07 am

That doesn’t make sense, nor is it what I have experienced.
Do you have more details? A set of steps that guarantee the bug every single time?
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

RomanHK
Posts: 436
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby RomanHK » Mon Apr 08, 2019 5:07 am

Lantis wrote:That doesn’t make sense, nor is it what I have experienced.
Do you have more details? A set of steps that guarantee the bug every single time?

At the moment, I can't simulate it. It has happened to me a couple of times. :oops: Sorry. In time, I'll find out why.
Turris Omnia with Gargoyle 1.11.X (1.13.X in test mode)
Linksys WRT3200ACM with Gargoyle 1.11.X
TL-WR1043ND v2 with Gargoyle 1.10.0

RomanHK
Posts: 436
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby RomanHK » Mon Apr 08, 2019 8:25 am

The problem is located in the /etc/config/gargoyle file.
Testing done in Czech localization
1) Installing "Webshell"
2) Backup made
3) Uninstall "Webshell" Plugin
4) Recovery from backup
The "Webshell" plugin appears to be installed but not physically.
Screenshot made after restoring backup:
Image
Turris Omnia with Gargoyle 1.11.X (1.13.X in test mode)
Linksys WRT3200ACM with Gargoyle 1.11.X
TL-WR1043ND v2 with Gargoyle 1.10.0

Lantis
Moderator
Posts: 5130
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby Lantis » Mon Apr 08, 2019 8:38 am

Thank you. I’ll look at it later.
This is how the bug reports need to be.

I need to be able to reproduce them on my end or I can’t fix them.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

edu
Posts: 41
Joined: Fri Jun 20, 2014 4:09 am

Re: 1.11.0.x gargoyle-ispy 2019-April-05 01

Postby edu » Mon Apr 08, 2019 9:54 pm

Lantis wrote:Is this using an external plugin root?

Yes!

"This happens using backup before installing plugins."
Flashed as instructed, settings not preserved.


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 4 guests