[BROKEN] Gargoyle 1.11.0 Release Candidate 3

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 5137
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Thu Nov 15, 2018 5:55 am

Can you check that gpkg info | grep kmod-video-uvc shows up a result?
It may also be worth while re-flashing the new copy of the firmware i uploaded to the same directory, then re-adding both repositories and checking the same.


As much as i'd rather not work on this stuff, it is important because it determines my approach to keeping the smaller devices alive. Thanks for continuing to test.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

buggers
Posts: 22
Joined: Mon Jan 30, 2012 7:47 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby buggers » Thu Nov 15, 2018 6:23 am

This is what I get:

Code: Select all

root@Gargoyle:~# gpkg info | grep kmod-video-uvc
Package: kmod-video-uvc
Filename: kmod-video-uvc_4.9.125-1-c8e7bd8a83b3c3f3bf94d022b73aaf8b_mips_24kc.ipk
Depends: libc, gargoyle, gargoyle-mjpg-streamer, kmod-video-core, kmod-video-gspca-core, kmod-video-uvc, kmod-video-gspca-zc3xx, kmod-video-gspca-ov534


I will re-flash

Code: Select all

http://lantisproject.com/gargoyle_1.11.x_rc4/ar71xx/gargoyle_1.11.x-ar71xx-generic-wndr3700-squashfs-sysupgrade.bin

without keeping my current configuration and report my findings with both repositories added.

Waterspuwer
Posts: 32
Joined: Mon Nov 12, 2018 6:04 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Waterspuwer » Thu Nov 15, 2018 8:15 am

danielwritesback wrote:You may have heard some negative. However, what you have accomplished amazes me far beyond my ability to express gratitude. Had someone told me that a mid level atheros could do low lag routinely and that QOS would be easy to do, I'd never believed it. Yet you have done it already.
I think it likely that there could be some flack when doing a large amount of impossible things graciously. In such case, what should be the concentration is going forth with even more well working impossible things. That is an epic delight.

I agree, it's a lovely firmware, finally no need to worry about family downloading while I'm playing a game. My normal ping is ~15ms, when someone is now downloading, it's usually 30-35ms, so perfectly playable. Without Gargoyle it was 300-500ms and unplayable.

Lantis
Moderator
Posts: 5137
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Thu Nov 15, 2018 8:18 am

buggers wrote:This is what I get:

Code: Select all

root@Gargoyle:~# gpkg info | grep kmod-video-uvc
Package: kmod-video-uvc
Filename: kmod-video-uvc_4.9.125-1-c8e7bd8a83b3c3f3bf94d022b73aaf8b_mips_24kc.ipk
Depends: libc, gargoyle, gargoyle-mjpg-streamer, kmod-video-core, kmod-video-gspca-core, kmod-video-uvc, kmod-video-gspca-zc3xx, kmod-video-gspca-ov534


I will re-flash

Code: Select all

http://lantisproject.com/gargoyle_1.11.x_rc4/ar71xx/gargoyle_1.11.x-ar71xx-generic-wndr3700-squashfs-sysupgrade.bin

without keeping my current configuration and report my findings with both repositories added.


I was able to try this and got it working.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

buggers
Posts: 22
Joined: Mon Jan 30, 2012 7:47 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby buggers » Thu Nov 15, 2018 8:52 am

Lantis wrote:
buggers wrote:This is what I get:

Code: Select all

root@Gargoyle:~# gpkg info | grep kmod-video-uvc
Package: kmod-video-uvc
Filename: kmod-video-uvc_4.9.125-1-c8e7bd8a83b3c3f3bf94d022b73aaf8b_mips_24kc.ipk
Depends: libc, gargoyle, gargoyle-mjpg-streamer, kmod-video-core, kmod-video-gspca-core, kmod-video-uvc, kmod-video-gspca-zc3xx, kmod-video-gspca-ov534


I will re-flash

Code: Select all

http://lantisproject.com/gargoyle_1.11.x_rc4/ar71xx/gargoyle_1.11.x-ar71xx-generic-wndr3700-squashfs-sysupgrade.bin

without keeping my current configuration and report my findings with both repositories added.


I was able to try this and got it working.


Not much improvement I am afraid:

Code: Select all

root@Gargoyle:~# gpkg update
Downloading package list for openwrt_18.06-snapshot_telephony source...
Package list for openwrt_18.06-snapshot_telephony downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_routing source...
Package list for openwrt_18.06-snapshot_routing downloaded successfully.

Downloading package list for gargoyle_1-11-x_rc4_ar71xx_usb_large_kernelspecific source...
Package list for gargoyle_1-11-x_rc4_ar71xx_usb_large_kernelspecific downloaded successfully.

Downloading package list for gargoyle source...
Package list for gargoyle downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_packages source...
Package list for openwrt_18.06-snapshot_packages downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_base source...
Package list for openwrt_18.06-snapshot_base downloaded successfully.

Downloading package list for gargoyle_1-11-x_rc4_ar71xx_usb source...
Package list for gargoyle_1-11-x_rc4_ar71xx_usb downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_management source...
Package list for openwrt_18.06-snapshot_management downloaded successfully.

root@Gargoyle:~# gpkg info plugin-gargoyle-webcam
Package: plugin-gargoyle-webcam
Version: 20130630-1
Install-Destination: Not Installed
SHA256sum: 7f007397f88e0f5b6e7740ed3b5342b7d650f72b73c584340d700ab0b7c0e3bb
Size: 6076
Installed-Size: 5111
Description: Webcam Support for Gargoyle
Architecture: mips_24kc
Source-ID: gargoyle_1-11-x_rc4_ar71xx_usb
Section: admin
Filename: plugin-gargoyle-webcam_20130630-1_mips_24kc.ipk
Status: unknown ok not-installed
Depends: libc, gargoyle, gargoyle-mjpg-streamer, kmod-video-core, kmod-video-gspca-core, kmod-video-uvc, kmod-video-gspca-zc3xx, kmod-video-gspca-ov534

root@Gargoyle:~#  gpkg install plugin-gargoyle-webcam
ERROR: Dependency kmod-video-uvc of package plugin-gargoyle-webcam cannot be found, try updating your package lists


Anything else you might like me to try out?

doug_porsche
Posts: 65
Joined: Fri Aug 16, 2013 3:59 pm

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby doug_porsche » Thu Nov 15, 2018 10:46 am

Thank you.
I just upgraded my NETGEAR WNDR3700v from rc2 to rc4, preserving, and installed the plugins using http://lantisproject.com/gargoyle_1.11. ... arge_nand/
this let me install the adblock plug in.

No drama, the little blue box seems to be working great, as usual.

I will update if with news if there is any.

Thanks again!
NETGEAR WNDR3700v4 or an old Soup can with string. So hard to tell these days.

Lantis
Moderator
Posts: 5137
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Thu Nov 15, 2018 4:09 pm

You are mixing up your repos.
You’ve got USB for one and USB large for the other.
They must be exactly the same, and must match your device.
Both should be USB
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

buggers
Posts: 22
Joined: Mon Jan 30, 2012 7:47 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby buggers » Thu Nov 15, 2018 5:43 pm

Lantis wrote:
buggers wrote:Followed your advice Lantis and the plugin list is now fully populated; no reboot was necessary in order to get:

Code: Select all

root@Gargoyle:~# ls -RlX /usr/lib/opkg/
/usr/lib/opkg/:
drwxr-xr-x    2 root     root           270 Sep  7 18:22 info
-rw-r--r--    1 root     root         52758 Sep  7 18:22 status

/usr/lib/opkg/info:
-rw-r--r--    1 root     root            38 Sep  7 18:22 dnsmasq.control
-rw-r--r--    1 root     root          1407 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.list
-rw-r--r--    1 root     root           352 Sep  7 18:22 plugin-gargoyle-usb-storage-noshare.list
-rwxr-xr-x    1 root     root           355 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.postrm
-rwxr-xr-x    1 root     root           117 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.prerm
-rwxr-xr-x    1 root     root           117 Sep  7 18:22 plugin-gargoyle-usb-storage-noshare.prerm


When I unsuccessfully attempted to install:

Code: Select all

Webcam Support for Gargoyle
Version: 20130630-1
Status: Not Installed
Required Disk Space: 99.174 kBytes

I noticed the following log entry:

Code: Select all

daemon.err uhttpd[1866]: ERROR: Dependency kmod-video-uvc of package plugin-gargoyle-webcam cannot be found, try updating your package lists

Perhaps a LEDE/OpenWRT glitch?

Nevertheless, I would like to sincerely thank you for your invaluable contribution; my nine-year-old router feels brand new thanks to Gargoyle!


Try adding this one as a plugin repository as well:
http://lantisproject.com/gargoyle_1.11. ... elspecific
Hopefully that fixes your issue.

(note that if you read this in the next 5 minutes it will still be uploading, so hopefully you're not that quick).


I used the repository suggested above :?
After replacing it with the appropriate repository, I got:

Code: Select all

root@Gargoyle:~# gpkg info plugin-gargoyle-webcam
Package: plugin-gargoyle-webcam
Version: 20130630-1
User-Installed: true
Install-Destination: root
SHA256sum: 7f007397f88e0f5b6e7740ed3b5342b7d650f72b73c584340d700ab0b7c0e3bb
Source: package/plugin-gargoyle-webcam
Size: 6076
Maintainer: Cezary Jackiewicz <cezary@eko.one.pl>
Installed-Size: 5111
Link-Destination:
Installed-Time: 1542316608
Provides:
Description: Webcam Support for Gargoyle
Architecture: mips_24kc
Source-ID: gargoyle_1-11-x_rc4_ar71xx_usb
Section: admin
Filename: plugin-gargoyle-webcam_20130630-1_mips_24kc.ipk
Status: install user installed
Depends: libc, gargoyle, gargoyle-mjpg-streamer, kmod-video-core, kmod-video-gspca-core, kmod-video-uvc, kmod-video-gspca-zc3xx, kmod-video-gspca-ov534

No more error messages ;)

Lantis
Moderator
Posts: 5137
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Thu Nov 15, 2018 6:08 pm

Sorry I forgot which device you were using. Thought it was in the other category.
Glad it works for you now.

I encourage all users to list their primary router in their signature for my sake ;) haha.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

bluegravy
Posts: 29
Joined: Mon Jul 10, 2017 12:50 pm
Location: Eastern Panhandle West Virginia, USA

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby bluegravy » Thu Nov 15, 2018 6:45 pm

I just upgraded my device to gargoyle_1.11.x-x86-64-combined-ext4.img and am experiencing the same issue with plugins seeming to install but do not. I have added http://lantisproject.com/gargoyle_1.11.x_rc3/x86/x64 as the repository.

I get the same error as Buggers got on the CLI.

This is running on a Dell 64-bit PC.

-Andy


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 18 guests